aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2018-11-23 18:22:16 +0000
committerLarry Rosenman <ler@FreeBSD.org>2018-11-23 18:22:16 +0000
commit3f50049b458318441ce868840ec322726fee0083 (patch)
tree42b75b3dd6d9fd46b2e4dfe0d05a59af8a704b81 /mail/dovecot
parentd3837a6b28e5677898e21a3be3013af0a72ae380 (diff)
downloadports-3f50049b458318441ce868840ec322726fee0083.tar.gz
ports-3f50049b458318441ce868840ec322726fee0083.zip
mail/dovecot: pick up patch from upstream to quiet format warnings.
Notes
Notes: svn path=/head/; revision=485697
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile1
-rw-r--r--mail/dovecot/files/patch-src_lib-master_test-event-stats.c67
2 files changed, 67 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index d878ab756725..5dc59c8f53f1 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dovecot
PORTVERSION= 2.3.4
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/2.3/
diff --git a/mail/dovecot/files/patch-src_lib-master_test-event-stats.c b/mail/dovecot/files/patch-src_lib-master_test-event-stats.c
index b4bf3f5b3f9b..3db95099a641 100644
--- a/mail/dovecot/files/patch-src_lib-master_test-event-stats.c
+++ b/mail/dovecot/files/patch-src_lib-master_test-event-stats.c
@@ -1,4 +1,4 @@
---- src/lib-master/test-event-stats.c.orig 2018-11-23 14:47:35 UTC
+--- src/lib-master/test-event-stats.c.orig 2018-11-23 11:06:49 UTC
+++ src/lib-master/test-event-stats.c
@@ -12,6 +12,7 @@
#include "stats-client.h"
@@ -8,3 +8,68 @@
#include <unistd.h>
#include <sys/socket.h>
#include <sys/un.h>
+@@ -360,7 +361,7 @@ static void test_no_merging2(void)
+ event_unref(&child_ev);
+ test_assert(
+ compare_test_stats_to(
+- "EVENT %lu 1 0 0"
++ "EVENT %"PRIu64" 1 0 0"
+ " stest-event-stats.c %d"
+ " l0 0 ctest2\n", id, l));
+ test_end();
+@@ -386,12 +387,12 @@ static void test_no_merging3(void)
+ event_unref(&child_ev);
+ test_assert(
+ compare_test_stats_to(
+- "BEGIN %lu 0 1 0 0"
++ "BEGIN %"PRIu64" 0 1 0 0"
+ " stest-event-stats.c %d ctest1\n"
+- "EVENT %lu 1 1 0"
++ "EVENT %"PRIu64" 1 1 0"
+ " stest-event-stats.c %d"
+ " l1 0 ctest2\n"
+- "END\t%lu\n", idp, lp, idp, l, idp));
++ "END\t%"PRIu64"\n", idp, lp, idp, l, idp));
+ test_end();
+ }
+
+@@ -451,7 +452,7 @@ static void test_merge_events2(void)
+ event_unref(&merge_ev2);
+ test_assert(
+ compare_test_stats_to(
+- "EVENT %lu 1 0 0"
++ "EVENT %"PRIu64" 1 0 0"
+ " stest-event-stats.c %d l0 0"
+ " ctest3 ctest2 ctest1 Tkey3"
+ " 10 0 Ikey2 20"
+@@ -483,11 +484,11 @@ static void test_skip_parents(void)
+ event_unref(&child_ev);
+ test_assert(
+ compare_test_stats_to(
+- "BEGIN %lu 0 1 0 0"
++ "BEGIN %"PRIu64" 0 1 0 0"
+ " stest-event-stats.c %d ctest1\n"
+- "EVENT %lu 1 3 0 "
++ "EVENT %"PRIu64" 1 3 0 "
+ "stest-event-stats.c %d l3 0"
+- " ctest2\nEND\t%lu\n", id, lp, id, l, id));
++ " ctest2\nEND\t%"PRIu64"\n", id, lp, id, l, id));
+ test_end();
+ }
+
+@@ -525,12 +526,12 @@ static void test_merge_events_skip_parents(void)
+ event_unref(&child2_ev);
+ test_assert(
+ compare_test_stats_to(
+- "BEGIN %lu 0 1 0 0"
++ "BEGIN %"PRIu64" 0 1 0 0"
+ " stest-event-stats.c %d ctest1\n"
+- "EVENT %lu 1 3 0 "
++ "EVENT %"PRIu64" 1 3 0 "
+ "stest-event-stats.c %d l3 0 "
+ "ctest4 ctest5 Tkey3 10 0 Skey4"
+- " str4\nEND\t%lu\n", id, lp, id, l, id));
++ " str4\nEND\t%"PRIu64"\n", id, lp, id, l, id));
+ test_end();
+ }
+