aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2019-01-06 17:46:53 +0000
committerLarry Rosenman <ler@FreeBSD.org>2019-01-06 17:46:53 +0000
commita6885ac1ef7b1602378b13250c8232d7cd7da814 (patch)
treebb6e0eebb38c5fcac02d1172a078f42028ad8c1d /mail/dovecot
parent57a107b8ab19603582e4fb982bda7d8e97058764 (diff)
downloadports-a6885ac1ef7b1602378b13250c8232d7cd7da814.tar.gz
ports-a6885ac1ef7b1602378b13250c8232d7cd7da814.zip
mail/dovecot: Pick up mailing list patch for imap-preauth vs. stats-writer.
see the dovecot mailing list thread on imap-preauth and stats-writer between Stephan Bosch and a FreeBSD user Obtained from: upstream mailing list.
Notes
Notes: svn path=/head/; revision=489515
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/files/patch-src_lib-master_master-service.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index e46fa24bfefc..3d24c3c3cf76 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dovecot
PORTVERSION= 2.3.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/2.3/
diff --git a/mail/dovecot/files/patch-src_lib-master_master-service.c b/mail/dovecot/files/patch-src_lib-master_master-service.c
new file mode 100644
index 000000000000..df780b4b1847
--- /dev/null
+++ b/mail/dovecot/files/patch-src_lib-master_master-service.c
@@ -0,0 +1,11 @@
+--- src/lib-master/master-service.c.orig 2019-01-06 17:42:52 UTC
++++ src/lib-master/master-service.c
+@@ -341,7 +341,7 @@ master_service_init(const char *name, enum master_serv
+ if ((flags & MASTER_SERVICE_FLAG_DONT_SEND_STATS) == 0) {
+ /* Initialize stats-client early so it can see all events. */
+ value = getenv(DOVECOT_STATS_WRITER_SOCKET_PATH);
+- if (value != NULL)
++ if (value != NULL && *value = '\0')
+ service->stats_client = stats_client_init(value, FALSE);
+ }
+