aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2019-07-12 19:22:09 +0000
committerLarry Rosenman <ler@FreeBSD.org>2019-07-12 19:22:09 +0000
commita9892b4b7b04282a93ff347050f711c1063eb852 (patch)
tree82c0ede4027c9ee87b0bbce9dc422d607964d079 /mail/dovecot
parent749ad53216c722f7bd9215d67f9305fe3d6e6029 (diff)
downloadports-a9892b4b7b04282a93ff347050f711c1063eb852.tar.gz
ports-a9892b4b7b04282a93ff347050f711c1063eb852.zip
mail/dovecot: stop spamming the log with EINVAL.
PR: 239172 Submitted by: zillion1@o2.pl Obtained from: dovecot mailing list.
Notes
Notes: svn path=/head/; revision=506487
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile1
-rw-r--r--mail/dovecot/files/patch-src_lib_ostream-file.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 3503b053762a..5445ff5cc470 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dovecot
PORTVERSION= 2.3.7
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= https://dovecot.org/releases/2.3/
diff --git a/mail/dovecot/files/patch-src_lib_ostream-file.c b/mail/dovecot/files/patch-src_lib_ostream-file.c
new file mode 100644
index 000000000000..5c3cc5daba69
--- /dev/null
+++ b/mail/dovecot/files/patch-src_lib_ostream-file.c
@@ -0,0 +1,11 @@
+--- src/lib/ostream-file.c.orig 2019-07-12 19:18:41 UTC
++++ src/lib/ostream-file.c
+@@ -334,7 +334,7 @@ static void o_stream_tcp_flush_via_nodelay(struct file
+ {
+ if (net_set_tcp_nodelay(fstream->fd, TRUE) < 0) {
+ if (errno != ENOTSUP && errno != ENOTSOCK &&
+- errno != ENOPROTOOPT) {
++ errno != ENOPROTOOPT && errno != EINVAL) {
+ i_error("file_ostream.net_set_tcp_nodelay(%s, TRUE) failed: %m",
+ o_stream_get_name(&fstream->ostream.ostream));
+ }