aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2019-07-23 14:26:56 +0000
committerLarry Rosenman <ler@FreeBSD.org>2019-07-23 14:26:56 +0000
commitbec604d83540908e69ca948ab0feb18642014f8a (patch)
tree64d987e75cab9a3969bdb1816971a17f75dc08b1 /mail/dovecot
parent6453b65dc5ac5dc6fc044473b22f886971dbb9e0 (diff)
downloadports-bec604d83540908e69ca948ab0feb18642014f8a.tar.gz
ports-bec604d83540908e69ca948ab0feb18642014f8a.zip
mail/dovecot, mail/dovecot-pigeonhole: upgrade to 2.3.7.1 and 0.5.7.1 respectively.
These releases fix the reported regressions in v2.3.7 & v0.5.7. Dovecot core: - Fix TCP_NODELAY errors being logged on non-Linux OSes - lmtp proxy: Fix assert-crash when client uses BODY=8BITMIME - Remove wrongly added checks in namespace prefix checking Pigeonhole: - dsync: Sieve script syncing failed if mailbox attributes weren't enabled.
Notes
Notes: svn path=/head/; revision=507215
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile3
-rw-r--r--mail/dovecot/distinfo6
-rw-r--r--mail/dovecot/files/patch-src_lib-storage_mail-storage.c35
-rw-r--r--mail/dovecot/files/patch-src_lib_ostream-file.c29
4 files changed, 4 insertions, 69 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 4a4f73b9790e..45e63dcec97c 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -7,8 +7,7 @@
######################################################################
PORTNAME= dovecot
-PORTVERSION= 2.3.7
-PORTREVISION= 4
+PORTVERSION= 2.3.7.1
CATEGORIES= mail ipv6
MASTER_SITES= https://dovecot.org/releases/2.3/
diff --git a/mail/dovecot/distinfo b/mail/dovecot/distinfo
index de00e8511cd5..679bd62996c1 100644
--- a/mail/dovecot/distinfo
+++ b/mail/dovecot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1562935512
-SHA256 (dovecot-2.3.7.tar.gz) = 11e156ae8539e42892809cc2412c3f1a294188806969f5547191a43abd4083aa
-SIZE (dovecot-2.3.7.tar.gz) = 7074117
+TIMESTAMP = 1563891542
+SHA256 (dovecot-2.3.7.1.tar.gz) = c5a51d6f76e6e9c843df69e52a364a4c65c4c60e0c51d992eaa45f22f71803c3
+SIZE (dovecot-2.3.7.1.tar.gz) = 7076500
diff --git a/mail/dovecot/files/patch-src_lib-storage_mail-storage.c b/mail/dovecot/files/patch-src_lib-storage_mail-storage.c
deleted file mode 100644
index 71204c480d85..000000000000
--- a/mail/dovecot/files/patch-src_lib-storage_mail-storage.c
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/lib-storage/mail-storage.c.orig 2019-07-12 10:46:25 UTC
-+++ src/lib-storage/mail-storage.c
-@@ -1040,10 +1040,10 @@ mailbox_name_verify_extra_separators(const char *vname
- }
-
- static bool
--mailbox_verify_name_prefix(struct mailbox *box, const char **error_r)
-+mailbox_verify_name_prefix(struct mail_namespace *ns, const char **vnamep,
-+ const char **error_r)
- {
-- const char *vname = box->vname;
-- struct mail_namespace *ns = box->list->ns;
-+ const char *vname = *vnamep;
-
- if (ns->prefix_len == 0)
- return TRUE;
-@@ -1071,6 +1071,7 @@ mailbox_verify_name_prefix(struct mailbox *box, const
- return FALSE;
- }
- }
-+ *vnamep = vname;
- return TRUE;
- }
-
-@@ -1085,7 +1086,9 @@ int mailbox_verify_name(struct mailbox *box)
- return 0;
- }
-
-- if (!mailbox_verify_name_prefix(box, &error)) {
-+ /* Verify the namespace prefix here. Change vname to skip the prefix
-+ for the following checks. */
-+ if (!mailbox_verify_name_prefix(box->list->ns, &vname, &error)) {
- mail_storage_set_error(box->storage, MAIL_ERROR_PARAMS,
- t_strdup_printf("Invalid mailbox name '%s': %s",
- str_sanitize(vname, 80), error));
diff --git a/mail/dovecot/files/patch-src_lib_ostream-file.c b/mail/dovecot/files/patch-src_lib_ostream-file.c
deleted file mode 100644
index 81ad0662d04d..000000000000
--- a/mail/dovecot/files/patch-src_lib_ostream-file.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/lib/ostream-file.c.orig 2019-07-12 10:46:25 UTC
-+++ src/lib/ostream-file.c
-@@ -333,17 +333,17 @@ static int buffer_flush(struct file_ostream *fstream)
- static void o_stream_tcp_flush_via_nodelay(struct file_ostream *fstream)
- {
- if (net_set_tcp_nodelay(fstream->fd, TRUE) < 0) {
-- if (errno != ENOTSUP && errno != ENOTSOCK &&
-- errno != ENOPROTOOPT) {
-- i_error("file_ostream.net_set_tcp_nodelay(%s, TRUE) failed: %m",
-- o_stream_get_name(&fstream->ostream.ostream));
-- }
-+ /* Don't bother logging errors. There are quite a lot of
-+ different errors that need to be ignored, and it differs
-+ between OSes. At least:
-+ Linux: ENOTSUP, ENOTSOCK, ENOPROTOOPT
-+ FreeBSD: EINVAL, ECONNRESET */
- fstream->no_socket_nodelay = TRUE;
- } else if (net_set_tcp_nodelay(fstream->fd, FALSE) < 0) {
-- /* We already successfully enabled TCP_NODELAY, so we're really
-- not expecting any errors here. */
-- i_error("file_ostream.net_set_tcp_nodelay(%s, FALSE) failed: %m",
-- o_stream_get_name(&fstream->ostream.ostream));
-+ /* We already successfully enabled TCP_NODELAY, so there
-+ shouldn't really be errors. Except ECONNRESET can possibly
-+ still happen between these two calls, so again don't log
-+ errors. */
- fstream->no_socket_nodelay = TRUE;
- }
- }