aboutsummaryrefslogtreecommitdiff
path: root/mail/emil
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-05-11 22:15:44 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-05-11 22:15:44 +0000
commit95e445a499b4d9d6f132cfeb0a027b5f3acddb8f (patch)
tree4aaa03a61e484a2edea7dfc1e91c633b24d482a6 /mail/emil
parent69da47a9de36c32471cac94d6f814e9d3c408dd1 (diff)
downloadports-95e445a499b4d9d6f132cfeb0a027b5f3acddb8f.tar.gz
ports-95e445a499b4d9d6f132cfeb0a027b5f3acddb8f.zip
Notes
Diffstat (limited to 'mail/emil')
-rw-r--r--mail/emil/files/patch-Makefile.in4
-rw-r--r--mail/emil/files/patch-charset_Makefile.in4
-rw-r--r--mail/emil/files/patch-charset_chset.c4
-rw-r--r--mail/emil/files/patch-charset_conv.c4
-rw-r--r--mail/emil/files/patch-charset_dfopen.c4
-rw-r--r--mail/emil/files/patch-charset_gc.c4
-rw-r--r--mail/emil/files/patch-configure4
-rw-r--r--mail/emil/files/patch-emil.cf.man4
-rw-r--r--mail/emil/files/patch-emil.man4
-rw-r--r--mail/emil/files/patch-func.h11
-rw-r--r--mail/emil/files/patch-getoption.y4
-rw-r--r--mail/emil/files/patch-header.c11
-rw-r--r--mail/emil/files/patch-main.c4
-rw-r--r--mail/emil/files/patch-message.c54
-rw-r--r--mail/emil/files/patch-mime.c4
-rw-r--r--mail/emil/files/patch-mimeparse.c20
-rw-r--r--mail/emil/files/patch-out.c11
-rw-r--r--mail/emil/files/patch-rfc822parse.c11
-rw-r--r--mail/emil/files/patch-uuencode.c13
19 files changed, 144 insertions, 35 deletions
diff --git a/mail/emil/files/patch-Makefile.in b/mail/emil/files/patch-Makefile.in
index fe0fbed4997a..712c369e85c1 100644
--- a/mail/emil/files/patch-Makefile.in
+++ b/mail/emil/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig 1996-06-04 13:54:32.000000000 +0200
-+++ Makefile.in 2013-12-29 21:24:36.000000000 +0100
+--- Makefile.in.orig 1996-06-04 11:54:32 UTC
++++ Makefile.in
@@ -41,9 +41,10 @@ exec_prefix = @exec_prefix@
#manprefix =
diff --git a/mail/emil/files/patch-charset_Makefile.in b/mail/emil/files/patch-charset_Makefile.in
index 9cbb9d6847a2..76adb335519e 100644
--- a/mail/emil/files/patch-charset_Makefile.in
+++ b/mail/emil/files/patch-charset_Makefile.in
@@ -1,5 +1,5 @@
---- charset/Makefile.in.orig 2014-01-25 18:34:47.000000000 +0100
-+++ charset/Makefile.in 2014-01-25 18:34:49.000000000 +0100
+--- charset/Makefile.in.orig 1994-12-23 07:33:00 UTC
++++ charset/Makefile.in
@@ -1,7 +1,6 @@
srcdir = @srcdir@
VPATH = @srcdir@
diff --git a/mail/emil/files/patch-charset_chset.c b/mail/emil/files/patch-charset_chset.c
index 64bf3136cf33..de29dcaa69b6 100644
--- a/mail/emil/files/patch-charset_chset.c
+++ b/mail/emil/files/patch-charset_chset.c
@@ -1,5 +1,5 @@
---- charset/chset.c.orig 2011-07-25 20:25:55.000000000 +0200
-+++ charset/chset.c 2011-07-25 20:25:56.000000000 +0200
+--- charset/chset.c.orig 1994-11-29 15:08:14 UTC
++++ charset/chset.c
@@ -42,7 +42,7 @@ int i;
return s;
}
diff --git a/mail/emil/files/patch-charset_conv.c b/mail/emil/files/patch-charset_conv.c
index 20a2c1f76dd4..044a208dd28c 100644
--- a/mail/emil/files/patch-charset_conv.c
+++ b/mail/emil/files/patch-charset_conv.c
@@ -1,5 +1,5 @@
---- charset/conv.c.orig 2011-07-25 20:26:26.000000000 +0200
-+++ charset/conv.c 2011-07-25 20:25:30.000000000 +0200
+--- charset/conv.c.orig 1994-12-16 12:47:50 UTC
++++ charset/conv.c
@@ -65,10 +65,10 @@ Char *b, *bm;
}
diff --git a/mail/emil/files/patch-charset_dfopen.c b/mail/emil/files/patch-charset_dfopen.c
index 550b1f47f1bc..d33aa1ce24b8 100644
--- a/mail/emil/files/patch-charset_dfopen.c
+++ b/mail/emil/files/patch-charset_dfopen.c
@@ -1,5 +1,5 @@
---- charset/dfopen.c.orig 1994-11-29 16:10:29.000000000 +0100
-+++ charset/dfopen.c 2011-07-25 20:21:13.000000000 +0200
+--- charset/dfopen.c.orig 1994-11-29 15:10:29 UTC
++++ charset/dfopen.c
@@ -1,7 +1,6 @@
#include "iso646.h"
#include <stdio.h>
diff --git a/mail/emil/files/patch-charset_gc.c b/mail/emil/files/patch-charset_gc.c
index 957d2f18ec63..f34e46515fd3 100644
--- a/mail/emil/files/patch-charset_gc.c
+++ b/mail/emil/files/patch-charset_gc.c
@@ -1,5 +1,5 @@
---- charset/gc.c.orig 2011-07-25 20:24:02.000000000 +0200
-+++ charset/gc.c 2011-07-25 20:24:04.000000000 +0200
+--- charset/gc.c.orig 1994-11-29 16:01:57 UTC
++++ charset/gc.c
@@ -256,7 +256,7 @@ char *file, *mode;
}
diff --git a/mail/emil/files/patch-configure b/mail/emil/files/patch-configure
index 9458efb87877..c9d394f073d4 100644
--- a/mail/emil/files/patch-configure
+++ b/mail/emil/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 1996-04-19 12:22:41.000000000 +0200
-+++ configure 2011-07-25 20:21:58.000000000 +0200
+--- configure.orig 1996-04-19 10:22:41 UTC
++++ configure
@@ -513,7 +513,6 @@ fi
diff --git a/mail/emil/files/patch-emil.cf.man b/mail/emil/files/patch-emil.cf.man
index be87c9845c3f..dfc302998f3f 100644
--- a/mail/emil/files/patch-emil.cf.man
+++ b/mail/emil/files/patch-emil.cf.man
@@ -1,5 +1,5 @@
---- emil.cf.man.orig 1996-02-10 14:16:17.000000000 +0100
-+++ emil.cf.man 2011-07-25 20:21:13.000000000 +0200
+--- emil.cf.man.orig 1996-02-10 13:16:17 UTC
++++ emil.cf.man
@@ -1,6 +1,6 @@
-.TH EMIL.CF 8 "19 December 1994"
+.TH EMIL.CF 1 "19 December 1994"
diff --git a/mail/emil/files/patch-emil.man b/mail/emil/files/patch-emil.man
index d9dd16831eca..77cca7898569 100644
--- a/mail/emil/files/patch-emil.man
+++ b/mail/emil/files/patch-emil.man
@@ -1,5 +1,5 @@
---- emil.man.orig 1996-06-04 13:42:42.000000000 +0200
-+++ emil.man 2011-07-25 20:21:13.000000000 +0200
+--- emil.man.orig 1996-06-04 11:42:42 UTC
++++ emil.man
@@ -1,4 +1,4 @@
-.TH EMIL 8 "19 December 1994"
+.TH EMIL 1 "19 December 1994"
diff --git a/mail/emil/files/patch-func.h b/mail/emil/files/patch-func.h
new file mode 100644
index 000000000000..6928bb83f7ba
--- /dev/null
+++ b/mail/emil/files/patch-func.h
@@ -0,0 +1,11 @@
+--- func.h.orig 1996-06-04 13:37:04 UTC
++++ func.h
+@@ -166,7 +166,7 @@ int check_encoding(struct message *)
+ int boundary_check(struct message *);
+ int is_bound(struct data *, char *);
+ struct message * copy_mstruct(struct message *, int);
+-int getline(struct data *);
++int get_line(struct data *);
+ int set_end_by_boundary(struct message *, char *);
+ int set_end_by_lines(struct message *, int);
+
diff --git a/mail/emil/files/patch-getoption.y b/mail/emil/files/patch-getoption.y
index 95ff6c84b0fe..7b494623beac 100644
--- a/mail/emil/files/patch-getoption.y
+++ b/mail/emil/files/patch-getoption.y
@@ -1,5 +1,5 @@
---- getoption.y.orig 2014-07-06 11:40:52.000000000 +0200
-+++ getoption.y 2014-07-06 11:40:40.000000000 +0200
+--- getoption.y.orig 1996-06-04 13:17:35 UTC
++++ getoption.y
@@ -163,13 +163,10 @@ static int Ycmp(char * pattern, char * s
extern char * yytext; /* defined by flex */
diff --git a/mail/emil/files/patch-header.c b/mail/emil/files/patch-header.c
new file mode 100644
index 000000000000..bd0ab72b7943
--- /dev/null
+++ b/mail/emil/files/patch-header.c
@@ -0,0 +1,11 @@
+--- header.c.orig 1996-06-04 13:36:56 UTC
++++ header.c
+@@ -75,7 +75,7 @@ load_header(struct message *m)
+ {
+ buf = indata->contents + indata->offset;
+
+- if ((linelen = getline(indata)) == 0)
++ if ((linelen = get_line(indata)) == 0)
+ {
+ /* End of data, illegal header */
+ indata->offset = startoffset; /* Rewind */
diff --git a/mail/emil/files/patch-main.c b/mail/emil/files/patch-main.c
index f7e0667cc0c2..89ed87a2594f 100644
--- a/mail/emil/files/patch-main.c
+++ b/mail/emil/files/patch-main.c
@@ -1,5 +1,5 @@
---- main.c.orig 1996-06-04 15:36:58.000000000 +0200
-+++ main.c 2011-07-25 20:32:45.000000000 +0200
+--- main.c.orig 1996-06-04 13:36:58 UTC
++++ main.c
@@ -69,7 +69,7 @@ int spawn_mailer = 0;
int pseudo_route = 0;
diff --git a/mail/emil/files/patch-message.c b/mail/emil/files/patch-message.c
new file mode 100644
index 000000000000..e49e319ad3fa
--- /dev/null
+++ b/mail/emil/files/patch-message.c
@@ -0,0 +1,54 @@
+--- message.c.orig 1996-06-04 13:36:59 UTC
++++ message.c
+@@ -93,7 +93,7 @@ move_past_boundary(struct message *m, ch
+ /* Find start boundary */
+ while (is_bound(inbuf, boundary) != TRUE)
+ {
+- if ((linelen = getline(inbuf)) == 0)
++ if ((linelen = get_line(inbuf)) == 0)
+ {
+ #ifdef DEBUG
+ if (edebug)
+@@ -115,7 +115,7 @@ move_past_boundary(struct message *m, ch
+ inbuf->loffset += 1;
+ }
+ /* Move past boundary */
+- inbuf->offset += getline(inbuf);
++ inbuf->offset += get_line(inbuf);
+ inbuf->loffset += 1;
+ #ifdef DEBUG
+ if (edebug)
+@@ -388,13 +388,13 @@ copy_mstruct(struct message *m, int forc
+
+ /*
+ * int
+- * getline(inbuf)
++ * get_line(inbuf)
+ *
+ * Move pointer to next line of inbuf. Return line length.
+ */
+
+ int
+-getline(struct data *inbuf)
++get_line(struct data *inbuf)
+ {
+ unsigned char *tmp;
+ if (inbuf == NULL || inbuf->contents == NULL ||
+@@ -423,7 +423,7 @@ set_end_by_boundary(struct message *m, c
+ loffset = inbuf->loffset;
+ while (is_bound(inbuf, boundary) != TRUE)
+ {
+- if ((linelen = getline(inbuf)) == 0)
++ if ((linelen = get_line(inbuf)) == 0)
+ {
+ if (m->parent)
+ inbuf->bodyend = m->parent->sd->bodyend;
+@@ -471,7 +471,7 @@ set_end_by_lines(struct message *m, int
+ offset = inbuf->offset;
+ loffset = inbuf->loffset;
+ lineend = loffset + lines;
+- while ((linelen = getline(inbuf)) != 0 && lineend > inbuf->loffset)
++ while ((linelen = get_line(inbuf)) != 0 && lineend > inbuf->loffset)
+ {
+ inbuf->offset += linelen;
+ inbuf->loffset += 1;
diff --git a/mail/emil/files/patch-mime.c b/mail/emil/files/patch-mime.c
index d2f4b15996c2..1142fbf579a6 100644
--- a/mail/emil/files/patch-mime.c
+++ b/mail/emil/files/patch-mime.c
@@ -1,5 +1,5 @@
---- mime.c.orig 1996-06-04 15:36:59.000000000 +0200
-+++ mime.c 2011-07-25 20:21:13.000000000 +0200
+--- mime.c.orig 1996-06-04 13:36:59 UTC
++++ mime.c
@@ -56,18 +56,18 @@ encode_mime(struct message *m)
if (match(m->sd->type, "TEXT"))
{
diff --git a/mail/emil/files/patch-mimeparse.c b/mail/emil/files/patch-mimeparse.c
index 19b25881742c..b3eab04c834e 100644
--- a/mail/emil/files/patch-mimeparse.c
+++ b/mail/emil/files/patch-mimeparse.c
@@ -1,6 +1,6 @@
---- mimeparse.c.orig 1996-06-04 15:36:59.000000000 +0200
-+++ mimeparse.c 2011-07-25 20:21:13.000000000 +0200
-@@ -219,8 +219,39 @@ parse_mime_siblings(struct message *m)
+--- mimeparse.c.orig 1996-06-04 13:36:59 UTC
++++ mimeparse.c
+@@ -219,9 +219,40 @@ parse_mime_siblings(struct message *m)
inbuf->bodystart,
inbuf->bodyend);
#endif
@@ -11,10 +11,10 @@
+ move_past_boundary(m, m->sd->endbound);
+ for (;;)
+ {
-+ tttt = getline(m->sd);
++ tttt = get_line(m->sd);
+#ifdef DEBUG
+ if (edebug)
-+ fprintf(stderr," getline = %d\n", tttt);
++ fprintf(stderr," get_line = %d\n", tttt);
+#endif
+ if (tttt == 1)
+ {
@@ -30,14 +30,16 @@
+ }
+ break;
+ }
-+
+
+- m->sd->offset = m->sd->bodyend;
+- if (getline(m->sd) == 0)
+ }
+ else
+ /* END_FIX */
+ m->sd->offset = m->sd->bodyend;
+
-
-- m->sd->offset = m->sd->bodyend;
- if (getline(m->sd) == 0)
++
++ if (get_line(m->sd) == 0)
return(OK);
if (m->sd->offset < m->sd->end)
+ {
diff --git a/mail/emil/files/patch-out.c b/mail/emil/files/patch-out.c
new file mode 100644
index 000000000000..da173705c51e
--- /dev/null
+++ b/mail/emil/files/patch-out.c
@@ -0,0 +1,11 @@
+--- out.c.orig 1996-06-04 13:37:00 UTC
++++ out.c
+@@ -143,7 +143,7 @@ void print_body(struct data *d, struct m
+ #endif
+ }
+ d->offset = d->bodystart;
+- while ((len = getline(d)) != 0)
++ while ((len = get_line(d)) != 0)
+ {
+ line->end = 0;
+ append_data(line, (d->contents + d->offset), len, MED_BUF);
diff --git a/mail/emil/files/patch-rfc822parse.c b/mail/emil/files/patch-rfc822parse.c
new file mode 100644
index 000000000000..5d4ac5e6d4a4
--- /dev/null
+++ b/mail/emil/files/patch-rfc822parse.c
@@ -0,0 +1,11 @@
+--- rfc822parse.c.orig 1996-06-04 13:37:01 UTC
++++ rfc822parse.c
+@@ -86,7 +86,7 @@ parse_rfc822_message(struct message *m)
+
+
+ /* Loop through rest of the message */
+- while ((linelen = getline(inbuf)) != 0)
++ while ((linelen = get_line(inbuf)) != 0)
+ {
+ if (inbuf->bodyend <= inbuf->offset &&
+ inbuf->lineend <= inbuf->loffset)
diff --git a/mail/emil/files/patch-uuencode.c b/mail/emil/files/patch-uuencode.c
index d43ab6a870f4..59716ff88ad6 100644
--- a/mail/emil/files/patch-uuencode.c
+++ b/mail/emil/files/patch-uuencode.c
@@ -1,5 +1,5 @@
---- uuencode.c.orig 1996-06-04 15:37:02.000000000 +0200
-+++ uuencode.c 2011-07-25 20:21:13.000000000 +0200
+--- uuencode.c.orig 1996-06-04 13:37:02 UTC
++++ uuencode.c
@@ -116,7 +116,7 @@ encode_uuencode(struct message *m)
/* Start with uuencode preamble */
fix_filename(m);
@@ -18,3 +18,12 @@
{
#ifdef DEBUG
if (edebug)
+@@ -290,7 +290,7 @@ decode_uuencode(struct message *m)
+ /* Check for end */
+ if (strncmp(inb, "end", 3) == 0)
+ {
+- inbuf->offset += getline(inbuf);
++ inbuf->offset += get_line(inbuf);
+ inbuf->loffset += 1;
+ inbuf->bodyend = inbuf->offset;
+ if (process)