aboutsummaryrefslogtreecommitdiff
path: root/mail/epstools
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-22 16:44:21 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-22 16:44:21 +0000
commit3d7e69467af16abd6c5cbb481136d4bef52be65a (patch)
tree1a85634b10e08c5051bd5cfbb8a967b345d0e267 /mail/epstools
parent93d4c4a5d11db15fd22db9286402c6d88667090c (diff)
downloadports-3d7e69467af16abd6c5cbb481136d4bef52be65a.tar.gz
ports-3d7e69467af16abd6c5cbb481136d4bef52be65a.zip
Sample code, and tools for EPS (Requires EPS v1.5)
WWW: http://www.inter7.com/index.php?page=eps PR: ports/83882 Submitted by: Ismail YENIGUL <ismail@enderunix.org> Approved by: flz (mentor)
Notes
Notes: svn path=/head/; revision=139907
Diffstat (limited to 'mail/epstools')
-rw-r--r--mail/epstools/Makefile52
-rw-r--r--mail/epstools/distinfo2
-rw-r--r--mail/epstools/files/pkg-message.in3
-rw-r--r--mail/epstools/pkg-descr3
-rw-r--r--mail/epstools/pkg-plist18
5 files changed, 78 insertions, 0 deletions
diff --git a/mail/epstools/Makefile b/mail/epstools/Makefile
new file mode 100644
index 000000000000..0ec32eae64ec
--- /dev/null
+++ b/mail/epstools/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: epstools
+# Date created: 21 Jul 2005
+# Whom: ismail@enderunix.org
+#
+# $FreeBSD$
+
+PORTNAME= epstools
+PORTVERSION= 1.7
+CATEGORIES= mail
+MASTER_SITES= http://www.inter7.com/eps/
+
+MAINTAINER= ismail@EnderUNIX.org
+COMMENT= EPS (Email Parsing System) sample tools
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libeps.a:${PORTSDIR}/mail/eps
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_REINPLACE= yes
+
+PORTDOCS= README
+
+MAKE_ENV+= DEFS="-I${LOCALBASE}/include ${CFLAGS}"
+SUB_FILES= pkg-message
+
+EXAMPLE_FILES= addr.1 addr.2 addr.3 addr.4 email.1 email.2 virus.email
+INSTALL_FILES= address b64decode b64encode body fold full headers qpdecode rewrite
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CC =|CC \?=|' \
+ -e 's|^DEFS =|DEFS \?=|' \
+ -e 's|^LIBS = -leps|LIBS = ${LOCALBASE}/lib/libeps.a|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+.for f in ${INSTALL_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/bin/eps-${f}
+.endfor
+
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/content/${f} ${EXAMPLESDIR}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/epstools/distinfo b/mail/epstools/distinfo
new file mode 100644
index 000000000000..a61292b02dc2
--- /dev/null
+++ b/mail/epstools/distinfo
@@ -0,0 +1,2 @@
+MD5 (epstools-1.7.tar.gz) = 4ed6d823621625e8aaa5a75f9134509e
+SIZE (epstools-1.7.tar.gz) = 5932
diff --git a/mail/epstools/files/pkg-message.in b/mail/epstools/files/pkg-message.in
new file mode 100644
index 000000000000..13dcee82b7fb
--- /dev/null
+++ b/mail/epstools/files/pkg-message.in
@@ -0,0 +1,3 @@
+
+Please read the %%DOCSDIR%%/README
+Example mail files are under %%EXAMPLESDIR%%
diff --git a/mail/epstools/pkg-descr b/mail/epstools/pkg-descr
new file mode 100644
index 000000000000..41f133163a0c
--- /dev/null
+++ b/mail/epstools/pkg-descr
@@ -0,0 +1,3 @@
+Sample code, and tools for EPS (Requires EPS v1.5)
+
+WWW: http://www.inter7.com/index.php?page=eps
diff --git a/mail/epstools/pkg-plist b/mail/epstools/pkg-plist
new file mode 100644
index 000000000000..cfc986526bda
--- /dev/null
+++ b/mail/epstools/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+bin/eps-headers
+bin/eps-body
+bin/eps-address
+bin/eps-full
+bin/eps-b64encode
+bin/eps-b64decode
+bin/eps-rewrite
+bin/eps-fold
+bin/eps-qpdecode
+%%EXAMPLESDIR%%/addr.1
+%%EXAMPLESDIR%%/addr.2
+%%EXAMPLESDIR%%/addr.3
+%%EXAMPLESDIR%%/addr.4
+%%EXAMPLESDIR%%/email.1
+%%EXAMPLESDIR%%/email.2
+%%EXAMPLESDIR%%/virus.email
+@dirrm %%EXAMPLESDIR%%