aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-ews/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /mail/evolution-ews/Makefile
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
Notes
Diffstat (limited to 'mail/evolution-ews/Makefile')
-rw-r--r--mail/evolution-ews/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/mail/evolution-ews/Makefile b/mail/evolution-ews/Makefile
index a63464fbcd62..6baf608cf10f 100644
--- a/mail/evolution-ews/Makefile
+++ b/mail/evolution-ews/Makefile
@@ -1,15 +1,14 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/mail/evolution-ews/Makefile 20048 2014-11-10 09:19:46Z gusi $
PORTNAME= evolution-ews
-PORTVERSION= 3.12.11
+PORTVERSION= 3.16.4
CATEGORIES= mail gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Evolution plugin to connect to Microsoft Exchange Web Services
+COMMENT= Evolution Microsoft Exchange plugin through Exchange Web Services
BUILD_DEPENDS= evolution>=3.0.0:${PORTSDIR}/mail/evolution
LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
@@ -17,8 +16,10 @@ LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libical.so:${PORTSDIR}/devel/libical
RUN_DEPENDS= evolution>=3.0.0:${PORTSDIR}/mail/evolution
+PORTSCOUT= limitw:1,even
+
USES= gettext gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= gnomeprefix intlhack
+USE_GNOME= intlhack
GNU_CONFIGURE= yes
USE_SQLITE= 3
USE_BDB= 5
@@ -26,9 +27,13 @@ USE_OPENLDAP= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --datarootdir=${PREFIX}/share \
+ --localedir=${PREFIX}/share/locale \
+ --prefix=${PREFIX}
INSTALL_TARGET= install-strip
-VERSION= 3.12
-PLIST_SUB= VERSION=${VERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(prefix)/$$(DATADIRNAME)/|$$(prefix)/share/|g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>