aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-ews
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /mail/evolution-ews
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'mail/evolution-ews')
-rw-r--r--mail/evolution-ews/Makefile34
-rw-r--r--mail/evolution-ews/distinfo2
-rw-r--r--mail/evolution-ews/pkg-descr5
-rw-r--r--mail/evolution-ews/pkg-plist58
4 files changed, 99 insertions, 0 deletions
diff --git a/mail/evolution-ews/Makefile b/mail/evolution-ews/Makefile
new file mode 100644
index 000000000000..8f29eafe2ac4
--- /dev/null
+++ b/mail/evolution-ews/Makefile
@@ -0,0 +1,34 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/mail/evolution-ews/Makefile 19979 2014-10-17 05:16:24Z gusi $
+
+PORTNAME= evolution-ews
+PORTVERSION= 3.12.7
+CATEGORIES= mail gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Evolution plugin to connect to Microsoft Exchange Web Services
+
+BUILD_DEPENDS= evolution>=3.0.0:${PORTSDIR}/mail/evolution
+LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libmspack.so:${PORTSDIR}/archivers/libmspack \
+ libical.so:${PORTSDIR}/devel/libical
+RUN_DEPENDS= evolution>=3.0.0:${PORTSDIR}/mail/evolution
+
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomeprefix intlhack
+GNU_CONFIGURE= yes
+USE_SQLITE= 3
+USE_BDB= 5
+USE_OPENLDAP= yes
+USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+VERSION= 3.12
+PLIST_SUB= VERSION=${VERSION}
+
+.include <bsd.port.mk>
diff --git a/mail/evolution-ews/distinfo b/mail/evolution-ews/distinfo
new file mode 100644
index 000000000000..741aafa8aae8
--- /dev/null
+++ b/mail/evolution-ews/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/evolution-ews-3.12.7.tar.xz) = 138fb6c4cdb36757b3c1efc430b5392d30fe7520c280168c80687627fc325671
+SIZE (gnome3/evolution-ews-3.12.7.tar.xz) = 661880
diff --git a/mail/evolution-ews/pkg-descr b/mail/evolution-ews/pkg-descr
new file mode 100644
index 000000000000..75d113451401
--- /dev/null
+++ b/mail/evolution-ews/pkg-descr
@@ -0,0 +1,5 @@
+Evolution-ews is a plugin for Evolution that adds Exchange integration though
+Exchange Web Service.
+
+See the following link for development.
+https://docs.google.com/spreadsheet/ccc?key=0ArU7C3muFYmHdHlvZUpRQ0FKQkNVck5kc1BpSDhkSGc&hl=en_U
diff --git a/mail/evolution-ews/pkg-plist b/mail/evolution-ews/pkg-plist
new file mode 100644
index 000000000000..e3aac72ef796
--- /dev/null
+++ b/mail/evolution-ews/pkg-plist
@@ -0,0 +1,58 @@
+include/evolution-data-server/ews/e-ews-connection-utils.h
+include/evolution-data-server/ews/e-ews-connection.h
+include/evolution-data-server/ews/e-ews-debug.h
+include/evolution-data-server/ews/e-ews-enums.h
+include/evolution-data-server/ews/e-ews-enumtypes.h
+include/evolution-data-server/ews/e-ews-folder.h
+include/evolution-data-server/ews/e-ews-item-change.h
+include/evolution-data-server/ews/e-ews-item.h
+include/evolution-data-server/ews/e-ews-message.h
+include/evolution-data-server/ews/e-ews-notification.h
+include/evolution-data-server/ews/e-ews-oof-settings.h
+include/evolution-data-server/ews/ews-errors.h
+lib/evolution-data-server/libeews-1.2.so
+lib/evolution-data-server/libeews-1.2.so.0
+lib/evolution-data-server/libeews-1.2.so.0.0.0
+lib/evolution-data-server/libewsutils.so
+lib/evolution-data-server/libewsutils.so.0
+lib/evolution-data-server/libewsutils.so.0.0.0
+lib/evolution-data-server/addressbook-backends/libebookbackendews.so
+lib/evolution-data-server/calendar-backends/libecalbackendews.so
+lib/evolution-data-server/camel-providers/libcamelews.so
+lib/evolution-data-server/camel-providers/libcamelews.urls
+lib/evolution-data-server/registry-modules/module-ews-backend.so
+lib/evolution/%%VERSION%%/modules/module-ews-configuration.so
+share/appdata/evolution-ews.metainfo.xml
+share/evolution-data-server/ews/windowsZones.xml
+share/evolution/%%VERSION%%/errors/module-ews-configuration.error
+share/locale/as/LC_MESSAGES/evolution-ews.mo
+share/locale/bg/LC_MESSAGES/evolution-ews.mo
+share/locale/ca/LC_MESSAGES/evolution-ews.mo
+share/locale/cs/LC_MESSAGES/evolution-ews.mo
+share/locale/da/LC_MESSAGES/evolution-ews.mo
+share/locale/de/LC_MESSAGES/evolution-ews.mo
+share/locale/el/LC_MESSAGES/evolution-ews.mo
+share/locale/en_GB/LC_MESSAGES/evolution-ews.mo
+share/locale/es/LC_MESSAGES/evolution-ews.mo
+share/locale/eu/LC_MESSAGES/evolution-ews.mo
+share/locale/fr/LC_MESSAGES/evolution-ews.mo
+share/locale/gl/LC_MESSAGES/evolution-ews.mo
+share/locale/gu/LC_MESSAGES/evolution-ews.mo
+share/locale/hu/LC_MESSAGES/evolution-ews.mo
+share/locale/id/LC_MESSAGES/evolution-ews.mo
+share/locale/ja/LC_MESSAGES/evolution-ews.mo
+share/locale/kn/LC_MESSAGES/evolution-ews.mo
+share/locale/lt/LC_MESSAGES/evolution-ews.mo
+share/locale/lv/LC_MESSAGES/evolution-ews.mo
+share/locale/mr/LC_MESSAGES/evolution-ews.mo
+share/locale/nb/LC_MESSAGES/evolution-ews.mo
+share/locale/or/LC_MESSAGES/evolution-ews.mo
+share/locale/pl/LC_MESSAGES/evolution-ews.mo
+share/locale/pt_BR/LC_MESSAGES/evolution-ews.mo
+share/locale/sl/LC_MESSAGES/evolution-ews.mo
+share/locale/sr/LC_MESSAGES/evolution-ews.mo
+share/locale/sr@latin/LC_MESSAGES/evolution-ews.mo
+share/locale/sv/LC_MESSAGES/evolution-ews.mo
+share/locale/ta/LC_MESSAGES/evolution-ews.mo
+share/locale/te/LC_MESSAGES/evolution-ews.mo
+share/locale/zh_CN/LC_MESSAGES/evolution-ews.mo