aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2019-03-11 16:26:23 +0000
committerLarry Rosenman <ler@FreeBSD.org>2019-03-11 16:26:23 +0000
commit0ec0fdfd5d0688cbe6e86e4caf937b53cc955a26 (patch)
tree8d3b6932440dc851c62c7a2bf05bc226b67caf54 /mail/exim
parent862873e89b7ca75f590ea6007c41b3d505ad70be (diff)
downloadports-0ec0fdfd5d0688cbe6e86e4caf937b53cc955a26.tar.gz
ports-0ec0fdfd5d0688cbe6e86e4caf937b53cc955a26.zip
mail/exim: add missing colon on I=
Reported by: ler (self) Approved by: vsevolod (maintainer, private mail)
Notes
Notes: svn path=/head/; revision=495360
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src_deliver.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 1d68bfdb19b6..b1371c5da1a4 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= EXIM:exim
MASTER_SITE_SUBDIR= /exim4/:exim \
diff --git a/mail/exim/files/patch-src_deliver.c b/mail/exim/files/patch-src_deliver.c
new file mode 100644
index 000000000000..476eaf7f6c34
--- /dev/null
+++ b/mail/exim/files/patch-src_deliver.c
@@ -0,0 +1,11 @@
+--- src/deliver.c.orig 2019-03-11 16:20:17 UTC
++++ src/deliver.c
+@@ -763,7 +763,7 @@ if (LOGGING(incoming_interface) && LOGGING(outgoing_in
+ {
+ g = string_fmt_append(g, " I=[%s]", sending_ip_address);
+ if (LOGGING(outgoing_port))
+- g = string_fmt_append(g, "%d", sending_port);
++ g = string_fmt_append(g, ":%d", sending_port);
+ }
+ return g;
+ }