aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2018-08-26 07:45:55 +0000
committerXin LI <delphij@FreeBSD.org>2018-08-26 07:45:55 +0000
commit7232456d14479e40094ffa54d9279637ef81fb00 (patch)
treeb45c425f5d1c7de9083d67d24ace092258b6c58c /mail/exim
parent050fe3e097cd285ec109470bfac4a331ab171ed7 (diff)
downloadports-7232456d14479e40094ffa54d9279637ef81fb00.tar.gz
ports-7232456d14479e40094ffa54d9279637ef81fb00.zip
mail/exim: Stop using arc4random_stir.
PR: 230826, 230756 Approved by: portmgr
Notes
Notes: svn path=/head/; revision=478103
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-OS_os.h-FreeBSD17
2 files changed, 18 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 4cda41df0d08..9b0f84d5eb07 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= EXIM:exim
MASTER_SITE_SUBDIR= /exim4/:exim \
diff --git a/mail/exim/files/patch-OS_os.h-FreeBSD b/mail/exim/files/patch-OS_os.h-FreeBSD
new file mode 100644
index 000000000000..0113c0c1ebb1
--- /dev/null
+++ b/mail/exim/files/patch-OS_os.h-FreeBSD
@@ -0,0 +1,17 @@
+--- OS/os.h-FreeBSD.orig 2018-04-14 23:18:10 UTC
++++ OS/os.h-FreeBSD
+@@ -12,6 +12,14 @@
+ #define SIOCGIFCONF_GIVES_ADDR
+ #define HAVE_SRANDOMDEV
+ #define HAVE_ARC4RANDOM
++/* Applications should not call arc4random_stir() explicitly after
++ FreeBSD r227520 (approximately 1000002).
++ Set NOT_HAVE_ARC4RANDOM_STIR if the version released is past
++ that point. */
++#include <sys/param.h>
++#if __FreeBSD_version >= 1000002
++# define NOT_HAVE_ARC4RANDOM_STIR
++#endif
+
+ typedef struct flock flock_t;
+