aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2018-04-17 09:32:06 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2018-04-17 09:32:06 +0000
commit8d16b09148c46e8d1e6511fcbf605b5943bdbdf4 (patch)
treed32f80cd48ce4c0d75727ea16878d11164b5257c /mail/exim
parentfb682ee41176dc38bdec1a805f5c05e667f5ae9b (diff)
downloadports-8d16b09148c46e8d1e6511fcbf605b5943bdbdf4.tar.gz
ports-8d16b09148c46e8d1e6511fcbf605b5943bdbdf4.zip
Various fixes for the Exim port
- Fix build with no OSCP support (ported from upstream) [1] - Fix Dane support [2] - Silence compile warnings caused by Exim code style Reported by: ler [1], Max Kostikov [2] via private email
Notes
Notes: svn path=/head/; revision=467585
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile7
-rw-r--r--mail/exim/files/patch-src-tls-openssl.c40
2 files changed, 45 insertions, 2 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 0fb0287c4a63..4cda41df0d08 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= EXIM:exim
MASTER_SITE_SUBDIR= /exim4/:exim \
@@ -151,6 +151,9 @@ CONFIG_FILE_PATH?= ${PREFIX}/etc/exim/configure
ALT_CONFIG_PREFIX?= ${PREFIX}/etc/exim/
EXIM_DYNAMIC_LDFLAGS= -fPIC -rdynamic -export-dynamic
+# Avoid too many warnings due to Exim code style
+EXIM_WARN_FLAGS?= -Wno-logical-op-parentheses -Wno-macro-redefined -Wno-parentheses -Wno-dangling-else
+CFLAGS+= ${EXIM_WARN_FLAGS}
SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%DOCSDIR%%,${DOCSDIR},g' \
@@ -214,7 +217,7 @@ SEDLIST+= -e 's,^\# (EXPERIMENTAL_DSN=),\1,'
.endif
.if ${PORT_OPTIONS:MDANE}
-SEDLIST+= -e 's,^\# (EXPERIMENTAL_DANE=),\1,'
+SEDLIST+= -e 's,^\# (SUPPORT_DANE=),\1,'
.endif
.if ${PORT_OPTIONS:MARC}
diff --git a/mail/exim/files/patch-src-tls-openssl.c b/mail/exim/files/patch-src-tls-openssl.c
new file mode 100644
index 000000000000..01e6800d7c3d
--- /dev/null
+++ b/mail/exim/files/patch-src-tls-openssl.c
@@ -0,0 +1,40 @@
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Mon, 16 Apr 2018 17:45:04 +0000 (+0100)
+Subject: Fix OpenSSL non-OCSP build
+X-Git-Url: https://git.exim.org/exim.git/commitdiff_plain/37f0ce65959019e417ff79b9d0959e13470c5290
+
+Fix OpenSSL non-OCSP build
+---
+
+diff --git a/src/src/tls-openssl.c b/src/src/tls-openssl.c
+index fb59217..cefa94f 100644
+--- src/tls-openssl.c.orig
++++ src/tls-openssl.c
+@@ -2505,10 +2505,12 @@ if (error == SSL_ERROR_ZERO_RETURN)
+ if (SSL_get_shutdown(server_ssl) == SSL_RECEIVED_SHUTDOWN)
+ SSL_shutdown(server_ssl);
+
++#ifndef DISABLE_OCSP
+ sk_X509_pop_free(server_static_cbinfo->verify_stack, X509_free);
++ server_static_cbinfo->verify_stack = NULL;
++#endif
+ SSL_free(server_ssl);
+ SSL_CTX_free(server_ctx);
+- server_static_cbinfo->verify_stack = NULL;
+ server_ctx = NULL;
+ server_ssl = NULL;
+ tls_in.active = -1;
+@@ -2782,11 +2784,13 @@ if (shutdown)
+ }
+ }
+
++#ifndef DISABLE_OCSP
+ if (is_server)
+ {
+ sk_X509_pop_free(server_static_cbinfo->verify_stack, X509_free);
+ server_static_cbinfo->verify_stack = NULL;
+ }
++#endif
+
+ SSL_CTX_free(*ctxp);
+ SSL_free(*sslp);