aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea@FreeBSD.org>2011-03-28 13:50:19 +0000
committerEygene Ryabinkin <rea@FreeBSD.org>2011-03-28 13:50:19 +0000
commite31c84776b00c1e4a2df096b1360951e25a70fba (patch)
tree4d36fc09bdc65777cfaae8c3b9267eb2ebdb551a /mail/exim
parent9539228d91b607d71ed18e6c4fb26dc76b33e2e5 (diff)
downloadports-e31c84776b00c1e4a2df096b1360951e25a70fba.tar.gz
ports-e31c84776b00c1e4a2df096b1360951e25a70fba.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile22
-rw-r--r--mail/exim/distinfo4
-rw-r--r--mail/exim/files/patch-src::EDITME4
3 files changed, 23 insertions, 7 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 1b0e580cdecf..9f34171a97ea 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -25,6 +25,18 @@ WANT_GNOME= yes
WANT_PERL= yes
MAKE_JOBS_UNSAFE= yes
+# One can tune the following "hidden" knobs:
+# - EXIM_USER: user exim is running as;
+# - EXIM_GROUP: ditto for the group;
+# - LOGDIR: where Exim logs will be put;
+# - LOG_FILE_PATH: path where '%s' will be substituted with
+# the target name (main, reject, etc);
+# - CONFIG_FILE_PATH: path to the default configuration file;
+# - ALT_CONFIG_PREFIX: path to the default prefix for all
+# configuration files, excluding the main one;
+# will be effective only when WITH_ALT_CONFIG_PREFIX
+# will be set via OPTIONS.
+
.if make(makesum) && !defined(FETCH_ALL)
.error "You forgot to define FETCH_ALL to create the sane distinfo"
.endif
@@ -65,7 +77,7 @@ PLIST_SUB+= SO_1024=""
PLIST_SUB+= SO_1024="@comment "
.endif
-EXIM_VERSION= 4.74
+EXIM_VERSION= 4.75
SA_EXIM_VERSION=4.2
SO_1024_VERSION=3.2
@@ -123,8 +135,10 @@ MAKE_ENV+= INSTALL_ARG="-no_chown"
EXIM_USER?= mailnull
EXIM_GROUP?= mail
-LOGDIR?= /var/log/exim
-LOG_FILE_PATH?= ${LOGDIR}/%slog
+LOGDIR?= /var/log/exim
+LOG_FILE_PATH?= ${LOGDIR}/%slog
+CONFIG_FILE_PATH?= ${PREFIX}/etc/exim/configure
+ALT_CONFIG_PREFIX?= ${PREFIX}/etc/exim/
SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%DOCSDIR%%,${DOCSDIR},g' \
@@ -173,6 +187,8 @@ SEDLIST+= -e 's,XX_CFLAGS_XX,${CFLAGS},' \
-e 's,XX_PREFIX_XX,${PREFIX},' \
-e 's,XX_LOCALBASE_XX,${LOCALBASE},' \
-e 's,XX_LOG_FILE_PATH_XX,${LOG_FILE_PATH},' \
+ -e 's,XX_CONFIG_FILE_PATH_XX,${CONFIG_FILE_PATH},' \
+ -e 's,XX_ALT_CONFIG_PREFIX_XX,${ALT_CONFIG_PREFIX},' \
-e 's,XX_EXIM_USER_XX,${EXIM_USER},' \
-e 's,XX_EXIM_GROUP_XX,${EXIM_GROUP},' \
-e 's,XX_DEFAULT_CHARSET_XX,${WITH_DEFAULT_CHARSET},'
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index ed71b6a83bee..eaac60f991b0 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,5 +1,5 @@
-SHA256 (exim/exim-4.74.tar.bz2) = e55b51c87e0be920f7f5aee830261566a4def8820f318d14a822fe2ae2ff8e40
-SIZE (exim/exim-4.74.tar.bz2) = 1588636
+SHA256 (exim/exim-4.75.tar.bz2) = dc6ef216dcf5b44b6c43f00a3ccb16c4b22e1cb2a414e324df22e991fd490ded
+SIZE (exim/exim-4.75.tar.bz2) = 1600867
SHA256 (exim/sa-exim-4.2.tar.gz) = 72e0a735547f18b05785e6c58a71d24623858f0f5234a5dc0e24cb453999e99a
SIZE (exim/sa-exim-4.2.tar.gz) = 66575
SHA256 (exim/spamooborona1024-src-3.2.tar.gz) = ab22a430f3860460045f6b213c68c89700a0cd10cbb6c7a808ece326c53787ee
diff --git a/mail/exim/files/patch-src::EDITME b/mail/exim/files/patch-src::EDITME
index 636f5dd0c09f..2e4e5eb43009 100644
--- a/mail/exim/files/patch-src::EDITME
+++ b/mail/exim/files/patch-src::EDITME
@@ -14,7 +14,7 @@
# file does not exist.
-CONFIGURE_FILE=/usr/exim/configure
-+CONFIGURE_FILE=XX_PREFIX_XX/etc/exim/configure
++CONFIGURE_FILE=XX_CONFIG_FILE_PATH_XX
# It is possible to specify a colon-separated list of files for CONFIGURE_FILE.
# In this case, Exim will use the first of them that exists when it is run.
@@ -78,7 +78,7 @@
# ALT_CONFIG_PREFIX=/some/directory/
# ALT_CONFIG_PREFIX=/some/directory/exim.conf-
-+ALT_CONFIG_PREFIX=XX_PREFIX_XX/etc/exim/
++ALT_CONFIG_PREFIX=XX_ALT_CONFIG_PREFIX_XX
#------------------------------------------------------------------------------