aboutsummaryrefslogtreecommitdiff
path: root/mail/exmh2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-24 22:13:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-24 22:13:33 +0000
commit42bdc9f77e595a7cd96df1061c46aa77b408b2de (patch)
tree2659f30d697d0790d7985886d458aae092ba671c /mail/exmh2
parent19a6a69e902c5960e899faa2a823f672fe5a6b44 (diff)
downloadports-42bdc9f77e595a7cd96df1061c46aa77b408b2de.tar.gz
ports-42bdc9f77e595a7cd96df1061c46aa77b408b2de.zip
- Update to 2.7.2
PR: ports/80715 Submitted by: Kevin Oberman <oberman@es.net>
Notes
Notes: svn path=/head/; revision=136074
Diffstat (limited to 'mail/exmh2')
-rw-r--r--mail/exmh2/Makefile2
-rw-r--r--mail/exmh2/distinfo4
-rw-r--r--mail/exmh2/files/patch-lib-folder.tcl25
-rw-r--r--mail/exmh2/files/patch-lib-quote.tcl11
-rw-r--r--mail/exmh2/files/patch-lib-uri.tcl13
-rw-r--r--mail/exmh2/pkg-plist1
6 files changed, 53 insertions, 3 deletions
diff --git a/mail/exmh2/Makefile b/mail/exmh2/Makefile
index 083cab6f0298..9786627c737c 100644
--- a/mail/exmh2/Makefile
+++ b/mail/exmh2/Makefile
@@ -7,7 +7,7 @@
# "+=" and "?=" lines are for sharing this Makefile with japanese/exmh2.
PORTNAME= exmh
-PORTVERSION= 2.7.0
+PORTVERSION= 2.7.2
CATEGORIES+= mail tk84
MASTER_SITES= ftp://ftp.tcl.tk/pub/tcl/%SUBDIR%/
MASTER_SITES+= ${MASTER_SITE_SOURCEFORGE}
diff --git a/mail/exmh2/distinfo b/mail/exmh2/distinfo
index ecf6a1a6c638..2229057d3d12 100644
--- a/mail/exmh2/distinfo
+++ b/mail/exmh2/distinfo
@@ -1,2 +1,2 @@
-MD5 (exmh-2.7.0.tar.gz) = 513f6cd11cbb0f35ee179ebe1a1475a8
-SIZE (exmh-2.7.0.tar.gz) = 1061945
+MD5 (exmh-2.7.2.tar.gz) = fdb7c6ff26d0429ea950590a36f1369f
+SIZE (exmh-2.7.2.tar.gz) = 1081601
diff --git a/mail/exmh2/files/patch-lib-folder.tcl b/mail/exmh2/files/patch-lib-folder.tcl
new file mode 100644
index 000000000000..b538f1fb9cf0
--- /dev/null
+++ b/mail/exmh2/files/patch-lib-folder.tcl
@@ -0,0 +1,25 @@
+--- lib/folder.tcl.orig Wed Dec 29 23:39:51 2004
++++ lib/folder.tcl Wed May 25 00:02:21 2005
+@@ -311,17 +311,17 @@
+
+ set out [open $fn w]
+ puts $out "wm withdraw ."
+- puts $out "source $exmh(library)/folder.tcl"
++ puts $out [list lappend auto_path $exmh(library)]
+ puts $out [list set mhProfile(delprefix) $mhProfile(delprefix)]
+ puts $out [list set mhProfile(purgeage) $mhProfile(purgeage)]
+ puts $out [list set mhProfile(path) $mhProfile(path)]
+- puts $out "proc Exmh_Status { s } \{catch \{send \"[winfo name .]\" \[list Exmh_Status \$s]\}\}"
++ puts $out "proc Exmh_Status { s args } \{catch \{send \"[winfo name .]\" \[list Exmh_Status \$s]\}\}"
+ puts $out "proc Exmh_Debug { args } {}"
+- puts $out [list proc File_Delete [info args File_Delete] [info body File_Delete]]
++ puts $out "Env_Init"
+ foreach folder $folderlist {
+- puts $out "Folder_Purge $folder"
++ puts $out [list Folder_Purge $folder]
+ }
+- puts $out "File_Delete $fn"
++ puts $out [list File_Delete $fn]
+ puts $out exit
+ close $out
+ exec $wish -f $fn &
diff --git a/mail/exmh2/files/patch-lib-quote.tcl b/mail/exmh2/files/patch-lib-quote.tcl
new file mode 100644
index 000000000000..14f78ff7ed19
--- /dev/null
+++ b/mail/exmh2/files/patch-lib-quote.tcl
@@ -0,0 +1,11 @@
+--- lib/quote.tcl.orig Mon Jul 26 20:23:33 2004
++++ lib/quote.tcl Wed May 25 00:04:18 2005
+@@ -23,7 +23,7 @@
+ return;
+ } else {
+ if {$quote(symlink)} {
+- if [catch {file link -symbolic $mhProfile(path)/$folder/$msg $quote(filename)} err] {
++ if [catch {exec ln -s $mhProfile(path)/$folder/$msg $quote(filename)} err] {
+ Exmh_Debug "Quote_MakeFile: $err"
+ }
+ } else {
diff --git a/mail/exmh2/files/patch-lib-uri.tcl b/mail/exmh2/files/patch-lib-uri.tcl
new file mode 100644
index 000000000000..f9c5df53e69b
--- /dev/null
+++ b/mail/exmh2/files/patch-lib-uri.tcl
@@ -0,0 +1,13 @@
+--- lib/uri.tcl.orig Mon Jul 26 20:23:34 2004
++++ lib/uri.tcl Wed May 25 00:05:06 2005
+@@ -174,8 +174,8 @@
+ global mimeHdr mime
+ set fileName $mimeHdr($part,file)
+ File_Delete [Env_Tmp]/exmh.[pid].html
+- if [catch {file link -hard $fileName [Env_Tmp]/exmh.[pid].html}] {
+- file copy $fileName [Env_Tmp]/exmh.[pid].html
++ if [catch {exec ln $fileName [Env_Tmp]/exmh.[pid].html}] {
++ exec cp $fileName [Env_Tmp]/exmh.[pid].html
+ }
+ set fileName [Env_Tmp]/exmh.[pid].html
+ Exmh_Status "HTML Load $fileName"
diff --git a/mail/exmh2/pkg-plist b/mail/exmh2/pkg-plist
index c367e58ddb54..2d1901274b2a 100644
--- a/mail/exmh2/pkg-plist
+++ b/mail/exmh2/pkg-plist
@@ -158,6 +158,7 @@ lib/exmh-%%EXMH_VERSION%%/mbuntidy.bitmap
lib/exmh-%%EXMH_VERSION%%/mh.tcl
lib/exmh-%%EXMH_VERSION%%/mime.tcl
lib/exmh-%%EXMH_VERSION%%/mime.types
+lib/exmh-%%EXMH_VERSION%%/mimencode.tcl
lib/exmh-%%EXMH_VERSION%%/mimeSun.tcl
lib/exmh-%%EXMH_VERSION%%/mosaic.tcl
lib/exmh-%%EXMH_VERSION%%/msg.tcl