aboutsummaryrefslogtreecommitdiff
path: root/mail/exmh2
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-12-08 07:08:09 +0000
committerCy Schubert <cy@FreeBSD.org>2012-12-08 07:08:09 +0000
commit99a5455d74a9643a0e7f5c09d49dadb83b4aaac9 (patch)
tree62dc85bf6da97c4846650fb5e9ae5aedd9d27471 /mail/exmh2
parenta18af5fc69936b94841c0048303f5c735357b72d (diff)
downloadports-99a5455d74a9643a0e7f5c09d49dadb83b4aaac9.tar.gz
ports-99a5455d74a9643a0e7f5c09d49dadb83b4aaac9.zip
Update 2,7,2 --> 2.8.0
Feature safe: yes
Notes
Notes: svn path=/head/; revision=308464
Diffstat (limited to 'mail/exmh2')
-rw-r--r--mail/exmh2/Makefile17
-rw-r--r--mail/exmh2/distinfo4
-rw-r--r--mail/exmh2/files/patch-lib-folder.tcl25
-rw-r--r--mail/exmh2/files/patch-lib-quote.tcl11
-rw-r--r--mail/exmh2/files/patch-lib-uri.tcl13
5 files changed, 13 insertions, 57 deletions
diff --git a/mail/exmh2/Makefile b/mail/exmh2/Makefile
index ef655ae70ac5..d88a8bb4f46d 100644
--- a/mail/exmh2/Makefile
+++ b/mail/exmh2/Makefile
@@ -8,11 +8,11 @@
# "+=" and "?=" lines are for sharing this Makefile with japanese/exmh2.
PORTNAME= exmh
-PORTVERSION= 2.7.2
-PORTREVISION= 6
+PORTVERSION= 2.8.0
CATEGORIES+= mail tk
MASTER_SITES= ${MASTER_SITE_TCLTK} \
SF
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER?= cy@FreeBSD.org
COMMENT?= X11/TK based mail reader front end to MH
@@ -23,10 +23,7 @@ BUILD_DEPENDS= tclsh8.0jp:${PORTSDIR}/japanese/tcl80
WISH= wish8.0jp
TCLSH= tclsh8.0jp
.else
-RUN_DEPENDS= wish8.6:${PORTSDIR}/x11-toolkits/tk86
-BUILD_DEPENDS= tclsh8.6:${PORTSDIR}/lang/tcl86
-WISH= wish8.6
-TCLSH= tclsh8.6
+USE_TK= 86
.endif
# exmh is pretty useless without this, but it's not needed to build it.
@@ -53,13 +50,21 @@ PLIST_SUB= EXMH_VERSION=${PORTVERSION}
MAN1= exmh.1
+.if defined(JAPANESE_EXMH)
do-build:
@cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} TCLSH=${TCLSH} \
WISH=${PREFIX}/bin/${WISH} WRKSRC=${WRKSRC} \
${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build
+.else
+do-build:
+ @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} TCLSH=${TCLSH} \
+ WISH=${WISH} WRKSRC=${WRKSRC} \
+ ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build
+.endif
do-install:
@cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} \
WRKSRC=${WRKSRC} ${SH} ${SCRIPTDIR}/install
+
.include <bsd.port.mk>
diff --git a/mail/exmh2/distinfo b/mail/exmh2/distinfo
index 59a25e24be47..2d89b48d926b 100644
--- a/mail/exmh2/distinfo
+++ b/mail/exmh2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (exmh-2.7.2.tar.gz) = f4533950bd6c843427fcae28e0946454c94eb47745f20256b847dba540bc5f3e
-SIZE (exmh-2.7.2.tar.gz) = 1081601
+SHA256 (exmh-2.8.0.tar.gz) = 0d907a19cbed17506e5fcd2212f13e9342e1619f174bf9a1733cc6a7c479d7cb
+SIZE (exmh-2.8.0.tar.gz) = 1090674
diff --git a/mail/exmh2/files/patch-lib-folder.tcl b/mail/exmh2/files/patch-lib-folder.tcl
deleted file mode 100644
index b538f1fb9cf0..000000000000
--- a/mail/exmh2/files/patch-lib-folder.tcl
+++ /dev/null
@@ -1,25 +0,0 @@
---- lib/folder.tcl.orig Wed Dec 29 23:39:51 2004
-+++ lib/folder.tcl Wed May 25 00:02:21 2005
-@@ -311,17 +311,17 @@
-
- set out [open $fn w]
- puts $out "wm withdraw ."
-- puts $out "source $exmh(library)/folder.tcl"
-+ puts $out [list lappend auto_path $exmh(library)]
- puts $out [list set mhProfile(delprefix) $mhProfile(delprefix)]
- puts $out [list set mhProfile(purgeage) $mhProfile(purgeage)]
- puts $out [list set mhProfile(path) $mhProfile(path)]
-- puts $out "proc Exmh_Status { s } \{catch \{send \"[winfo name .]\" \[list Exmh_Status \$s]\}\}"
-+ puts $out "proc Exmh_Status { s args } \{catch \{send \"[winfo name .]\" \[list Exmh_Status \$s]\}\}"
- puts $out "proc Exmh_Debug { args } {}"
-- puts $out [list proc File_Delete [info args File_Delete] [info body File_Delete]]
-+ puts $out "Env_Init"
- foreach folder $folderlist {
-- puts $out "Folder_Purge $folder"
-+ puts $out [list Folder_Purge $folder]
- }
-- puts $out "File_Delete $fn"
-+ puts $out [list File_Delete $fn]
- puts $out exit
- close $out
- exec $wish -f $fn &
diff --git a/mail/exmh2/files/patch-lib-quote.tcl b/mail/exmh2/files/patch-lib-quote.tcl
deleted file mode 100644
index 14f78ff7ed19..000000000000
--- a/mail/exmh2/files/patch-lib-quote.tcl
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/quote.tcl.orig Mon Jul 26 20:23:33 2004
-+++ lib/quote.tcl Wed May 25 00:04:18 2005
-@@ -23,7 +23,7 @@
- return;
- } else {
- if {$quote(symlink)} {
-- if [catch {file link -symbolic $mhProfile(path)/$folder/$msg $quote(filename)} err] {
-+ if [catch {exec ln -s $mhProfile(path)/$folder/$msg $quote(filename)} err] {
- Exmh_Debug "Quote_MakeFile: $err"
- }
- } else {
diff --git a/mail/exmh2/files/patch-lib-uri.tcl b/mail/exmh2/files/patch-lib-uri.tcl
deleted file mode 100644
index f9c5df53e69b..000000000000
--- a/mail/exmh2/files/patch-lib-uri.tcl
+++ /dev/null
@@ -1,13 +0,0 @@
---- lib/uri.tcl.orig Mon Jul 26 20:23:34 2004
-+++ lib/uri.tcl Wed May 25 00:05:06 2005
-@@ -174,8 +174,8 @@
- global mimeHdr mime
- set fileName $mimeHdr($part,file)
- File_Delete [Env_Tmp]/exmh.[pid].html
-- if [catch {file link -hard $fileName [Env_Tmp]/exmh.[pid].html}] {
-- file copy $fileName [Env_Tmp]/exmh.[pid].html
-+ if [catch {exec ln $fileName [Env_Tmp]/exmh.[pid].html}] {
-+ exec cp $fileName [Env_Tmp]/exmh.[pid].html
- }
- set fileName [Env_Tmp]/exmh.[pid].html
- Exmh_Status "HTML Load $fileName"