aboutsummaryrefslogtreecommitdiff
path: root/mail/fastforward/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-03 21:40:02 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-03 21:40:02 +0000
commit0729fa7197504124132f3175cfeb2fe4ccabebfc (patch)
tree761102f53ec018f56c86d8d73ee46a8aa2c52556 /mail/fastforward/Makefile
parent98b65f501fbbf551b84040c39347473cac4dc975 (diff)
downloadports-0729fa7197504124132f3175cfeb2fe4ccabebfc.tar.gz
ports-0729fa7197504124132f3175cfeb2fe4ccabebfc.zip
Notes
Diffstat (limited to 'mail/fastforward/Makefile')
-rw-r--r--mail/fastforward/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/mail/fastforward/Makefile b/mail/fastforward/Makefile
new file mode 100644
index 000000000000..edbca31e6655
--- /dev/null
+++ b/mail/fastforward/Makefile
@@ -0,0 +1,41 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= fastforward
+PORTVERSION= 0.51
+CATEGORIES= mail
+MASTER_SITES= http://cr.yp.to/software/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Fastforward handles qmail forwarding according to a cdb database
+
+USES= gmake
+
+ALL_TARGET= default
+
+MAN1= fastforward.1 printforward.1 setforward.1 newaliases.1 printmaillist.1 setmaillist.1 newinclude.1
+CAT1= fastforward.0 printforward.0 setforward.0 newaliases.0 printmaillist.0 setmaillist.0 newinclude.0
+
+PORTDOCS= ALIASES
+
+PLIST_FILES= \
+ bin/fastforward bin/printforward bin/setforward bin/newaliases bin/printmaillist bin/setmaillist bin/newinclude \
+ ${MAN1:S,^,man/man1/,:S,$,.gz,} ${CAT1:S,^,man/cat1/,:S,$,.gz,}
+
+do-install:
+.for binfile in fastforward printforward setforward newaliases printmaillist setmaillist newinclude
+ ${INSTALL_PROGRAM} ${WRKSRC}/${binfile} ${STAGEDIR}${PREFIX}/bin/${binfile}
+.endfor
+
+.for manfile in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${manfile} ${STAGEDIR}${MAN1PREFIX}/man/man1/${manfile}
+.endfor
+
+.for catfile in ${CAT1}
+ ${INSTALL_MAN} ${WRKSRC}/${catfile} ${STAGEDIR}${MAN1PREFIX}/man/cat1/${catfile}
+.endfor
+
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ALIASES ${STAGEDIR}${DOCSDIR}/ALIASES
+
+.include <bsd.port.mk>