aboutsummaryrefslogtreecommitdiff
path: root/mail/fdm
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-09-06 01:19:05 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-09-06 01:19:05 +0000
commit021d280d6f1dc5061cf2a6a6f18847a4fc2bd95a (patch)
treeee26c74178409d0959d7ade10a21a71e64498312 /mail/fdm
parent5d73ee151e2f980fa6c4e5c8f76c1ecdaa72e047 (diff)
downloadports-021d280d6f1dc5061cf2a6a6f18847a4fc2bd95a.tar.gz
ports-021d280d6f1dc5061cf2a6a6f18847a4fc2bd95a.zip
- Integrate a couple of upstream patches
Obtained from: Debian package Suggested by: Frank Terbeck <ft _at_ bewatermyfriend.org>
Notes
Notes: svn path=/head/; revision=198883
Diffstat (limited to 'mail/fdm')
-rw-r--r--mail/fdm/Makefile2
-rw-r--r--mail/fdm/files/patch-fix_cmdline_macros42
-rw-r--r--mail/fdm/files/patch-fix_regex_match_tags23
3 files changed, 66 insertions, 1 deletions
diff --git a/mail/fdm/Makefile b/mail/fdm/Makefile
index f1e4e129bc23..26ec63e04086 100644
--- a/mail/fdm/Makefile
+++ b/mail/fdm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fdm
-PORTVERSION= 1.3.0.1
+PORTVERSION= 1.3.0.2
DISTVERSION= 1.3c
CATEGORIES= mail
MASTER_SITES= SFE
diff --git a/mail/fdm/files/patch-fix_cmdline_macros b/mail/fdm/files/patch-fix_cmdline_macros
new file mode 100644
index 000000000000..668111658076
--- /dev/null
+++ b/mail/fdm/files/patch-fix_cmdline_macros
@@ -0,0 +1,42 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 05fix_cmdline_macros.dpatch by Frank Terbeck <ft@bewatermyfriend.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Quick fix for a bug that breaks macros defined on the command line.
+## Written by Nicholas Marriott (fdm upstream). He will fix this issue
+## the upstream CVS repository as well.
+
+@DPATCH@
+diff -urNad fdm-1.3c~/fdm.c fdm-1.3c/fdm.c
+--- fdm-1.3c~/fdm.c Wed Aug 1 11:58:54 2007
++++ fdm.c Thu Aug 30 14:51:35 2007
+@@ -271,6 +271,8 @@
+ conf.queue_high = -1;
+ conf.queue_low = -1;
+
++ TAILQ_INIT(&parse_macros);
++
+ ARRAY_INIT(&conf.incl);
+ ARRAY_INIT(&conf.excl);
+
+diff -u ../fdm-1.3c.orig/parse.y ./parse.y
+--- ../fdm-1.3c.orig/parse.y Wed Aug 1 11:58:56 2007
++++ parse.y Thu Aug 30 14:51:25 2007
+@@ -70,8 +70,6 @@
+ strb_create(&parse_tags);
+ default_tags(&parse_tags, NULL);
+
+- TAILQ_INIT(&parse_macros);
+-
+ yyparse();
+
+ if (!ARRAY_EMPTY(&parse_rulestack))
+@@ -667,7 +665,7 @@
+ macro->fixed = 0;
+ strlcpy(macro->name, $1, sizeof macro->name);
+ TAILQ_INSERT_HEAD(&parse_macros, macro, entry);
+- } else
++ } else if (!macro->fixed)
+ xfree(macro->value.str);
+ if (!macro->fixed) {
+ macro->type = MACRO_STRING;
diff --git a/mail/fdm/files/patch-fix_regex_match_tags b/mail/fdm/files/patch-fix_regex_match_tags
new file mode 100644
index 000000000000..57f526faf165
--- /dev/null
+++ b/mail/fdm/files/patch-fix_regex_match_tags
@@ -0,0 +1,23 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 06fix_regex_match_tags.dpatch by Frank Terbeck <ft@bewatermyfriend.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: This is a fix for broken behaviour if regex matches are used on
+## messages with a From_ header, in which case the replacement tags
+## (like %1) break.
+## Written by Nicholas Marriott (fdm upstream).
+
+@DPATCH@
+diff -urNad fdm-1.3c~/replace.c fdm-1.3c/replace.c
+--- fdm-1.3c~/replace.c Wed Aug 1 11:58:54 2007
++++ replace.c Thu Aug 30 14:51:35 2007
+@@ -257,7 +257,7 @@ replace(char *src, struct strb *tags, st
+ if (!rml->list[idx].valid)
+ continue;
+
+- tptr = m->base + rml->list[idx].so;
++ tptr = m->data + rml->list[idx].so;
+ tlen = rml->list[idx].eo - rml->list[idx].so;
+ break;
+ }
+