aboutsummaryrefslogtreecommitdiff
path: root/mail/fdm
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-25 12:54:09 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-25 12:54:09 +0000
commitc876c8b2279f85aa4788c3cd4c9141156ade7717 (patch)
treec88e53441c55c67a4d7570e1ea59a76be5e20f03 /mail/fdm
parent2ace452a3857ea31821351c386d2f961deb7bdd9 (diff)
downloadports-c876c8b2279f85aa4788c3cd4c9141156ade7717.tar.gz
ports-c876c8b2279f85aa4788c3cd4c9141156ade7717.zip
Add port mail/fdm:
fdm is a simple, lightweight replacement for mail fetch, filter and delivery programs such as fetchmail and procmail. It can currently fetch using POP3, POP3S or from stdin, and deliver to a pipe, file, maildir, mbox or SMTP server, based on regexps. WWW: http://fdm.sourceforge.net/ Author: Nicholas Marriott <nicm@users.sourceforge.net>
Notes
Notes: svn path=/head/; revision=171381
Diffstat (limited to 'mail/fdm')
-rw-r--r--mail/fdm/Makefile31
-rw-r--r--mail/fdm/distinfo3
-rw-r--r--mail/fdm/files/patch-parse.y10
-rw-r--r--mail/fdm/pkg-descr7
4 files changed, 51 insertions, 0 deletions
diff --git a/mail/fdm/Makefile b/mail/fdm/Makefile
new file mode 100644
index 000000000000..8757d8fe1236
--- /dev/null
+++ b/mail/fdm/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: fdm
+# Date created: 25 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fdm
+PORTVERSION= 0.1
+CATEGORIES= mail
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Fetches and delivers mail
+
+PLIST_FILES= bin/fdm etc/fdm.conf.sample
+PORTDOCS= README
+
+CFLAGS= -I/usr/include/openssl
+
+MAN1= fdm.1
+MAN5= fdm.conf.5
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/fdm.conf ${PREFIX}/etc/fdm.conf.sample
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/fdm/distinfo b/mail/fdm/distinfo
new file mode 100644
index 000000000000..4c97b5a1baa6
--- /dev/null
+++ b/mail/fdm/distinfo
@@ -0,0 +1,3 @@
+MD5 (fdm-0.1.tar.gz) = ee3b6a9ed07ff5d0723d313928dd9d89
+SHA256 (fdm-0.1.tar.gz) = ac29c9edd9f13281701cad6e286d97c07e79a11fd0b900f036c390a868d879e2
+SIZE (fdm-0.1.tar.gz) = 34931
diff --git a/mail/fdm/files/patch-parse.y b/mail/fdm/files/patch-parse.y
new file mode 100644
index 000000000000..1904880582e1
--- /dev/null
+++ b/mail/fdm/files/patch-parse.y
@@ -0,0 +1,10 @@
+--- ./parse.y.orig Fri Aug 25 16:42:22 2006
++++ ./parse.y Fri Aug 25 16:42:32 2006
+@@ -21,6 +21,7 @@
+ %{
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <sys/limits.h>
+
+ #include <ctype.h>
+ #include <grp.h>
diff --git a/mail/fdm/pkg-descr b/mail/fdm/pkg-descr
new file mode 100644
index 000000000000..0f795c729459
--- /dev/null
+++ b/mail/fdm/pkg-descr
@@ -0,0 +1,7 @@
+fdm is a simple, lightweight replacement for mail fetch, filter and
+delivery programs such as fetchmail and procmail. It can currently
+fetch using POP3, POP3S or from stdin, and deliver to a pipe, file,
+maildir, mbox or SMTP server, based on regexps.
+
+WWW: http://fdm.sourceforge.net/
+Author: Nicholas Marriott <nicm@users.sourceforge.net>