aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmailconf
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-05-29 12:24:56 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-06-01 16:46:28 +0000
commit58cb56664fb02e860bde94b2bedb080d7778b60a (patch)
treed4ff0d5008227bbd3bf38b81aa9cc93a82442951 /mail/fetchmailconf
parent9bf40d7c50b665db38a19e0065a16a26be0e3aaa (diff)
downloadports-58cb56664fb02e860bde94b2bedb080d7778b60a.tar.gz
ports-58cb56664fb02e860bde94b2bedb080d7778b60a.zip
mail/fetchmailconf: avoid polluting BUILD_DEPENDS
The RUN_DEPENDS+=BUILD_DEPENDS may pull ccache in as run-time requisite, so let's flip the assignments and make BUILD_DEPENDS use RUN_DEPENDS to avoid just this pollution. PR: 256242 Approved by: Corey Halpin (maintainer)
Diffstat (limited to 'mail/fetchmailconf')
-rw-r--r--mail/fetchmailconf/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/fetchmailconf/Makefile b/mail/fetchmailconf/Makefile
index e049dd2f0ee8..f25ceb941cec 100644
--- a/mail/fetchmailconf/Makefile
+++ b/mail/fetchmailconf/Makefile
@@ -12,10 +12,10 @@ LICENSE_COMB= dual
# minimum required version 6.4.2 - not codified, on the assumption
# that fetchmail port updated at the same time
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
fetchmail>=${PORTVERSION}:mail/fetchmail
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+BUILD_DEPENDS+= ${RUN_DEPENDS}
USES= python shebangfix tar:xz
USE_PYTHON= py3kplist