aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmailconf
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-11-20 10:19:22 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-11-20 22:55:58 +0000
commit997bacb528ceba53b9e680dff833a0258d3bf917 (patch)
treef5a77e3d2d7a7dc71f832ddec4f8dac430e56b6b /mail/fetchmailconf
parent1b50e97082ad95373cf08f07a5e4194a9f89336c (diff)
downloadports-997bacb528ceba53b9e680dff833a0258d3bf917.tar.gz
ports-997bacb528ceba53b9e680dff833a0258d3bf917.zip
mail/fetchmail: update to 6.4.24 and block LibreSSL.
Now really 6.4.24 and not a 6.4.25 WIP. fetchmail cannot legally be linked with LibreSSL, because there is no GPLv2 clause 2b exemption for LibreSSL, only for OpenSSL. Correct LICENSE and remove LICENSE_COMB. Add comment on FSF dynamic linking dynamically suggested by Corey Halpin in the approval. Remove LibreSSL patch. Related to: PR: 259214 Update: PR: 259945 MFH: 2021Q4 Approved by: chalpin@cs.wisc.edu (maintainer)
Diffstat (limited to 'mail/fetchmailconf')
-rw-r--r--mail/fetchmailconf/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/mail/fetchmailconf/Makefile b/mail/fetchmailconf/Makefile
index f25ceb941cec..63599abe7b3f 100644
--- a/mail/fetchmailconf/Makefile
+++ b/mail/fetchmailconf/Makefile
@@ -7,31 +7,30 @@ DISTNAME= fetchmail-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= chalpin@cs.wisc.edu
COMMENT= Python-based GUI to configure fetchmail
-LICENSE= GPLv2 LGPL21
-LICENSE_COMB= dual
+LICENSE= GPLv2+
# minimum required version 6.4.2 - not codified, on the assumption
# that fetchmail port updated at the same time
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
fetchmail>=${PORTVERSION}:mail/fetchmail
BUILD_DEPENDS+= ${RUN_DEPENDS}
USES= python shebangfix tar:xz
USE_PYTHON= py3kplist
+GNU_CONFIGURE= yes
+ALL_TARGET= fetchmailconf
+INSTALL_TARGET= install-data-am install-nodist_binSCRIPTS install-man
+
FILESDIR= ${.CURDIR}/files
PATCHDIR= ${FILESDIR}
+NO_ARCH= yes
SUB_FILES= fetchmailconf
-SUB_LIST= PYTHON_CMD=${PYTHON_CMD} PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
+SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
+ PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
PLIST= ${.CURDIR}/pkg-plist
-NO_ARCH= yes
-
-GNU_CONFIGURE= yes
-
-ALL_TARGET= fetchmailconf
-INSTALL_TARGET= install-data-am install-nodist_binSCRIPTS install-man
post-install:
# first, run smoke tests - the version check makes sure we have all