aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmailconf
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2019-01-20 11:25:07 +0000
committerMatthias Andree <mandree@FreeBSD.org>2019-01-20 11:25:07 +0000
commitf7cd8bfb78a2ae011e17dbdc0d7c0b1e6eb3e653 (patch)
treed80d3a39788dbcfa89ba41aa7e03e22aac5ee243 /mail/fetchmailconf
parenta2f29160777b0c53e9b4a1fb2a48c13a42ea161f (diff)
downloadports-f7cd8bfb78a2ae011e17dbdc0d7c0b1e6eb3e653.tar.gz
ports-f7cd8bfb78a2ae011e17dbdc0d7c0b1e6eb3e653.zip
Notes
Diffstat (limited to 'mail/fetchmailconf')
-rw-r--r--mail/fetchmailconf/Makefile37
-rw-r--r--mail/fetchmailconf/distinfo7
-rw-r--r--mail/fetchmailconf/files/fetchmailconf.in22
-rw-r--r--mail/fetchmailconf/pkg-descr14
-rw-r--r--mail/fetchmailconf/pkg-plist6
5 files changed, 86 insertions, 0 deletions
diff --git a/mail/fetchmailconf/Makefile b/mail/fetchmailconf/Makefile
new file mode 100644
index 000000000000..d557ae69eebb
--- /dev/null
+++ b/mail/fetchmailconf/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= fetchmailconf
+PORTREVISION= 0
+DISTNAME= fetchmail-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= chalpin@cs.wisc.edu
+COMMENT= Python-based GUI to configure fetchmail
+
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= dual
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ fetchmail>=${PORTVERSION}:mail/fetchmail
+
+USES= python shebangfix tar:xz
+
+FILESDIR= ${.CURDIR}/files
+
+SHEBANG_FILES= fetchmailconf.py
+SUB_FILES= fetchmailconf
+PLIST= ${.CURDIR}/pkg-plist
+NO_ARCH= yes
+
+GNU_CONFIGURE= yes
+
+TARGET= fetchmailconf
+INSTALL_TARGET= install-data-am install-nodist_binSCRIPTS install-man
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/fetchmailconf.py ${STAGEDIR}${PREFIX}/libexec
+ ${RM} ${STAGEDIR}${PREFIX}/man/man1/fetchmail.1*
+
+MASTERDIR= ${.CURDIR}/../fetchmail
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/fetchmailconf/distinfo b/mail/fetchmailconf/distinfo
new file mode 100644
index 000000000000..b0080b347c89
--- /dev/null
+++ b/mail/fetchmailconf/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1546191531
+SHA256 (fetchmail-6.3.26.tar.xz) = 79b4c54cdbaf02c1a9a691d9948fcb1a77a1591a813e904283a8b614b757e850
+SIZE (fetchmail-6.3.26.tar.xz) = 1283816
+SHA256 (9b8b634.patch) = b0a9f7e28e7e6a5a16669832ad7a7a7dca47b435ce446ef10bd0421deea4a848
+SIZE (9b8b634.patch) = 1023
+SHA256 (fetchmail-6.3.26-ssl-backport.patch) = a34b1a6becf731e2ef029a1c5ee3a82a7bbb1e2487b6f3be15bbb4e7dc8b500d
+SIZE (fetchmail-6.3.26-ssl-backport.patch) = 31596
diff --git a/mail/fetchmailconf/files/fetchmailconf.in b/mail/fetchmailconf/files/fetchmailconf.in
new file mode 100644
index 000000000000..32bb008144cd
--- /dev/null
+++ b/mail/fetchmailconf/files/fetchmailconf.in
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# Wrapper for the real fetchmailconf. Checks whether Python and Tkinter are
+# installed, and runs the real fetchmailconf or alerts the user, as appropriate.
+#
+# $FreeBSD$
+
+LOCALBASE=%%LOCALBASE%%
+
+if [ -x $LOCALBASE/bin/python ] ; then
+ PYTHON_VERSION=python$(${LOCALBASE}/bin/python -c 'import sys; print sys.version[:3]' 2>/dev/null)
+ if [ -e ${LOCALBASE}/lib/${PYTHON_VERSION}/lib-dynload/_tkinter.so ]; then
+ exec ${LOCALBASE}/libexec/fetchmailconf.py "$@"
+ fi
+fi
+cat <<EOF
+The fetchmailconf program requires Python with Tkinter, which does
+not appear to be installed on this system. Python can be found in
+the FreeBSD Ports Collection in lang/python, and Tkinter for Python
+can be found in x11-toolkits/py-tkinter.
+EOF
+exit 1
diff --git a/mail/fetchmailconf/pkg-descr b/mail/fetchmailconf/pkg-descr
new file mode 100644
index 000000000000..970903ce3ffc
--- /dev/null
+++ b/mail/fetchmailconf/pkg-descr
@@ -0,0 +1,14 @@
+Fetchmail is a full-featured IMAP/POP2/POP3/APOP/KPOP/ETRN/ODMR client with
+easy configuration, daemon mode, forwarding via SMTP or local MDA, and
+superior reply handling. It is used to handle intermittent email connections
+by acting as a coupling that seamlessly batch forwards fetched mail from your
+mail server to your local delivery system, allowing you to read it with your
+favourite mail user agent. Fetchmail also includes useful spam filtering and
+multi-user functions.
+
+A typical use of fetchmail is to connect to your ISP's POP3 server,
+downloading your mail into the INBOX on your local computer. You may then
+read the mail, offline if you want, using pine, mutt, or any standard mail
+user agent.
+
+WWW: http://www.fetchmail.info/
diff --git a/mail/fetchmailconf/pkg-plist b/mail/fetchmailconf/pkg-plist
new file mode 100644
index 000000000000..901917414c2d
--- /dev/null
+++ b/mail/fetchmailconf/pkg-plist
@@ -0,0 +1,6 @@
+bin/fetchmailconf
+libexec/fetchmailconf.py
+man/man1/fetchmailconf.1.gz
+%%PYTHON_SITELIBDIR%%/fetchmailconf.py
+%%PYTHON_SITELIBDIR%%/fetchmailconf.pyc
+%%PYTHON_SITELIBDIR%%/fetchmailconf.pyo