aboutsummaryrefslogtreecommitdiff
path: root/mail/filtermail
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-08-08 09:50:41 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-08-08 09:50:41 +0000
commit0f11a0d9cb8586588d9177a0af22ac33945969eb (patch)
tree90cbf7093b046a70ea91ec459b08ece77055cb91 /mail/filtermail
parentf5b4a6e5eaf99b7e74f9ed3a6221e67d73ae7c25 (diff)
downloadports-0f11a0d9cb8586588d9177a0af22ac33945969eb.tar.gz
ports-0f11a0d9cb8586588d9177a0af22ac33945969eb.zip
mail/filtermail: update 0.8.3 -> 0.8.6
- fix build with more recent flex versions - pet portlint PR: 247771 Submitted by: Mike Clarke <jmc-freebsd2@milibyte.co.uk> (maintainer) MFH: 2020Q3 Relnotes: https://raw.githubusercontent.com/nondeterministic/mailfilter/master/NEWS
Notes
Notes: svn path=/head/; revision=544378
Diffstat (limited to 'mail/filtermail')
-rw-r--r--mail/filtermail/Makefile19
-rw-r--r--mail/filtermail/distinfo5
-rw-r--r--mail/filtermail/files/patch-src__Makefile.in7
-rw-r--r--mail/filtermail/files/patch-src__filter.hh4
-rw-r--r--mail/filtermail/files/patch-src__preferences.cc4
-rw-r--r--mail/filtermail/pkg-descr2
6 files changed, 25 insertions, 16 deletions
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index c5dc17afede1..a7227f6546a4 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -1,33 +1,42 @@
# $FreeBSD$
PORTNAME= filtermail
-PORTVERSION= 0.8.3
-PORTREVISION= 1
+PORTVERSION= 0.8.6
CATEGORIES= mail
MASTER_SITES= http://sourceforge.net/projects/mailfilter/files/Mailfilter/
DISTNAME= mailfilter-${PORTVERSION}
-MAINTAINER= jmc-filtermail@milibyte.co.uk
+MAINTAINER= jmc-freebsd2@milibyte.co.uk
COMMENT= Filter mail on a POP3 server: saves downloading spam
LICENSE= GPLv3
+.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300000
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
+.endif
+
+USES= bison gmake ssl
+
# This port is filtermail, but the author called it mailfilter. To avoid a
# clash with another port called mailfilter, we change all files
# installed by this port from the form *mailfilter* to the form
# *filtermail*, and similarly the names in the man pages.
-#
+
EXTRACT_CMD= ${GZIP_CMD}
EXTRACT_BEFORE_ARGS= -dc
EXTRACT_AFTER_ARGS= | ${SED} 's/[mM][aA][iI][lL][fF][iI][lL][tT][eE][rR]/filtermail/g' | ${TAR} -xf -
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= bison gmake ssl
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300000
+CPPFLAGS+= -I${LOCALBASE}/include/flex
+FLEX=${LOCALBASE}/bin/flex
+.endif
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} \
diff --git a/mail/filtermail/distinfo b/mail/filtermail/distinfo
index f65cd29806af..4c976338c58e 100644
--- a/mail/filtermail/distinfo
+++ b/mail/filtermail/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mailfilter-0.8.3.tar.gz) = 60a40e1d35148fd50a2627fc4bbe47626b886614db50f88c0a21d934df63cb7a
-SIZE (mailfilter-0.8.3.tar.gz) = 425337
+TIMESTAMP = 1593601356
+SHA256 (mailfilter-0.8.6.tar.gz) = f4e6b94996e95b7d45cec9fadee8fc99a6832c42dcfd86e2a1fd821deaf3069c
+SIZE (mailfilter-0.8.6.tar.gz) = 471479
diff --git a/mail/filtermail/files/patch-src__Makefile.in b/mail/filtermail/files/patch-src__Makefile.in
index d6131ef46d5c..69ae742d7330 100644
--- a/mail/filtermail/files/patch-src__Makefile.in
+++ b/mail/filtermail/files/patch-src__Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig Sat Nov 27 22:29:44 2004
-+++ src/Makefile.in Mon Mar 7 22:54:36 2005
-@@ -421,8 +421,6 @@
+--- src/Makefile.in.orig 2016-10-25 18:20:29 UTC
++++ src/Makefile.in
+@@ -424,8 +424,6 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/apop.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/feedback.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filter.Po@am__quote@
@@ -9,4 +9,3 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/header.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/imap.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filtermail.Po@am__quote@
-
diff --git a/mail/filtermail/files/patch-src__filter.hh b/mail/filtermail/files/patch-src__filter.hh
index 5366038c8ecd..00f494221789 100644
--- a/mail/filtermail/files/patch-src__filter.hh
+++ b/mail/filtermail/files/patch-src__filter.hh
@@ -1,5 +1,5 @@
---- src/filter.hh.orig Sun Jan 25 21:56:42 2004
-+++ src/filter.hh Fri Mar 19 23:19:33 2004
+--- src/filter.hh.orig 2016-06-05 09:28:35 UTC
++++ src/filter.hh
@@ -21,8 +21,8 @@
#include <string>
diff --git a/mail/filtermail/files/patch-src__preferences.cc b/mail/filtermail/files/patch-src__preferences.cc
index b7eb55b3aa1b..a0639206a7c0 100644
--- a/mail/filtermail/files/patch-src__preferences.cc
+++ b/mail/filtermail/files/patch-src__preferences.cc
@@ -1,5 +1,5 @@
---- src/preferences.cc.orig 2007-01-22 23:36:04.000000000 +0100
-+++ src/preferences.cc 2008-04-08 17:00:17.000000000 +0200
+--- src/preferences.cc.orig 2014-05-17 17:19:41 UTC
++++ src/preferences.cc
@@ -24,6 +24,7 @@
#include <vector>
#include <stdexcept>
diff --git a/mail/filtermail/pkg-descr b/mail/filtermail/pkg-descr
index c53c0f0b5fc7..7f7961e25ab2 100644
--- a/mail/filtermail/pkg-descr
+++ b/mail/filtermail/pkg-descr
@@ -1,5 +1,5 @@
This is mail/filtermail, a port of mailfilter, renamed because another
-mailfilter exists in the ports tree.
+mailfilter previously existed in the ports tree.
It filters mail on a pop3 server, allowing junk to be deleted on the
server rather than after it has been downloaded, and integrates with other