aboutsummaryrefslogtreecommitdiff
path: root/mail/filtermail
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-10-05 11:08:40 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-10-05 11:08:40 +0000
commit3aff526f34f4656596f8d4adbe9e4fe6e878c984 (patch)
tree482eb8960ab992cb1855c21aaa40aee9491bdcdf /mail/filtermail
parentbfecf34625b5728836bfd590c8ad40ab3066edc3 (diff)
downloadports-3aff526f34f4656596f8d4adbe9e4fe6e878c984.tar.gz
ports-3aff526f34f4656596f8d4adbe9e4fe6e878c984.zip
mail/filtermail: resurrect, stage, 0.8.2 -> 0.8.3, new maintainer
PR: 193721 Submitted by: Mike Clarke <jmc-freebsd2@milibyte.co.uk>
Notes
Notes: svn path=/head/; revision=370055
Diffstat (limited to 'mail/filtermail')
-rw-r--r--mail/filtermail/Makefile43
-rw-r--r--mail/filtermail/distinfo2
-rw-r--r--mail/filtermail/files/patch-src__Makefile.in12
-rw-r--r--mail/filtermail/files/patch-src__filter.hh12
-rw-r--r--mail/filtermail/files/patch-src__preferences.cc19
-rw-r--r--mail/filtermail/pkg-descr8
6 files changed, 96 insertions, 0 deletions
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
new file mode 100644
index 000000000000..d1bb675f6deb
--- /dev/null
+++ b/mail/filtermail/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= filtermail
+PORTVERSION= 0.8.3
+CATEGORIES= mail
+MASTER_SITES= http://sourceforge.net/projects/mailfilter/files/Mailfilter/
+DISTNAME= mailfilter-${PORTVERSION}
+
+MAINTAINER= jmc-filtermail@milibyte.co.uk
+COMMENT= Filter mail on a POP3 server: saves downloading spam
+
+LICENSE= GPLv3
+
+# This port is filtermail, but the author called it mailfilter. To avoid a
+# clash with another port called mailfilter, we change all files
+# installed by this port from the form *mailfilter* to the form
+# *filtermail*, and similarly the names in the man pages.
+#
+EXTRACT_CMD= ${GZIP_CMD}
+EXTRACT_BEFORE_ARGS= -dc
+EXTRACT_AFTER_ARGS= | ${SED} 's/[mM][aA][iI][lL][fF][iI][lL][tT][eE][rR]/filtermail/g' | ${TAR} -xf -
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USES= bison gmake
+GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ man/man5/${PORTNAME}ex.5.gz \
+ man/man5/${PORTNAME}rc.5.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|filtermail.sourceforge|mailfilter.sourceforge|g' ${WRKSRC}/README
+
+post-extract:
+ @${RM} -f ${WRKSRC}/src/getopt.h
+
+.include <bsd.port.mk>
diff --git a/mail/filtermail/distinfo b/mail/filtermail/distinfo
new file mode 100644
index 000000000000..f65cd29806af
--- /dev/null
+++ b/mail/filtermail/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mailfilter-0.8.3.tar.gz) = 60a40e1d35148fd50a2627fc4bbe47626b886614db50f88c0a21d934df63cb7a
+SIZE (mailfilter-0.8.3.tar.gz) = 425337
diff --git a/mail/filtermail/files/patch-src__Makefile.in b/mail/filtermail/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..d6131ef46d5c
--- /dev/null
+++ b/mail/filtermail/files/patch-src__Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig Sat Nov 27 22:29:44 2004
++++ src/Makefile.in Mon Mar 7 22:54:36 2005
+@@ -421,8 +421,6 @@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/apop.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/feedback.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filter.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getopt.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getopt1.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/header.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/imap.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filtermail.Po@am__quote@
+
diff --git a/mail/filtermail/files/patch-src__filter.hh b/mail/filtermail/files/patch-src__filter.hh
new file mode 100644
index 000000000000..5366038c8ecd
--- /dev/null
+++ b/mail/filtermail/files/patch-src__filter.hh
@@ -0,0 +1,12 @@
+--- src/filter.hh.orig Sun Jan 25 21:56:42 2004
++++ src/filter.hh Fri Mar 19 23:19:33 2004
+@@ -21,8 +21,8 @@
+
+ #include <string>
+ extern "C" {
+-#include <regex.h>
+ #include <sys/types.h>
++#include <regex.h>
+ }
+
+ // Filter modes
diff --git a/mail/filtermail/files/patch-src__preferences.cc b/mail/filtermail/files/patch-src__preferences.cc
new file mode 100644
index 000000000000..b7eb55b3aa1b
--- /dev/null
+++ b/mail/filtermail/files/patch-src__preferences.cc
@@ -0,0 +1,19 @@
+--- src/preferences.cc.orig 2007-01-22 23:36:04.000000000 +0100
++++ src/preferences.cc 2008-04-08 17:00:17.000000000 +0200
+@@ -24,6 +24,7 @@
+ #include <vector>
+ #include <stdexcept>
+ #include <cstdio>
++#include <wordexp.h>
+ #include "preferences.hh"
+ #include "filter.hh"
+ #include "filtermail.hh"
+@@ -34,7 +35,7 @@
+
+ extern "C"
+ {
+-#include <wordexp.h>
++#include <glob.h>
+ #include <sys/types.h>
+ #include <regex.h>
+ }
diff --git a/mail/filtermail/pkg-descr b/mail/filtermail/pkg-descr
new file mode 100644
index 000000000000..c53c0f0b5fc7
--- /dev/null
+++ b/mail/filtermail/pkg-descr
@@ -0,0 +1,8 @@
+This is mail/filtermail, a port of mailfilter, renamed because another
+mailfilter exists in the ports tree.
+
+It filters mail on a pop3 server, allowing junk to be deleted on the
+server rather than after it has been downloaded, and integrates with other
+programs such as fetchmail.
+
+WWW: http://mailfilter.sourceforge.net