aboutsummaryrefslogtreecommitdiff
path: root/mail/filtermail
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-19 19:41:35 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-19 19:41:35 +0000
commit6ae3e7efd3f31a7d151bb3e0789b9fb412bcde15 (patch)
treee504488ac6a81f4dbd668d738dfc769193ffa1c9 /mail/filtermail
parentb80b6fcb588383b54c70e623b0aa398affd45bda (diff)
downloadports-6ae3e7efd3f31a7d151bb3e0789b9fb412bcde15.tar.gz
ports-6ae3e7efd3f31a7d151bb3e0789b9fb412bcde15.zip
- Update to version 0.7
PR: ports/64471 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=104656
Diffstat (limited to 'mail/filtermail')
-rw-r--r--mail/filtermail/Makefile13
-rw-r--r--mail/filtermail/distinfo4
-rw-r--r--mail/filtermail/files/patch-src::Makefile.in80
-rw-r--r--mail/filtermail/files/patch-src::filter.hh12
-rw-r--r--mail/filtermail/files/patch-src::preferences.cc51
-rw-r--r--mail/filtermail/files/patch-src::rcfile.ll34
-rw-r--r--mail/filtermail/pkg-plist1
7 files changed, 151 insertions, 44 deletions
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index f4000a9776f8..2dee27d191a9 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -9,8 +9,7 @@
#
PORTNAME= filtermail
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://home.in.tum.de/baueran/%SUBDIR%/
@@ -31,8 +30,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GETOPT_LONG= yes
USE_GETTEXT= yes
-USE_GMAKE= yes
USE_BISON= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -43,13 +42,7 @@ MAN5= filtermailex.5 filtermailrc.5
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502103
-BROKEN= "Build fails on FreeBSD >= 5.x"
-.endif
-
post-extract:
@${RM} -f ${WRKSRC}/src/getopt.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/filtermail/distinfo b/mail/filtermail/distinfo
index f0c4fb45748d..c43b893a106c 100644
--- a/mail/filtermail/distinfo
+++ b/mail/filtermail/distinfo
@@ -1,2 +1,2 @@
-MD5 (mailfilter-0.6.tar.gz) = 00066598d56cd2d9d3ac5c4b43cf1638
-SIZE (mailfilter-0.6.tar.gz) = 482738
+MD5 (mailfilter-0.7.tar.gz) = 015246adff2cf664398d6790cd50e8b7
+SIZE (mailfilter-0.7.tar.gz) = 458864
diff --git a/mail/filtermail/files/patch-src::Makefile.in b/mail/filtermail/files/patch-src::Makefile.in
index d2b558eeb407..09866089e67d 100644
--- a/mail/filtermail/files/patch-src::Makefile.in
+++ b/mail/filtermail/files/patch-src::Makefile.in
@@ -1,38 +1,56 @@
---- src/Makefile.in.orig Mon Oct 27 01:22:52 2003
-+++ src/Makefile.in Sat Nov 8 00:53:16 2003
-@@ -203,7 +203,6 @@
- PopAccount.cc PopAccount.hh \
- RFC822.cc RFC822.hh \
- RegExp.cc RegExp.hh \
+--- src/Makefile.in.orig Sun Feb 15 02:36:23 2004
++++ src/Makefile.in Fri Mar 19 22:58:12 2004
+@@ -198,7 +198,6 @@
+ i18n.hh \
+ rcfile.ll rcfile.hh \
+ rfc822.ll \
- getopt.c getopt.h getopt1.c \
- filtermail.cc filtermail.hh
+ filtermail.hh filtermail.cc \
+ header.hh header.cc \
+ weeder.hh weeder.cc \
+@@ -231,7 +230,7 @@
+ PROGRAMS = $(bin_PROGRAMS)
-
-@@ -226,8 +225,8 @@
- Account.$(OBJEXT) Feedback.$(OBJEXT) rcfile.$(OBJEXT) \
- Preferences.$(OBJEXT) Checker.$(OBJEXT) Connection.$(OBJEXT) \
- SocketConnection.$(OBJEXT) PopAccount.$(OBJEXT) \
-- RFC822.$(OBJEXT) RegExp.$(OBJEXT) getopt.$(OBJEXT) \
-- getopt1.$(OBJEXT) filtermail.$(OBJEXT)
-+ RFC822.$(OBJEXT) RegExp.$(OBJEXT) \
-+ filtermail.$(OBJEXT)
- filtermail_OBJECTS = $(am_filtermail_OBJECTS) \
- $(nodist_filtermail_OBJECTS)
- filtermail_DEPENDENCIES = rcparser.o
-@@ -242,7 +241,6 @@
- @AMDEP_TRUE@ ./$(DEPDIR)/Preferences.Po ./$(DEPDIR)/RFC822.Po \
- @AMDEP_TRUE@ ./$(DEPDIR)/RegExp.Po \
- @AMDEP_TRUE@ ./$(DEPDIR)/SocketConnection.Po \
+ am_filtermail_OBJECTS = md5c.$(OBJEXT) rcfile.$(OBJEXT) rfc822.$(OBJEXT) \
+- getopt.$(OBJEXT) getopt1.$(OBJEXT) filtermail.$(OBJEXT) \
++ filtermail.$(OBJEXT) \
+ header.$(OBJEXT) weeder.$(OBJEXT) preferences.$(OBJEXT) \
+ feedback.$(OBJEXT) filter.$(OBJEXT) score.$(OBJEXT) \
+ account.$(OBJEXT) protocol.$(OBJEXT) socket.$(OBJEXT) \
+@@ -246,7 +245,6 @@
+ am__depfiles_maybe = depfiles
+ @AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/account.Po ./$(DEPDIR)/apop.Po \
+ @AMDEP_TRUE@ ./$(DEPDIR)/feedback.Po ./$(DEPDIR)/filter.Po \
-@AMDEP_TRUE@ ./$(DEPDIR)/getopt.Po ./$(DEPDIR)/getopt1.Po \
- @AMDEP_TRUE@ ./$(DEPDIR)/filtermail.Po ./$(DEPDIR)/md5c.Po \
- @AMDEP_TRUE@ ./$(DEPDIR)/rcfile.Po ./$(DEPDIR)/y.tab.Po
- COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
-@@ -312,8 +310,6 @@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/RFC822.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/RegExp.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/SocketConnection.Po@am__quote@
+ @AMDEP_TRUE@ ./$(DEPDIR)/header.Po ./$(DEPDIR)/filtermail.Po \
+ @AMDEP_TRUE@ ./$(DEPDIR)/md5c.Po ./$(DEPDIR)/pop3.Po \
+ @AMDEP_TRUE@ ./$(DEPDIR)/preferences.Po ./$(DEPDIR)/protocol.Po \
+@@ -315,8 +313,6 @@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/apop.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/feedback.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filter.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getopt.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getopt1.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/header.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filtermail.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/md5c.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rcfile.Po@am__quote@
+@@ -568,8 +564,8 @@
+ rcparser.hh: y.tab.c
+ y.tab.c: rcfile.yy
+ $(YACC) -p rc $(YFLAGS) -o$@ $^; \
+- mv --force y.tab.c rcparser.cc; \
+- mv --force y.tab.h rcparser.hh; \
++ mv -f y.tab.c rcparser.cc; \
++ mv -f y.tab.h rcparser.hh; \
+ $(CXXCOMPILE) -c rcparser.cc; \
+ touch y.tab.c
+
+@@ -580,7 +576,7 @@
+ rfc822parser.hh: rfc822parser.cc
+ rfc822parser.cc: rfc822.yy
+ $(YACC) $(YFLAGS) -p rfc -o$@ $^; \
+- mv --force y.tab.h rcparser.hh; \
++ mv -f y.tab.h rcparser.hh; \
+ $(CXXCOMPILE) -c rfc822parser.cc; \
+ touch y.tab.c
+
diff --git a/mail/filtermail/files/patch-src::filter.hh b/mail/filtermail/files/patch-src::filter.hh
new file mode 100644
index 000000000000..5366038c8ecd
--- /dev/null
+++ b/mail/filtermail/files/patch-src::filter.hh
@@ -0,0 +1,12 @@
+--- src/filter.hh.orig Sun Jan 25 21:56:42 2004
++++ src/filter.hh Fri Mar 19 23:19:33 2004
+@@ -21,8 +21,8 @@
+
+ #include <string>
+ extern "C" {
+-#include <regex.h>
+ #include <sys/types.h>
++#include <regex.h>
+ }
+
+ // Filter modes
diff --git a/mail/filtermail/files/patch-src::preferences.cc b/mail/filtermail/files/patch-src::preferences.cc
new file mode 100644
index 000000000000..651f399560ae
--- /dev/null
+++ b/mail/filtermail/files/patch-src::preferences.cc
@@ -0,0 +1,51 @@
+--- src/preferences.cc.orig Sun Jan 25 21:56:46 2004
++++ src/preferences.cc Fri Mar 19 23:16:27 2004
+@@ -34,7 +34,7 @@
+ #include "rcfile.hh"
+ extern "C"
+ {
+-#include <wordexp.h>
++#include <glob.h>
+ #include <sys/types.h>
+ #include <regex.h>
+ }
+@@ -230,15 +230,15 @@
+ void Preferences :: set_headers_file (const char* name)
+ {
+ // Expand the given file name.
+- wordexp_t result;
+- if (wordexp (name, &result, 0) == 0)
+- headers_file_name = result.we_wordv[0];
++ glob_t result;
++ if (glob (name, 0, NULL, &result) == 0)
++ headers_file_name = result.gl_pathv[0];
+ else
+ {
+ ERROR_MSG(_("Invalid file name: ") + (string)name + ".");
+ exit (-1);
+ }
+- wordfree (&result);
++ globfree (&result);
+ }
+
+ string Preferences :: headers_file (void)
+@@ -256,15 +256,15 @@
+ // command line.
+ if (log_file_name.length () == 0)
+ {
+- wordexp_t result;
+- if (wordexp (name, &result, 0) == 0)
+- log_file_name = result.we_wordv[0];
++ glob_t result;
++ if (glob (name, 0, NULL, &result) == 0)
++ log_file_name = result.gl_pathv[0];
+ else
+ {
+ ERROR_MSG(_("Invalid file name: ") + (string)name + ".");
+ exit (-1);
+ }
+- wordfree (&result);
++ globfree (&result);
+ }
+ }
+
diff --git a/mail/filtermail/files/patch-src::rcfile.ll b/mail/filtermail/files/patch-src::rcfile.ll
new file mode 100644
index 000000000000..305346085f78
--- /dev/null
+++ b/mail/filtermail/files/patch-src::rcfile.ll
@@ -0,0 +1,34 @@
+--- src/rcfile.ll.orig Sun Jan 25 21:56:46 2004
++++ src/rcfile.ll Fri Mar 19 23:18:03 2004
+@@ -44,7 +44,7 @@
+
+ extern "C"
+ {
+-#include "wordexp.h"
++#include "glob.h"
+ }
+
+ using namespace std;
+@@ -125,7 +125,7 @@
+
+ <INCL>[^ \t\n]+ {
+ /* Include further rcfiles: */
+- wordexp_t result;
++ glob_t result;
+
+ if (include_stack_ptr >= MAX_INCLUDE_DEPTH)
+ {
+@@ -136,10 +136,10 @@
+
+ try
+ {
+- if (wordexp (yytext, &result, 0) == 0)
++ if (glob (yytext, 0, NULL, &result) == 0)
+ {
+- sub_file = result.we_wordv[0];
+- wordfree (&result);
++ sub_file = result.gl_pathv[0];
++ globfree (&result);
+ }
+ else
+ {
diff --git a/mail/filtermail/pkg-plist b/mail/filtermail/pkg-plist
index 9f8828e33310..bf3d0e7e24f8 100644
--- a/mail/filtermail/pkg-plist
+++ b/mail/filtermail/pkg-plist
@@ -4,6 +4,5 @@ share/locale/el/LC_MESSAGES/filtermail.mo
share/locale/es/LC_MESSAGES/filtermail.mo
share/locale/fr/LC_MESSAGES/filtermail.mo
share/locale/it/LC_MESSAGES/filtermail.mo
-share/locale/pl/LC_MESSAGES/filtermail.mo
share/locale/pt_BR/LC_MESSAGES/filtermail.mo
share/locale/ru/LC_MESSAGES/filtermail.mo