aboutsummaryrefslogtreecommitdiff
path: root/mail/filtermail
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
commit9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0 (patch)
tree043d479b1d60668b1d77568d010f6178e25bd6ba /mail/filtermail
parentc4823e883be563337dde9dde23949cde6c3fce0f (diff)
downloadports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.tar.gz
ports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.zip
BROKEN on 5.1: bad C++
Notes
Notes: svn path=/head/; revision=81207
Diffstat (limited to 'mail/filtermail')
-rw-r--r--mail/filtermail/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index ce2bd0454df6..88297476b272 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -23,6 +23,12 @@ LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
iconv:${PORTSDIR}/converters/libiconv \
gnugetopt:${PORTSDIR}/devel/libgnugetopt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
@@ -39,4 +45,4 @@ MAN5= filtermailrc.5 filtermailex.5
EXTRACT_AFTER_ARGS= | ${SED} 's/[mM][aA][iI][lL][fF][iI][lL][tT][eE][rR]/filtermail/g' | ${TAR} -xf -
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>