aboutsummaryrefslogtreecommitdiff
path: root/mail/filtermail
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:36:46 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:36:46 +0000
commitb53baaf9b8f46684bcebe28bfe399cef95cad66e (patch)
tree87f30b7330590625607590dfc8a3cf2a2841a135 /mail/filtermail
parentbb5a27fdcefbbbe4b9f56b97a94165408ba7034f (diff)
downloadports-b53baaf9b8f46684bcebe28bfe399cef95cad66e.tar.gz
ports-b53baaf9b8f46684bcebe28bfe399cef95cad66e.zip
get rid of libgnugetopt dependency for -CURRENT.
configure script tests getopt_long() but does not use its result; getopt.o and getopt1.o will always be linked. So libgnugetopt dependency is just redundant.
Notes
Notes: svn path=/head/; revision=84829
Diffstat (limited to 'mail/filtermail')
-rw-r--r--mail/filtermail/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index c131918a7c3e..32a75388ec1b 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -10,6 +10,7 @@
PORTNAME= filtermail
PORTVERSION= 0.2.4
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://home.in.tum.de/baueran/%SUBDIR%/
@@ -20,12 +21,12 @@ MAINTAINER= harry_newton@telinco.co.uk
COMMENT= Filter mail on a pop3 server: saves downloading spam
LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
- iconv:${PORTSDIR}/converters/libiconv \
- gnugetopt:${PORTSDIR}/devel/libgnugetopt
+ iconv:${PORTSDIR}/converters/libiconv
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_GMAKE= yes
MAN1= filtermail.1
@@ -42,7 +43,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
+BROKEN= "Does not compile (bad C++ code)"
.endif
.include <bsd.port.post.mk>