aboutsummaryrefslogtreecommitdiff
path: root/mail/imapfilter
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-24 20:48:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-24 20:48:53 +0000
commit6518529262fa14decfdd2ce5f1206e96ffd98df4 (patch)
tree4048f0648e14b263d9835bfff1a917e6cb4c2897 /mail/imapfilter
parent7c5e870d303690a6e6ec6bf520f9f77450e56246 (diff)
downloadports-6518529262fa14decfdd2ce5f1206e96ffd98df4.tar.gz
ports-6518529262fa14decfdd2ce5f1206e96ffd98df4.zip
- Update to 1.0
PR: ports/67076 Submitted by: Lefteris Chatzibarbas <lefcha@hellug.gr> (maintainer)
Notes
Notes: svn path=/head/; revision=109892
Diffstat (limited to 'mail/imapfilter')
-rw-r--r--mail/imapfilter/Makefile22
-rw-r--r--mail/imapfilter/distinfo4
-rw-r--r--mail/imapfilter/files/patch-aa68
-rw-r--r--mail/imapfilter/pkg-descr25
4 files changed, 66 insertions, 53 deletions
diff --git a/mail/imapfilter/Makefile b/mail/imapfilter/Makefile
index 38fe6aa5a6b5..bcbebd54a734 100644
--- a/mail/imapfilter/Makefile
+++ b/mail/imapfilter/Makefile
@@ -6,26 +6,38 @@
#
PORTNAME= imapfilter
-PORTVERSION= 0.9.6
+PORTVERSION= 1.0
CATEGORIES= mail
MASTER_SITES= http://imapfilter.hellug.gr/source/
MAINTAINER= lefcha@hellug.gr
COMMENT= IMAP mail filtering utility
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+
USE_BZIP2= yes
USE_OPENSSL= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= -d ${PREFIX} -s ${DATADIR}
MAN1= imapfilter.1
-MAN5= imapfilterrc.5
+MAN5= imapfilter_config.5
PORTDOCS= LICENSE NEWS README
-PLIST_FILES= bin/imapfilter ${EXAMPLESDIR:S%${PREFIX}/%%}/sample.imapfilterrc
-PLIST_DIRS= ${EXAMPLESDIR:S%${PREFIX}/%%}
+PLIST_FILES= bin/imapfilter \
+ ${DATADIR:S%${PREFIX}/%%}/interface.lua \
+ ${DATADIR:S%${PREFIX}/%%}/auxiliary.lua \
+ ${EXAMPLESDIR:S%${PREFIX}/%%}/sample.config.lua \
+ ${EXAMPLESDIR:S%${PREFIX}/%%}/sample.extend.lua
+PLIST_DIRS= ${DATADIR:S%${PREFIX}/%%} ${EXAMPLESDIR:S%${PREFIX}/%%}
post-install:
${STRIP_CMD} ${PREFIX}/bin/imapfilter
+ @${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} interface.lua \
+ auxiliary.lua ${DATADIR}
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/sample.imapfilterrc ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} sample.config.lua \
+ sample.extend.lua ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
diff --git a/mail/imapfilter/distinfo b/mail/imapfilter/distinfo
index f2313c7edfe1..ea1de41acf0c 100644
--- a/mail/imapfilter/distinfo
+++ b/mail/imapfilter/distinfo
@@ -1,2 +1,2 @@
-MD5 (imapfilter-0.9.6.tar.bz2) = d84bf9bd0116ce434de836015e6d410f
-SIZE (imapfilter-0.9.6.tar.bz2) = 38251
+MD5 (imapfilter-1.0.tar.bz2) = 417cc5a8b92cb0004946a1e6da381f66
+SIZE (imapfilter-1.0.tar.bz2) = 27816
diff --git a/mail/imapfilter/files/patch-aa b/mail/imapfilter/files/patch-aa
index d42a30be7b15..344ec80d63c0 100644
--- a/mail/imapfilter/files/patch-aa
+++ b/mail/imapfilter/files/patch-aa
@@ -1,35 +1,45 @@
---- Makefile.orig Wed Aug 6 22:00:14 2003
-+++ Makefile Wed Aug 6 22:03:56 2003
-@@ -1,10 +1,9 @@
--CC = cc
--CFLAGS = -O
--LDFLAGS =
--
--DESTDIR = /usr/local
--BINDIR = /usr/local/bin
--MANDIR = /usr/local/man
-+DESTDIR = $(PREFIX)
-+BINDIR = $(PREFIX)/bin
-+MANDIR = $(PREFIX)/man
+--- configure.orig Sun May 23 15:03:23 2004
++++ configure Sun May 23 15:08:27 2004
+@@ -143,16 +143,16 @@
+ SHAREDIR = $sharedir
+ MANDIR = $mandir
+
++INST_BIN = \$(BSD_INSTALL_PROGRAM)
++INST_DOC = \$(BSD_INSTALL_MAN)
+
-+INST_BIN = $(BSD_INSTALL_PROGRAM)
-+INST_DOC = $(BSD_INSTALL_MAN)
+ INCDIRS = $incdirs
+ LIBDIRS = $libdirs
+
+-MYCFLAGS = $mycflags
+-MYLDFLAGS = $myldflags
+-
+ DEFS = $defs
+
+-CFLAGS = \$(MYCFLAGS) \$(DEFS) \$(INCDIRS)
+-LDFLAGS = \$(MYLDFLAGS) \$(LIBDIRS)
++CFLAGS += \$(DEFS) \$(INCDIRS)
++LDFLAGS += \$(LIBDIRS)
+
+ LIBS = $libs
- MAN_BIN = imapfilter.1
- MAN_RC = imapfilterrc.5
-@@ -32,12 +31,9 @@
+@@ -181,17 +181,9 @@
imapfilter.o: version.h
- install: imapfilter
-- if test ! -d $(BINDIR); then mkdir -p $(BINDIR); fi
-- cp -f $(BIN) $(BINDIR) && chmod 0755 $(BINDIR)/$(BIN)
-- if test ! -d $(MANDIR)/man1; then mkdir -p $(MANDIR)/man1; fi
-- cp -f $(MAN_BIN) $(MANDIR)/man1 && chmod 0644 $(MANDIR)/man1/$(MAN_BIN)
-- if test ! -d $(MANDIR)/man5; then mkdir -p $(MANDIR)/man5; fi
-- cp -f $(MAN_RC) $(MANDIR)/man5 && chmod 0644 $(MANDIR)/man5/$(MAN_RC)
-+ $(INST_BIN) $(BIN) $(BINDIR)
-+ $(INST_DOC) $(MAN_BIN) $(MANDIR)/man1
-+ $(INST_DOC) $(MAN_RC) $(MANDIR)/man5
+ install: \$(BIN)
+- if test ! -d \$(BINDIR); then mkdir -p \$(BINDIR); fi
+- cp -f \$(BIN) \$(BINDIR) && chmod 0755 \$(BINDIR)/\$(BIN)
+- if test ! -d \$(SHAREDIR); then mkdir -p \$(SHAREDIR); fi
+- cp -f \$(INTERFACE_LUA) \$(SHAREDIR) && \\
+- chmod 0644 \$(SHAREDIR)/\$(INTERFACE_LUA)
+- cp -f \$(AUXILIARY_LUA) \$(SHAREDIR) && \\
+- chmod 0644 \$(SHAREDIR)/\$(AUXILIARY_LUA)
+- if test ! -d \$(MANDIR)/man1; then mkdir -p \$(MANDIR)/man1; fi
+- cp -f \$(MAN_BIN) \$(MANDIR)/man1 && chmod 0644 \$(MANDIR)/man1/\$(MAN_BIN)
+- if test ! -d \$(MANDIR)/man5; then mkdir -p \$(MANDIR)/man5; fi
+- cp -f \$(MAN_CONFIG) \$(MANDIR)/man5 && chmod 0644 \$(MANDIR)/man5/\$(MAN_CONFIG)
++ \$(INST_BIN) \$(BIN) \$(BINDIR)
++ \$(INST_DOC) \$(MAN_BIN) \$(MANDIR)/man1
++ \$(INST_DOC) \$(MAN_CONFIG) \$(MANDIR)/man5
deinstall:
- rm -f $(BINDIR)/$(BIN) $(MANDIR)/man1/$(MAN_BIN) $(MANDIR)/man5/$(MAN_RC)
+ rm -f \$(BINDIR)/\$(BIN) \$(SHAREDIR)/\$(INTERFACE_LUA) \\
diff --git a/mail/imapfilter/pkg-descr b/mail/imapfilter/pkg-descr
index e5d5c738c19f..ed634120a74d 100644
--- a/mail/imapfilter/pkg-descr
+++ b/mail/imapfilter/pkg-descr
@@ -1,20 +1,11 @@
-IMAPFilter is an IMAP mail filtering utility, which based on user defined
-rules, processes mail residing in IMAP mailboxes without downloading them.
-Available searching criteria, which can be combined using logical operators
-(and/or/not), include the matching of a string in the headers or body of
-messages, the size, date or status of them. Different actions can be applied
-such as deletion, copying or moving of messages to mailboxes in the same or
-different mail server, and changing of their flags.
-
-IMAPFilter additionally supports connection encryption through either imaps SSL
-wrapped session or the IMAP STARTTLS extension and user authentication using
-the CRAM-MD5 mechanism. Other features also include encryption and secure
-storing in the filesystem of the user's passwords, running in daemon mode,
-support for the IMAP NAMESPACE extension.
-
-IMAPfilter is purposed as a preconnect utility before a user fetches his/her
-mail, accesses his/her mailboxes with one of the available mail user agents or
-browses them via the Web.
+IMAPFilter is a mail filtering utility. It connects to remote mail servers
+using the Internet Message Access Protocol (IMAP), sends searching queries to
+the server and processes mailboxes based on the results. It can be used to
+delete, copy, move, flag, etc. messages residing in mailboxes at the same or
+different mail servers.
+
+IMAPFilter uses the Lua programming language as a configuration and extension
+language.
WWW: http://imapfilter.hellug.gr