aboutsummaryrefslogtreecommitdiff
path: root/mail/isoqlog
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-07-20 16:39:49 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-07-20 16:39:49 +0000
commit1135846b6fa437b7c04c8ef20e72ad96651e475f (patch)
treeb65824af064ca2f21cd2c08412bb206aa9f2bee8 /mail/isoqlog
parente7690885fd83ccaab97ab6d71c490c0b06763654 (diff)
downloadports-1135846b6fa437b7c04c8ef20e72ad96651e475f.tar.gz
ports-1135846b6fa437b7c04c8ef20e72ad96651e475f.zip
Add isoqlog, it's an MTA log analysis program written in C.
PR: ports/40720 Submitted by: Omer Faruk Sen <roots@enderunix.org>
Notes
Notes: svn path=/head/; revision=63276
Diffstat (limited to 'mail/isoqlog')
-rw-r--r--mail/isoqlog/Makefile23
-rw-r--r--mail/isoqlog/distinfo1
-rw-r--r--mail/isoqlog/files/patch-htmltemp::images::Makefile.in13
-rw-r--r--mail/isoqlog/pkg-comment1
-rw-r--r--mail/isoqlog/pkg-descr24
-rw-r--r--mail/isoqlog/pkg-message10
-rw-r--r--mail/isoqlog/pkg-plist55
7 files changed, 127 insertions, 0 deletions
diff --git a/mail/isoqlog/Makefile b/mail/isoqlog/Makefile
new file mode 100644
index 000000000000..fa7a49de3b3e
--- /dev/null
+++ b/mail/isoqlog/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: isoqlog
+# Date created: 17 June 2002
+# Whom: Omer Faruk Sen <roots@enderunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= isoqlog
+PORTVERSION= 2.0
+CATEGORIES= mail
+MASTER_SITES= http://www.enderunix.org/isoqlog/ \
+ http://www.trunix.org/isogloq/ \
+ http://www.acikkod.org/softwares/
+
+MAINTAINER= roots@enderunix.org
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
+
+.include <bsd.port.mk>
diff --git a/mail/isoqlog/distinfo b/mail/isoqlog/distinfo
new file mode 100644
index 000000000000..3279118545ea
--- /dev/null
+++ b/mail/isoqlog/distinfo
@@ -0,0 +1 @@
+MD5 (isoqlog-2.0.tar.gz) = b64ac68f671a93fbd6c96e6facb3169c
diff --git a/mail/isoqlog/files/patch-htmltemp::images::Makefile.in b/mail/isoqlog/files/patch-htmltemp::images::Makefile.in
new file mode 100644
index 000000000000..1a27792aa418
--- /dev/null
+++ b/mail/isoqlog/files/patch-htmltemp::images::Makefile.in
@@ -0,0 +1,13 @@
+--- htmltemp/images/Makefile.in.orig Sun Jul 21 00:20:41 2002
++++ htmltemp/images/Makefile.in Sun Jul 21 00:32:31 2002
+@@ -72,7 +72,9 @@
+
+ images_DATA = isoqlog.gif \
+ dot.gif \
+- pk.gif
++ pk.gif \
++ home.gif \
++ up.gif
+
+ subdir = htmltemp/images
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/mail/isoqlog/pkg-comment b/mail/isoqlog/pkg-comment
new file mode 100644
index 000000000000..8092736b567a
--- /dev/null
+++ b/mail/isoqlog/pkg-comment
@@ -0,0 +1 @@
+A MTA log analysis program supporting qmail, postfix, sendmail
diff --git a/mail/isoqlog/pkg-descr b/mail/isoqlog/pkg-descr
new file mode 100644
index 000000000000..3f9fb9d8e529
--- /dev/null
+++ b/mail/isoqlog/pkg-descr
@@ -0,0 +1,24 @@
+Isoqlog is an MTA log analysis program written in C.It designed to scan qmail,
+postfix, sendmail logfile and produce usage statistics in HTML format for
+viewing through a browser.It produces Top domains output according to Incoming,
+Outgoing, total mails and bytes, it keeps your main domain mail statistics
+with Days Top Domain, Top Users values for per day, per month, and years.
+
+Features:
+--------
+* Multi MTA support(qmail (multilog and syslog), postfix, sendmail)
+* Multi-domain support: Shows quite detailed statistics for not only your main
+domain, but also, any domain you want.
+* Displays statistics for common mail delivery errors.
+* For each domain you specify; displays Top incoming, outgoing, total and byte
+based statistics for users.
+* Displays server's activity based on incoming, outgoing, total mails and size
+of incoming mail, for domain and its users.
+* All days', all months', all years' activities ( above ones ) are stored for
+future inspection.
+* Multi-language Support ( Turkish, English, German,Portuguese,Spanish ,
+Italian, French, Swedish, Dutch, Polish, Norwegian)
+
+WWW: http://www.enderunix.org/isoqlog
+- EnderUNIX SDT @ Turkey
+roots@enderunix.org
diff --git a/mail/isoqlog/pkg-message b/mail/isoqlog/pkg-message
new file mode 100644
index 000000000000..7b956caa2532
--- /dev/null
+++ b/mail/isoqlog/pkg-message
@@ -0,0 +1,10 @@
+
+First edit %%PREFIX%%/etc/isoqlog.conf
+After that edit %%PREFIX%%/etc/isqlog.domains
+
+Finally you have to add a crontab entry in order to get isoqlog work like:
+
+58 * * * * %%PREFIX%%/bin/isoqlog 1>/dev/null 2>/dev/null
+
+You can read %%PREFIX%%/share/doc/isoqlog/EnderUNIX about our other projects
+
diff --git a/mail/isoqlog/pkg-plist b/mail/isoqlog/pkg-plist
new file mode 100644
index 000000000000..82e89a85421c
--- /dev/null
+++ b/mail/isoqlog/pkg-plist
@@ -0,0 +1,55 @@
+bin/isoqlog
+@unexec if cmp -s %D/etc/isoqlog.conf %D/etc/isoqlog.conf-dist; then rm -f %D/etc/isoqlog.conf; fi
+etc/isoqlog.conf-dist
+@exec [ -f %B/isoqlog.conf ] || cp %B/%f %B/isoqlog.conf
+@unexec if cmp -s %D/etc/isoqlog.domains %D/etc/isoqlog.domains-dist; then rm -f %D/etc/isoqlog.domains; fi
+etc/isoqlog.domains-dist
+@exec [ -f %B/isoqlog.domains ] || cp %B/%f %B/isoqlog.domains
+share/doc/isoqlog/AUTHORS
+share/doc/isoqlog/ChangeLog
+share/doc/isoqlog/COPYING
+share/doc/isoqlog/EnderUNIX
+share/doc/isoqlog/INSTALL
+share/doc/isoqlog/NEWS
+share/doc/isoqlog/README
+share/doc/isoqlog/README.Turkish
+share/doc/isoqlog/TODO
+share/doc/isoqlog/tr/BENIOKU
+share/doc/isoqlog/tr/DEGISIKLIKLER
+share/doc/isoqlog/tr/HABERLER
+share/doc/isoqlog/tr/KOPYALAMA
+share/doc/isoqlog/tr/KURULUM
+share/doc/isoqlog/tr/YAZARLAR
+share/isoqlog/htmltemp/daily.html
+share/isoqlog/htmltemp/days.html
+share/isoqlog/htmltemp/domain.html
+share/isoqlog/htmltemp/index.html
+share/isoqlog/htmltemp/generaldaily.html
+share/isoqlog/htmltemp/generaldomain.html
+share/isoqlog/htmltemp/generalmonthly.html
+share/isoqlog/htmltemp/generalyearly.html
+share/isoqlog/htmltemp/monthly.html
+share/isoqlog/htmltemp/images/dot.gif
+share/isoqlog/htmltemp/images/home.gid
+share/isoqlog/htmltemp/images/isoqlog.gif
+share/isoqlog/htmltemp/images/pk.gif
+share/isoqlog/htmltemp/images/up.gif
+share/isoqlog/htmltemp/library/isoqlog.css
+share/isoqlog/lang/dutch
+share/isoqlog/lang/english
+share/isoqlog/lang/french
+share/isoqlog/lang/german
+share/isoqlog/lang/italian
+share/isoqlog/lang/norwegian
+share/isoqlog/lang/polish
+share/isoqlog/lang/portuguese
+share/isoqlog/lang/spanish
+share/isoqlog/lang/swedish
+share/isoqlog/lang/turkish
+@dirrm share/doc/isoqlog/tr
+@dirrm share/doc/isoqlog
+@dirrm share/isoqlog/htmltemp/images
+@dirrm share/isoqlog/htmltemp/library
+@dirrm share/isoqlog/htmltemp
+@dirrm share/isoqlog/lang
+@dirrm share/isoqlog