aboutsummaryrefslogtreecommitdiff
path: root/mail/isync
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-03-19 19:03:03 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-03-19 19:03:03 +0000
commitc424ef8a01e097deadcef5f5d69d52f2089a66d4 (patch)
treed31509df9e2e2e506a4a31e0b57a7d7fa9ed4362 /mail/isync
parentc54e9cf6f60e727e0a62e11308774fb76171133b (diff)
downloadports-c424ef8a01e097deadcef5f5d69d52f2089a66d4.tar.gz
ports-c424ef8a01e097deadcef5f5d69d52f2089a66d4.zip
Provide an upstream patch that fixes an issue with duplication loops when using
davmail and moving mails around in folders. PR: 236635 Submitted by: sascha@root-login.org
Notes
Notes: svn path=/head/; revision=496289
Diffstat (limited to 'mail/isync')
-rw-r--r--mail/isync/Makefile2
-rw-r--r--mail/isync/files/patch-src_drv__imap.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/mail/isync/Makefile b/mail/isync/Makefile
index 4f9dc0f0a0cf..79ff6200700d 100644
--- a/mail/isync/Makefile
+++ b/mail/isync/Makefile
@@ -3,7 +3,7 @@
PORTNAME= isync
PORTVERSION= 1.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= SF
diff --git a/mail/isync/files/patch-src_drv__imap.c b/mail/isync/files/patch-src_drv__imap.c
new file mode 100644
index 000000000000..c052af79b34c
--- /dev/null
+++ b/mail/isync/files/patch-src_drv__imap.c
@@ -0,0 +1,20 @@
+--- src/drv_imap.c.orig 2019-03-19 09:37:32 UTC
++++ src/drv_imap.c
+@@ -2388,7 +2388,7 @@ imap_open_box_p2( imap_store_t *ctx, imap_cmd_t *gcmd,
+ INIT_IMAP_CMD(imap_cmd_open_box_t, cmd, cmdp->callback, cmdp->callback_aux)
+ cmd->gen.param.lastuid = 1;
+ imap_exec( ctx, &cmd->gen, imap_open_box_p3,
+- "UID FETCH *:* (UID)" );
++ "UID FETCH * (UID)" );
+ }
+
+ static void
+@@ -2922,7 +2922,7 @@ imap_find_new_msgs_p2( imap_store_t *ctx, imap_cmd_t *
+ cmd->uid = cmdp->uid;
+ cmd->gen.param.lastuid = 1;
+ imap_exec( ctx, &cmd->gen, imap_find_new_msgs_p3,
+- "UID FETCH *:* (UID)" );
++ "UID FETCH * (UID)" );
+ }
+
+ static void