aboutsummaryrefslogtreecommitdiff
path: root/mail/libcmime
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:07:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:07:03 +0000
commit095536f07438c1106fd7fbc92a4027b4bbe9bf9c (patch)
tree135b48270eb7c0b969ecfaa44c2256cf3508e055 /mail/libcmime
parentc6c1772f2a7be6bdcbd7477f261487c8e82a15c1 (diff)
downloadports-095536f07438c1106fd7fbc92a4027b4bbe9bf9c.tar.gz
ports-095536f07438c1106fd7fbc92a4027b4bbe9bf9c.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
- Switch to options helpers - Fix plist for DOXYGEN option Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=430945
Diffstat (limited to 'mail/libcmime')
-rw-r--r--mail/libcmime/Makefile48
-rw-r--r--mail/libcmime/pkg-plist6
2 files changed, 20 insertions, 34 deletions
diff --git a/mail/libcmime/Makefile b/mail/libcmime/Makefile
index 53609ed3f57a..57252afbeea4 100644
--- a/mail/libcmime/Makefile
+++ b/mail/libcmime/Makefile
@@ -16,40 +16,17 @@ USES= bison cmake pkgconfig
USE_LDCONFIG= yes
CMAKE_ARGS= --no-warn-unused-cli
-OPTIONS_DEFINE= DEBUG DOCS DOXYGEN
-OPTIONS_SUB= yes
-DOCS_ALL_TARGET=doc
-
PORTDOCS= AUTHORS CHANGELOG INSTALL README
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} < 1000033
-BUILD_DEPENDS+= flex>=2.5.33:textproc/flex
-CMAKE_ARGS+= -DFLEX_EXECUTABLE:FILEPATH=${LOCALBASE}/bin/flex
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CMAKE_ARGS+= -DENABLE_DEBUG=TRUE
-.endif
-
-.if ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS+= doxygen>=1.8:devel/doxygen \
- dot:graphics/graphviz
-CMAKE_ARGS+= -DENABLE_DOC=TRUE
-.endif
+OPTIONS_DEFINE= DEBUG DOCS DOXYGEN
+OPTIONS_SUB= yes
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
-
-.if ${PORT_OPTIONS:MDOXYGEN}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
-.endif
+DOCS_ALL_TARGET= doc
+DEBUG_CMAKE_BOOL= ENABLE_DEBUG
+DOXYGEN_IMPLIES= DOCS
+DOXYGEN_BUILD_DEPENDS= doxygen>=1.8:devel/doxygen \
+ dot:graphics/graphviz
+DOXYGEN_CMAKE_BOOL= ENABLE_DOC
post-patch:
@${REINPLACE_CMD} -E -e 's|\$${CMAKE_INSTALL_LIBDIR}(/pkgconfig)|$${CMAKE_INSTALL_PREFIX}/libdata\1|' \
@@ -59,4 +36,13 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|STRIP_FROM_PATH = ../src|STRIP_FROM_PATH = ../|' \
${WRKSRC}/Doxyfile.cmake
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+post-install-DOXYGEN-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
+
.include <bsd.port.mk>
diff --git a/mail/libcmime/pkg-plist b/mail/libcmime/pkg-plist
index c6e3408e1863..e1373ff90938 100644
--- a/mail/libcmime/pkg-plist
+++ b/mail/libcmime/pkg-plist
@@ -103,10 +103,10 @@ libdata/pkgconfig/libcmime.pc
%%DOXYGEN%%%%DOCSDIR%%/html/dir_14dd74dc80f24763b120f0ff163f9df8_dep.map
%%DOXYGEN%%%%DOCSDIR%%/html/dir_14dd74dc80f24763b120f0ff163f9df8_dep.md5
%%DOXYGEN%%%%DOCSDIR%%/html/dir_14dd74dc80f24763b120f0ff163f9df8_dep.png
-%%DOXYGEN%%%%DOCSDIR%%/html/dir_1edc0395ad56873333946c4638ce0128.html
-%%DOXYGEN%%%%DOCSDIR%%/html/dir_3f183ecd10d967a2074c4220b91bc697.html
+%%DOXYGEN%%%%DOCSDIR%%/html/dir_2bb7f550d8e697095cc7f47e9f37ad22.html
%%DOXYGEN%%%%DOCSDIR%%/html/dir_5c5ffee34b892d1b4d0cf55593804adf.html
-%%DOXYGEN%%%%DOCSDIR%%/html/dir_864d32d2116dbbcddccfb73d1326ff18.html
+%%DOXYGEN%%%%DOCSDIR%%/html/dir_67f864eb8ebacc07ebdb04fb5b180557.html
+%%DOXYGEN%%%%DOCSDIR%%/html/dir_7e106de535c2fdcdb6daafe445d0af81.html
%%DOXYGEN%%%%DOCSDIR%%/html/dir_e428b993447293e8c40322f1ce81b90e.html
%%DOXYGEN%%%%DOCSDIR%%/html/dir_fb5e4eb41281a43f514336e9345ffcea.html
%%DOXYGEN%%%%DOCSDIR%%/html/dir_fb5e4eb41281a43f514336e9345ffcea_dep.map