aboutsummaryrefslogtreecommitdiff
path: root/mail/libetpan
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
commit2fa62596744270745d9d0540f5bbd839f6b78d23 (patch)
treeb7e5a1ec8ce92178c23aff878c9671b8c96b7b89 /mail/libetpan
parente496938a05b08a6dc0a4f3562f7615a574354e2e (diff)
downloadports-2fa62596744270745d9d0540f5bbd839f6b78d23.tar.gz
ports-2fa62596744270745d9d0540f5bbd839f6b78d23.zip
Convert my ports to optionsNG
Notes
Notes: svn path=/head/; revision=298711
Diffstat (limited to 'mail/libetpan')
-rw-r--r--mail/libetpan/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index 8eb0fd201b83..ab9f9c6e5a91 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -29,21 +29,29 @@ MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-OPTIONS= GNUTLS "Enable gnuTLS support" off \
- IPV6 "Enable ipv6 support." on
+OPTIONS_DEFINE= IPV6
+OPTIONS_SINGLE= CRYPTO
+OPTIONS_SINGLE_CRYPTO= GNUTLS OPENSSL
+GNUTLS_DESC= Enable GNUTLS support
+OPENSSL_DESC= Enable OpenSSL support
+OPTIONS_DEFAULT= IPV6 OPENSSL
-.if defined(WITH_GNUTLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --without-openssl --with-gnutls
-.else
+.endif
+
+.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+= --without-gnutls
.endif
-.if defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --disable-ipv6
-.else
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
.endif
AUTOTOOLSFILES= aclocal.m4