aboutsummaryrefslogtreecommitdiff
path: root/mail/libetpan
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
commite482e392f687b2248d2975d68327324a858e1273 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /mail/libetpan
parent5183b406511b98ffef72263a3609234aaaa0d4fb (diff)
downloadports-e482e392f687b2248d2975d68327324a858e1273.tar.gz
ports-e482e392f687b2248d2975d68327324a858e1273.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Notes
Notes: svn path=/head/; revision=322729
Diffstat (limited to 'mail/libetpan')
-rw-r--r--mail/libetpan/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index a3eed9098c55..c6bcfb3bdb30 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
USE_AUTOTOOLS= libtool autoconf
AUTOTOOLSFILES= aclocal.m4
-USE_GMAKE= yes
-USES= iconv
+USES= gmake iconv
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
@@ -31,23 +30,18 @@ OPTIONS_SINGLE= CRYPTO
OPTIONS_SINGLE_CRYPTO= GNUTLS OPENSSL
OPTIONS_DEFAULT= OPENSSL
-.include <bsd.port.options.mk>
+GNUTLS_CONFIGURE_ON= --without-openssl --with-gnutls
+GNUTLS_LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
+ gcrypt:${PORTSDIR}/security/libgcrypt
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt
-CONFIGURE_ARGS+= --without-openssl --with-gnutls
-.endif
+IPV6_CONFIGURE_ENABLE= ipv6
+
+OPENSSL_CONFIGURE_ON= --without-gnutls
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
-CONFIGURE_ARGS+= --without-gnutls
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
.endif
post-patch: