aboutsummaryrefslogtreecommitdiff
path: root/mail/lmtp2nntp
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-23 08:50:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-23 08:50:30 +0000
commit51fe2cda5716e43050a7969d8abdddd74c37dce2 (patch)
treed40981b00bc399a8b9d44767bb99352e7c8bfadb /mail/lmtp2nntp
parent0c0513b71ffc82283d5aa3e58dacea65a93355bf (diff)
downloadports-51fe2cda5716e43050a7969d8abdddd74c37dce2.tar.gz
ports-51fe2cda5716e43050a7969d8abdddd74c37dce2.zip
- Attempt to unbreak parallel (-jX) builds by fixing targets dependencies
- Convert NOPORTDOCS -> PORT_OPTIONS:MDOCS, modernize LIB_DEPENDS - Connect "check" target to our standard "regression-test" that automated package builders know about - Trim the header and drop check for alpha: unfortunately, it's long gone Reported by: marino Approved by: miwi, bapt (portmgr, implicit)
Notes
Notes: svn path=/head/; revision=325257
Diffstat (limited to 'mail/lmtp2nntp')
-rw-r--r--mail/lmtp2nntp/Makefile45
1 files changed, 21 insertions, 24 deletions
diff --git a/mail/lmtp2nntp/Makefile b/mail/lmtp2nntp/Makefile
index 81ba2a28851e..f68381767d91 100644
--- a/mail/lmtp2nntp/Makefile
+++ b/mail/lmtp2nntp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lmtp2nntp
-# Date created: 12 November 2001
-# Whom: Thomas Lotterer <thomas.lotterer@cw.com>
-#
+# Created by: Thomas Lotterer <thomas.lotterer@cw.com>
# $FreeBSD$
-#
PORTNAME= lmtp2nntp
PORTVERSION= 1.4.1
@@ -14,10 +10,10 @@ MASTER_SITE_SUBDIR= tool/${PORTNAME}
MAINTAINER= vd@FreeBSD.org
COMMENT= OSSP mail to news gateway
-LIB_DEPENDS= str.9:${PORTSDIR}/devel/str \
- ex.10:${PORTSDIR}/devel/ossp-ex \
- sa.12:${PORTSDIR}/net/ossp-sa \
- var.11:${PORTSDIR}/devel/ossp-var
+LIB_DEPENDS= libstr.so:${PORTSDIR}/devel/str \
+ libex.so:${PORTSDIR}/devel/ossp-ex \
+ libsa.so:${PORTSDIR}/net/ossp-sa \
+ libvar.so:${PORTSDIR}/devel/ossp-var
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ex=${LOCALBASE} --with-str=${LOCALBASE} \
@@ -25,26 +21,27 @@ CONFIGURE_ARGS= --with-ex=${LOCALBASE} --with-str=${LOCALBASE} \
MAN8= lmtp2nntp.8
PLIST_FILES= sbin/lmtp2nntp
-
-.if !defined(NOPORTDOCS)
PORTDOCS= INSTALL README
-.endif
-check: build
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+# Try to fix parallel builds (-jX)
+post-patch:
+ @${REINPLACE_CMD} -e '/^all:/s, _SUBDIRS_all,, ; \
+ /^$$(PROG)/s,$$, _SUBDIRS_all,' ${WRKSRC}/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}/
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
+check: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} check)
-.if ${ARCH} == "alpha"
-BROKEN= Does not compile on alpha
-.endif
+regression-test: check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>