aboutsummaryrefslogtreecommitdiff
path: root/mail/mailagent
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1998-09-19 10:49:02 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1998-09-19 10:49:02 +0000
commite52c5930cd00e4f914e7585f4b0ec60cf2bea900 (patch)
treec09f053c70640ef72a585dbffb2a129f34c77712 /mail/mailagent
parent9f5ed4e44d89a9bd0311e151a593677cd0ed659d (diff)
downloadports-e52c5930cd00e4f914e7585f4b0ec60cf2bea900.tar.gz
ports-e52c5930cd00e4f914e7585f4b0ec60cf2bea900.zip
Update this port so that it uses correct perl5.
Some portlint fixes.
Notes
Notes: svn path=/head/; revision=13243
Diffstat (limited to 'mail/mailagent')
-rw-r--r--mail/mailagent/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index 4d47f5ea82e1..f368b19748e4 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 Sep 1996
# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.23 1998/04/04 09:08:00 max Exp $
+# $Id: Makefile,v 1.24 1998/08/10 12:39:39 max Exp $
#
DISTNAME= mailagent-3.0@63
@@ -20,27 +20,26 @@ IS_INTERACTIVE= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -dres \
- -Dperlpath='${PERLPATH}/perl' \
+ -Dperlpath='${PERL5}' \
-Dutmp='/var/run/utmp' \
-Dprefix='${PREFIX}' -Dmansrc='${PREFIX}/man/man1' \
-Dnotifypatches='false'
-MAKE_ENV= PATH=${PERLPATH}:${PATH}
+MAKE_ENV= PATH=`dirname ${PERL5}`:${PATH}
INSTALL_TARGET= install install.man
# Note that mailhelp.1 is intentionally left uncompressed as it is referred
# from several other man pages with .so macro.
MAN1= edusers.1 mailagent.1 maildist.1 \
maillist.1 mailpatch.1 package.1
-PERLPATH?= ${PREFIX}/bin
pre-extract:
@if [ `${SH} -c umask` != 0022 ]; then \
- echo "Please set umask to 022 before running make,"; \
- echo "or mailagent will not build successfully."; \
- false; fi
+ ${ECHO} "Please set umask to 022 before running make,"; \
+ ${ECHO} "or mailagent will not build successfully."; \
+ ${FALSE}; fi
@if [ `id -u` = 0 ]; then \
- echo "Do not build mailagent as root or it won't pass the sanity tests."; \
- false; fi
+ ${ECHO} "Do not build mailagent as root or it won't pass the sanity tests."; \
+ ${FALSE}; fi
post-install:
@${MKDIR} ${PREFIX}/share/examples/mailagent/agent