aboutsummaryrefslogtreecommitdiff
path: root/mail/mailagent
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2013-04-30 12:19:06 +0000
committerStefan Walter <stefan@FreeBSD.org>2013-04-30 12:19:06 +0000
commite74f6dbefa50452aa08729e88344c6eed51192e2 (patch)
tree29746eba37edccacd9cd96ea02aa9d60f4e68201 /mail/mailagent
parentf743ddb190264fea63405532237b576c2177db0e (diff)
downloadports-e74f6dbefa50452aa08729e88344c6eed51192e2.tar.gz
ports-e74f6dbefa50452aa08729e88344c6eed51192e2.zip
- Update to 3.1.77. [1]
- Fix build on 9.x. [1] - Convert Makefile header to new style and fix a couple of portlint warnings. PR: 164306 [1] Submitted by: Yoshiaki Kasahara <kasahara@nc.kyushu-u.ac.jp> [1]
Notes
Notes: svn path=/head/; revision=316925
Diffstat (limited to 'mail/mailagent')
-rw-r--r--mail/mailagent/Makefile16
-rw-r--r--mail/mailagent/distinfo4
-rw-r--r--mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_Makefile.SH20
-rw-r--r--mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_utmp.pl25
4 files changed, 56 insertions, 9 deletions
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index b698065170c0..5a162998d838 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: mailagent
-# Date created: 23 Sep 1996
-# Whom: Masafumi NAKANE <max@FreeBSD.org>
-#
+# Created by: Masafumi NAKANE <max@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mailagent
-PORTVERSION= 3.1.71
+PORTVERSION= 3.1.77
CATEGORIES= mail
MASTER_SITES= http://eron.info/
@@ -34,6 +30,12 @@ MAN1= edusers.1 mailagent.1 package.1 mailhelp.1
MLINKS= mailhelp.1 maildist.1 mailhelp.1 mailpatch.1 \
mailhelp.1 maillist.1
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900006
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-utmpx-agent_pl_utmp_utmp.pl \
+ ${PATCHDIR}/extra-patch-utmpx-agent_pl_utmp_Makefile.SH
+.endif
+
pre-extract:
@if [ `${SH} -c umask` != 0022 ]; then \
${ECHO} "Please set umask to 022 before running make,"; \
@@ -58,4 +60,4 @@ post-install:
${CP} -pR ${WRKSRC}/misc/* ${EXAMPLESDIR}/misc
@${LN} -fs ${PREFIX}/lib/mailagent/examples ${EXAMPLESDIR}/agent
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/mailagent/distinfo b/mail/mailagent/distinfo
index 9ed84cb51d53..f75154ce976b 100644
--- a/mail/mailagent/distinfo
+++ b/mail/mailagent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mailagent-3.1.71.tar.bz2) = 4785a018797d4405f8708ba59197f249f77cd4f22f87b086c04c7226cb64ebdb
-SIZE (mailagent-3.1.71.tar.bz2) = 446820
+SHA256 (mailagent-3.1.77.tar.bz2) = 89d399ee9aa87399070309e18b1e4237edf62b345ee1d8061202913de8e027b3
+SIZE (mailagent-3.1.77.tar.bz2) = 450202
diff --git a/mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_Makefile.SH b/mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_Makefile.SH
new file mode 100644
index 000000000000..dec69898cb5e
--- /dev/null
+++ b/mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_Makefile.SH
@@ -0,0 +1,20 @@
+--- ../mailagent-3.1.77/agent/pl/utmp/Makefile.SH 2006-08-24 22:24:12.354556000 +0900
++++ agent/pl/utmp/Makefile.SH 2012-01-19 17:37:50.697895588 +0900
+@@ -107,7 +107,6 @@
+ cp Makefile.new Makefile
+ $(RM) Makefile.new
+
+-all:: utmp_ph
+
+ local_realclean::
+ $(RM) utmp_ph
+@@ -122,8 +121,7 @@
+ local_realclean::
+ $(RM) utmp.pl
+
+-utmp.pl: utmp_pl.sh utmp_ph
+- /bin/sh utmp_pl.sh
++utmp.pl:
+
+ ########################################################################
+ # Common rules for all Makefiles -- do not edit
diff --git a/mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_utmp.pl b/mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_utmp.pl
new file mode 100644
index 000000000000..50cdf1195c9f
--- /dev/null
+++ b/mail/mailagent/files/extra-patch-utmpx-agent_pl_utmp_utmp.pl
@@ -0,0 +1,25 @@
+--- /dev/null 2012-01-19 17:47:14.000000000 +0900
++++ agent/pl/utmp/utmp.pl 2012-01-19 17:53:06.536872534 +0900
+@@ -0,0 +1,22 @@
++#
++# utmp file primitives
++#
++
++package utmp;
++
++# Return the ttys on which a given user is logged
++sub ttys {
++ local($user) = @_; # User's login name
++ local(@u);
++ open(WHO, '/usr/bin/who |') || warn "Can't invoke /usr/bin/who: $!\n";
++ while (<WHO>) {
++ next unless /^$user\s/;
++ my ($name, $line, $dummy) = split;
++ push(@u, $line);
++ }
++ close WHO;
++ return @u; # Returns array of ttys
++}
++
++package main;
++