aboutsummaryrefslogtreecommitdiff
path: root/mail/maildrop
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-07 13:12:31 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-07 13:12:31 +0000
commit53ad8315b0a2ef773e5e5f74a380bab573e4d008 (patch)
tree5522ebdbbbc41a02fbc8bf3da8fa96b3719b6d61 /mail/maildrop
parentc0af1ccd5f350208e51572a7122f075c545462ec (diff)
downloadports-53ad8315b0a2ef773e5e5f74a380bab573e4d008.tar.gz
ports-53ad8315b0a2ef773e5e5f74a380bab573e4d008.zip
Add some shebangfix to allow building most of the ports tree without /usr/bin/perl
Submitted by: John Marino Obtained from: DPorts
Notes
Notes: svn path=/head/; revision=317605
Diffstat (limited to 'mail/maildrop')
-rw-r--r--mail/maildrop/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index 96a453dd376e..f99a44003738 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -17,7 +17,7 @@
PORTNAME= maildrop
PORTVERSION= 2.6.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= SF/courier/${PORTNAME}/${PORTVERSION}
@@ -31,7 +31,7 @@ USE_GMAKE= yes
.endif
USE_BZIP2= yes
USE_PERL5= yes
-USES= iconv
+USES= iconv shebangfix
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --enable-syslog=1 \
@@ -41,6 +41,8 @@ CONFIGURE_ARGS= --enable-syslog=1 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+SHEBANG_FILES= unicode/*.pl
+
CONFLICTS= courier-0.65*
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre