aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-03-02 08:34:40 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-03-02 08:34:40 +0000
commit240fff7e0bfb05ba19935588360a22ceaf6d5516 (patch)
tree31a30a84086889c1d71559ec5965c42bda3e216e /mail/mailman
parent536a7e97be6ef9f6a786998b68c3c2a3e55abb4f (diff)
downloadports-240fff7e0bfb05ba19935588360a22ceaf6d5516.tar.gz
ports-240fff7e0bfb05ba19935588360a22ceaf6d5516.zip
Preserve some kinds of signatures, reenable HTDIG option.
Pull upstream change 1629 to fix Launchpad Bug #1551075 <https://bugs.launchpad.net/mailman/+bug/1551075>. This fix improves preservation of OpenPGP MIME multipart signatures, by not collapsing a multipart with a single sub-part inside multipart/signed parts. See the Launchpad bug report for details. EXPERIMENTAL feature: Reenable HTDIG support by rolling the patch on our own, and laying down instructions to do so in the Makefile. Mark Sapiro no longer maintains the patch. Bump PORTREVISION to 3. Note that the upstream maintainer considers another release in a few weeks' time, and called for help with updating translations. If you want to help, see <http://www.mail-archive.com/mailman-users%40python.org/msg68036.html>
Notes
Notes: svn path=/head/; revision=409916
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile13
-rw-r--r--mail/mailman/distinfo4
-rw-r--r--mail/mailman/files/patch-LP155107540
3 files changed, 51 insertions, 6 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index f1b32e203c1d..e85767d5e65d 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,11 +3,12 @@
PORTNAME= mailman
DISTVERSION= 2.1.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
https://launchpad.net/mailman/${DISTVERSION:R}/${DISTVERSION}/+download/
+PATCH_SITES= LOCAL/mandree
DIST_SUBDIR= mailman
PATCH_DIST_STRIP= -p1
@@ -64,7 +65,7 @@ PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS README README-I18N.en \
OPTIONS_SINGLE= MTA
OPTIONS_SINGLE_MTA= COURIER EXIM4 OPENSMTPD POSTFIX SENDMAIL
-OPTIONS_DEFINE= NAMAZU2 NLS DOCS # HTDIG defunct in 2.1.21
+OPTIONS_DEFINE= HTDIG NAMAZU2 NLS DOCS
OPTIONS_DEFAULT= SENDMAIL
COURIER_DESC= for use with courier
EXIM4_DESC= for use with exim4
@@ -109,9 +110,13 @@ MAIL_GID?= _smtpd
.endif
.if ${PORT_OPTIONS:MHTDIG}
-PATCH_SITES+= http://www.msapiro.net/mm/
-PATCHFILES+= index_htdig.patch.2.1.20
PKGNAMESUFFIX+= -with-htdig
+# how to create PATCHFILES:
+#X fetch http://bazaar.launchpad.net/~msapiro/mailman/htdig/tarball/1632?start_revid=1632
+#X unpack this tarball, and the original distfile
+#X diff -NEur original-unpack bazaar-unpack | xz --best -c >msapiro-htdig-1632.patch.xz
+#X upload the latter with mode 0644 or similar to freefall's public_distfiles/ directory
+PATCHFILES+= msapiro-htdig-1632.patch.xz
RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
PLIST_SUB+= SUB_HTDIG=""
.else
diff --git a/mail/mailman/distinfo b/mail/mailman/distinfo
index eac15ed06211..4090b7204ae4 100644
--- a/mail/mailman/distinfo
+++ b/mail/mailman/distinfo
@@ -1,4 +1,4 @@
SHA256 (mailman/mailman-2.1.21.tgz) = fed33a18154deaa4e81a20798c814485ed4b2e5d8b42cf6d3d55867ff4f70843
SIZE (mailman/mailman-2.1.21.tgz) = 9266286
-SHA256 (mailman/index_htdig.patch.2.1.20) = 6b47c01b3d65b280829adc8d937e0e8b42d175cceb2a5bc7518e46819f960ac2
-SIZE (mailman/index_htdig.patch.2.1.20) = 324328
+SHA256 (mailman/msapiro-htdig-1632.patch.xz) = 241128c0a10a0f4a31d62433de0cbdc7c96673ff5dd1012af70beb7658f9b38c
+SIZE (mailman/msapiro-htdig-1632.patch.xz) = 50956
diff --git a/mail/mailman/files/patch-LP1551075 b/mail/mailman/files/patch-LP1551075
new file mode 100644
index 000000000000..35b8975a3720
--- /dev/null
+++ b/mail/mailman/files/patch-LP1551075
@@ -0,0 +1,40 @@
+=== modified file 'Mailman/Handlers/MimeDel.py'
+--- Mailman/Handlers/MimeDel.py 2011-04-13 04:13:10 +0000
++++ Mailman/Handlers/MimeDel.py 2016-02-29 06:28:44 +0000
+@@ -1,4 +1,4 @@
+-# Copyright (C) 2002-2011 by the Free Software Foundation, Inc.
++# Copyright (C) 2002-2016 by the Free Software Foundation, Inc.
+ #
+ # This program is free software; you can redistribute it and/or
+ # modify it under the terms of the GNU General Public License
+@@ -210,6 +210,11 @@
+ # If we're left with a multipart message with only one sub-part, recast
+ # the message to just the sub-part, but not if the part is message/rfc822
+ # because we don't want to lose the headers.
++ # Also, if this is a multipart/signed part, stop now as the original part
++ # may have had a multipart sub-part with only one sub-sub-part, the sig
++ # may still be valid and going further may break it. (LP: #1551075)
++ if msg.get_content_type() == 'multipart/signed':
++ return
+ if msg.is_multipart():
+ if (len(msg.get_payload()) == 1 and
+ msg.get_content_type() <> 'message/rfc822'):
+
+=== modified file 'NEWS'
+--- NEWS 2016-02-28 20:43:02 +0000
++++ NEWS 2016-02-29 06:28:44 +0000
+@@ -5,6 +5,13 @@
+
+ Here is a history of user visible changes to Mailman.
+
++2.1.22 (xx-xxx-xxxx)
++
++ Bug fixes and other patches
++
++ - Don't collapse multipart with a single sub-part inside multipart/signed
++ parts. (LP: #1551075)
++
+ 2.1.21 (28-Feb-2016)
+
+ New Features
+