aboutsummaryrefslogtreecommitdiff
path: root/mail/mailsync
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-11-11 17:25:22 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-11-11 17:25:22 +0000
commit950bf6ba9c56d318b6f43de0159a46296977ddd9 (patch)
treec179b5b91577b67662745536b0ef7747d599068f /mail/mailsync
parent9463f9e2143341fc298b7756fac305e9aa07d863 (diff)
downloadports-950bf6ba9c56d318b6f43de0159a46296977ddd9.tar.gz
ports-950bf6ba9c56d318b6f43de0159a46296977ddd9.zip
mail/mailsync: Unbreak in 11.4 and 12.2
This port is broken in 12.2 and 11.4, but not in 12.1 or 13-current. The problem is the old mail/cclient doing things like redefining C++ keywords. Workaround this by building with GCC in those releases where it is broken. PR: 250740 Submitted by: colin@fbug.ksac.uk
Notes
Notes: svn path=/head/; revision=554904
Diffstat (limited to 'mail/mailsync')
-rw-r--r--mail/mailsync/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/mail/mailsync/Makefile b/mail/mailsync/Makefile
index b9e39c0456f8..1f8a43bfcadd 100644
--- a/mail/mailsync/Makefile
+++ b/mail/mailsync/Makefile
@@ -24,6 +24,16 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.pre.mk>
+# This is a nasty hack due to the weird things that mail/cclient
+# do redefining C++ keywords. For some reason GCC seems to build
+# this, but we should expect it to break at some point.
+# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=250740
+# for reference.
+.if ${OPSYS} == FreeBSD && (${OSREL} == 12.2 || ${OSREL} == 11.4)
+USE_GCC= yes
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/mailsync ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/mailsync.1 ${STAGEDIR}${MANPREFIX}/man/man1
@@ -41,4 +51,4 @@ do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/examples/mailsync ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>