aboutsummaryrefslogtreecommitdiff
path: root/mail/mairix
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-07-02 17:50:00 +0000
committerXin LI <delphij@FreeBSD.org>2012-07-02 17:50:00 +0000
commit49ef64df6fc050353c08989e22459a4fbb461ae8 (patch)
treef7fbef7536c8443e82fbfb920a4af0f7f95aed7d /mail/mairix
parent5c8b9b589113803e940874745ba6238141cb4e3d (diff)
downloadports-49ef64df6fc050353c08989e22459a4fbb461ae8.tar.gz
ports-49ef64df6fc050353c08989e22459a4fbb461ae8.zip
* Enable support of gzip- and bzip2-compressed mbox.
PR: ports/169128 Submitted by: gjb Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=300392
Diffstat (limited to 'mail/mairix')
-rw-r--r--mail/mairix/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/mail/mairix/Makefile b/mail/mairix/Makefile
index 9bbffa30cd76..fc7d422b92d7 100644
--- a/mail/mairix/Makefile
+++ b/mail/mairix/Makefile
@@ -22,6 +22,26 @@ MAN5= mairixrc.5
PLIST_FILES= bin/mairix %%EXAMPLESDIR%%/dotmairixrc.eg
PLIST_DIRS= %%EXAMPLESDIR%%
+OPTIONS_DEFINE= GZIP BZIP
+GZIP_DESC= Enable gzip mbox support
+BZIP_DESC= Enable bzip2 mbox support
+
+OPTIONS_DEFAULT=
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGZIP}
+CONFIGURE_ARGS+= --enable-gzip-mbox
+.else
+CONFIGURE_ARGS+= --disable-gzip-mbox
+.endif
+
+.if ${PORT_OPTIONS:MBZIP}
+CONFIGURE_ARGS+= --enable-bzip-mbox
+.else
+CONFIGURE_ARGS+= --disable-bzip-mbox
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mairix ${PREFIX}/bin
${MKDIR} ${EXAMPLESDIR}