aboutsummaryrefslogtreecommitdiff
path: root/mail/masqmail
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 19:33:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 19:33:19 +0000
commitb965bf4c576972fbd13790341a12f06a2c165ad2 (patch)
tree23aa49bcf336c11f0bd9ad9f37cd3f252f0102de /mail/masqmail
parent87c26c1519e85cba7d164c5a152556e99eae5a99 (diff)
downloadports-b965bf4c576972fbd13790341a12f06a2c165ad2.tar.gz
ports-b965bf4c576972fbd13790341a12f06a2c165ad2.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=320122
Diffstat (limited to 'mail/masqmail')
-rw-r--r--mail/masqmail/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/mail/masqmail/Makefile b/mail/masqmail/Makefile
index eb47e2d4ecec..988ac183bc18 100644
--- a/mail/masqmail/Makefile
+++ b/mail/masqmail/Makefile
@@ -23,19 +23,20 @@ CFLAGS+= -Wno-trigraphs
CONFIGURE_ARGS+= --with-user=mailnull --with-group=mail \
--with-confdir=${PREFIX}/etc/masqmail --with-logdir=/var/log/masqmail
-OPTIONS += RESOLVER "Resolver" on
-OPTIONS += AUTH "SMTP AUTH (RFC2554) support" on
-OPTIONS += DEBUG "Enable Debugging" off
+OPTIONS_DEFINE= RESOLVER AUTH DEBUG
+OPTIONS_DEFAULT= RESOLVER AUTH
+RESOLVER_DESC= Resolver
+AUTH_DESC= SMTP AUTH (RFC2554) support
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_RESOLVER)
+.if ! ${PORT_OPTIONS:MRESOLVER}
CONFIGURE_ARGS+= --disable-resolver
.endif
-.if defined(WITH_AUTH)
+.if ${PORT_OPTIONS:MAUTH}
CONFIGURE_ARGS+= --enable-auth
.endif
-.if defined(WITHOUT_DEBUG)
+.if ! ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --disable-debug
.endif
@@ -46,7 +47,7 @@ post-install:
${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/localnet.route ${PREFIX}/etc/masqmail/localnet.route-dist
${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/openssl.route ${PREFIX}/etc/masqmail/openssl.route-dist
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/docs
cd ${WRKSRC} && ${CP} ChangeLog NEWS AUTHORS COPYING README TODO INSTALL THANKS ${DOCSDIR}
(cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/docs/)