aboutsummaryrefslogtreecommitdiff
path: root/mail/mboxgrep
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-30 22:49:54 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-30 22:49:54 +0000
commit60d0e9fd8dd627e2fa08e68f8d94004c37576993 (patch)
tree4dfc3b273f29f8d63ce582fb7e60307fee4a65f0 /mail/mboxgrep
parent2dda46c5dd85bb5d8ae6d864c3ca2f35d02b36c8 (diff)
downloadports-60d0e9fd8dd627e2fa08e68f8d94004c37576993.tar.gz
ports-60d0e9fd8dd627e2fa08e68f8d94004c37576993.zip
Add mboxgrep 0.7.0, a utility to scan mailboxes for messages matching a
regular expression. PR: 31550 Submitted by: Anders Nordby <anders@fix.no>
Notes
Notes: svn path=/head/; revision=49403
Diffstat (limited to 'mail/mboxgrep')
-rw-r--r--mail/mboxgrep/Makefile37
-rw-r--r--mail/mboxgrep/distinfo1
-rw-r--r--mail/mboxgrep/files/patch-Makefile.in14
-rw-r--r--mail/mboxgrep/files/patch-wrap.h10
-rw-r--r--mail/mboxgrep/pkg-comment1
-rw-r--r--mail/mboxgrep/pkg-descr19
-rw-r--r--mail/mboxgrep/pkg-plist9
7 files changed, 91 insertions, 0 deletions
diff --git a/mail/mboxgrep/Makefile b/mail/mboxgrep/Makefile
new file mode 100644
index 000000000000..c8b1f1b5b49a
--- /dev/null
+++ b/mail/mboxgrep/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mboxgrep
+# Date created: 28 October 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mboxgrep
+PORTVERSION= 0.7.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= anders@fix.no
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= mboxgrep.1
+
+DOCS= ChangeLog NEWS README TODO
+
+post-install:
+ install-info ${PREFIX}/info/mboxgrep.info ${PREFIX}/info/dir
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/mboxgrep/distinfo b/mail/mboxgrep/distinfo
new file mode 100644
index 000000000000..e4988cf97692
--- /dev/null
+++ b/mail/mboxgrep/distinfo
@@ -0,0 +1 @@
+MD5 (mboxgrep-0.7.0.tar.gz) = 7259f9ed9be88666e3386fbd8db9db28
diff --git a/mail/mboxgrep/files/patch-Makefile.in b/mail/mboxgrep/files/patch-Makefile.in
new file mode 100644
index 000000000000..892bf9545cf5
--- /dev/null
+++ b/mail/mboxgrep/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- src/Makefile.in.orig Fri Oct 26 15:08:54 2001
++++ src/Makefile.in Sun Oct 28 10:46:33 2001
+@@ -19,9 +19,9 @@
+
+ CC = @CC@
+ OBJS = info.o main.o mh.o scan.o maildir.o mbox.o misc.o \
+- wrap.o
++ wrap.o getopt.o getopt1.o
+ SRCS = info.c main.c mh.c scan.c maildir.c mbox.c misc.c \
+- wrap.c
++ wrap.c getopt.c getopt1.c
+ TARGET = mboxgrep
+ CFLAGS = @CFLAGS@
+ LIBS = @LIBS@
diff --git a/mail/mboxgrep/files/patch-wrap.h b/mail/mboxgrep/files/patch-wrap.h
new file mode 100644
index 000000000000..f5432e809d5d
--- /dev/null
+++ b/mail/mboxgrep/files/patch-wrap.h
@@ -0,0 +1,10 @@
+--- src/wrap.h.orig Fri Oct 26 15:08:54 2001
++++ src/wrap.h Sun Oct 28 11:06:48 2001
+@@ -28,6 +28,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <dirent.h>
++#include <unistd.h>
+
+ int m_open(const char *pathname, int flags, mode_t mode);
+
diff --git a/mail/mboxgrep/pkg-comment b/mail/mboxgrep/pkg-comment
new file mode 100644
index 000000000000..d57295338f40
--- /dev/null
+++ b/mail/mboxgrep/pkg-comment
@@ -0,0 +1 @@
+Utility to scan mailboxes for messages matching a regular expression
diff --git a/mail/mboxgrep/pkg-descr b/mail/mboxgrep/pkg-descr
new file mode 100644
index 000000000000..04cb04d0744d
--- /dev/null
+++ b/mail/mboxgrep/pkg-descr
@@ -0,0 +1,19 @@
+mboxgrep is a small utility that scans a mailbox for messages matching a
+regular expression. Found messages can be either displayed on standard output,
+counted, deleted, piped to a shell command or written to another mailbox.
+
+Its features include:
+
+* ability to limit the search to message body or headers (although the whole
+message is scanned by default)
+* message counting
+* ability to invert the sense of matching
+* ability to write found messages to another mailbox
+* support for mbox (either plain or compressed), MH, nnmh, nnml and maildir
+folders
+* support for basic and extended POSIX regular expressions, and, optionally,
+Perl-complatible regular expressions (if linked with the PCRE library)
+
+WWW: http://mboxgrep.sourceforge.net/
+
+- Anders Nordby <anders@fix.no>
diff --git a/mail/mboxgrep/pkg-plist b/mail/mboxgrep/pkg-plist
new file mode 100644
index 000000000000..8ebc2c073662
--- /dev/null
+++ b/mail/mboxgrep/pkg-plist
@@ -0,0 +1,9 @@
+bin/mboxgrep
+@unexec install-info --delete %D/info/mboxgrep.info %D/info/dir
+info/mboxgrep.info
+@exec install-info %D/info/mboxgrep.info %D/info/dir
+%%PORTDOCS%%share/doc/mboxgrep/ChangeLog
+%%PORTDOCS%%share/doc/mboxgrep/NEWS
+%%PORTDOCS%%share/doc/mboxgrep/README
+%%PORTDOCS%%share/doc/mboxgrep/TODO
+%%PORTDOCS%%@dirrm share/doc/mboxgrep