aboutsummaryrefslogtreecommitdiff
path: root/mail/mdpop3d
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-02-20 23:04:37 +0000
committerRene Ladan <rene@FreeBSD.org>2013-02-20 23:04:37 +0000
commit252938c14bd43ee881d9842ff6c7f70744c817d0 (patch)
treea588577fba24d127b8259729288343ce4033fe58 /mail/mdpop3d
parent4b13f5ecdd5a593dc92c524dc3f4b6106338b57b (diff)
downloadports-252938c14bd43ee881d9842ff6c7f70744c817d0.tar.gz
ports-252938c14bd43ee881d9842ff6c7f70744c817d0.zip
- convert to optionsNG
- convert Makefile header
Notes
Notes: svn path=/head/; revision=312682
Diffstat (limited to 'mail/mdpop3d')
-rw-r--r--mail/mdpop3d/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/mail/mdpop3d/Makefile b/mail/mdpop3d/Makefile
index c3e093ca9abd..19ef1eb70d46 100644
--- a/mail/mdpop3d/Makefile
+++ b/mail/mdpop3d/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: mdpop3d
-# Date created: 2 July 2006
-# Whom: Alexander Logvinov <info@logvinov.com>
-#
+# Created by: Alexander Logvinov <info@logvinov.com>
# $FreeBSD$
PORTNAME= mdpop3d
@@ -16,15 +13,15 @@ PLIST_FILES= libexec/mdpop3d
MAN8= mdpop3d.8
MANCOMPRESSED= no
-OPTIONS= PAM "Build with PAM support" off \
- APOP "Build with APOP command support (requires PAM)" off
+OPTIONS_DEFINE= PAM APOP
+APOP_DESC= Build with APOP command support (requires PAM)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|LIBS = -lpam -ldl|LIBS = -lpam|;/^CC[[:blank:]]*=/d' \
${WRKSRC}/Makefile
-.if defined(WITHOUT_PAM)
+.if ! ${PORT_OPTIONS:MPAM}
@${REINPLACE_CMD} -e 's|LIBS = -lpam|LIBS = -lcrypt|' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|DEFS = -DUSE_PAM|#DEFS = -DUSE_PAM|' \
@@ -32,7 +29,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|OPTS = -DUSE_APOP|#OPTS = -DUSE_APOP|' \
${WRKSRC}/Makefile
.endif
-.if defined(WITHOUT_APOP)
+.if ! ${PORT_OPTIONS:MAPOP}
@${REINPLACE_CMD} -e 's|OPTS = -DUSE_APOP|#OPTS = -DUSE_APOP|' \
${WRKSRC}/Makefile
.endif
@@ -41,4 +38,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/libexec
${INSTALL_MAN} ${WRKSRC}/mdpop3d.8 ${PREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>