aboutsummaryrefslogtreecommitdiff
path: root/mail/metamail
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-01-01 09:09:51 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-01-01 09:09:51 +0000
commitf452ae78db56e5912ef69acd9ee4a7fff0fa0d7a (patch)
tree3e4cb6ef592dab4821f722abaa02685db06daa80 /mail/metamail
parentd1b30ff34a381678b325405813afce159e5e5786 (diff)
downloadports-f452ae78db56e5912ef69acd9ee4a7fff0fa0d7a.tar.gz
ports-f452ae78db56e5912ef69acd9ee4a7fff0fa0d7a.zip
mail/metamail: fix build with X11 option enabled
- It has been broken for more than one year. r412348 was the last buildable version PR: 224794 Submitted by: Ting-Wei Lan <lantw44@gmail.com>
Notes
Notes: svn path=/head/; revision=457758
Diffstat (limited to 'mail/metamail')
-rw-r--r--mail/metamail/Makefile4
-rw-r--r--mail/metamail/files/extra-patch-Makefile-nox11 (renamed from mail/metamail/files/patch-Makefile)0
-rw-r--r--mail/metamail/files/extra-patch-Makefile-x11110
3 files changed, 113 insertions, 1 deletions
diff --git a/mail/metamail/Makefile b/mail/metamail/Makefile
index 0216e77c5e1e..b6fc91d452d4 100644
--- a/mail/metamail/Makefile
+++ b/mail/metamail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= metamail
PORTVERSION= 2.7
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= mail
MASTER_SITES= http://ftp.funet.fi/pub/unix/mail/metamail/ \
ftp://ftp.research.telcordia.com/pub/nsb/
@@ -28,6 +28,8 @@ X11_BUILD_DEPENDS= bdftopcf:x11-fonts/bdftopcf \
X11_RUN_DEPENDS= xloadimage:x11/xloadimage \
mkfontdir:x11-fonts/mkfontdir
X11_USE= XORG=x11
+X11_EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile-x11
+X11_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Makefile-nox11
post-patch-X11-off:
@${REINPLACE_CMD} -e '/fonts/d' ${WRKSRC}/Makefile
diff --git a/mail/metamail/files/patch-Makefile b/mail/metamail/files/extra-patch-Makefile-nox11
index 92abf5010366..92abf5010366 100644
--- a/mail/metamail/files/patch-Makefile
+++ b/mail/metamail/files/extra-patch-Makefile-nox11
diff --git a/mail/metamail/files/extra-patch-Makefile-x11 b/mail/metamail/files/extra-patch-Makefile-x11
new file mode 100644
index 000000000000..8d9796b994c5
--- /dev/null
+++ b/mail/metamail/files/extra-patch-Makefile-x11
@@ -0,0 +1,110 @@
+--- Makefile.orig 1994-01-26 17:32:33 UTC
++++ Makefile
+@@ -26,7 +26,7 @@ MAKE = make
+ CP = cp
+
+ # How to compile C programs
+-CC = cc
++#CC = cc
+
+ # You may also want to change the CFLAGS variable, which will be passed on
+ # to all subdirectories. If you do that, the changes will only work right if you
+@@ -38,7 +38,7 @@ FOOBAR-sun4=-Bstatic
+
+ STATICFLAG=FOOBAR${HOST_ARCH}
+
+-CFLAGS = -g -I. ${$(STATICFLAG)}
++CFLAGS += -I. ${$(STATICFLAG)}
+ # The following is better if you want to make sure you run with SYSV defined
+ # CFLAGS = -g -I. ${$(STATICFLAG)} -DSYSV
+ # Also, for SGI Irix, compile in K&R mode
+@@ -49,9 +49,9 @@ CFLAGS = -g -I. ${$(STATICFLAG)}
+ # LDLIBS variable.
+ #
+ # For Sun and BSD systems, the following should work...
+-LDLIBS =
++# LDLIBS =
+ # On BSD 4.4 systems, you will need the following
+-# LDLIBS = -lcompat
++LDLIBS = -s -lcompat
+ # On SGI machines, we need -lsun for getpw...(), and -lc_s saves some space.
+ # LDLIBS = -lsun -lc_s
+ # ISC SysVr3.2.2 has a shared C library and requires libinet.a to resolve
+@@ -72,10 +72,10 @@ CONFIGDIR = .
+ # install -s -c $(LOCALBINDIR) $$file
+ #
+ #INSTALL = cp
+-INSTALL = install -c -s
++INSTALL = install -c
+
+ # Root of installation tree
+-INSTROOT = /usr/local
++INSTROOT = ${PREFIX}
+ #
+ # This is where binaries should be copied
+ LOCALBINDIR = ${INSTROOT}/bin
+@@ -96,9 +96,9 @@ MAILCAPDIR = ${INSTROOT}/etc
+ # This helps with the "for" constructs below on some platforms:
+ SHELL=/bin/sh
+
+-install: basics
++install: install-all
+
+-basics::
++all basics::
+ (cd metamail ; $(MAKE) CONFIGDIR=../${CONFIGDIR} CFLAGS="${CFLAGS}" CC="${CC}" LDLIBS="${LDLIBS}")
+ -${RM} bin/metamail
+ (cd bin; ${LN} ../metamail/metamail metamail)
+@@ -115,9 +115,9 @@ basics::
+ (cd richmail ; $(MAKE) CONFIGDIR=../${CONFIGDIR} CFLAGS="${CFLAGS}" CC="${CC}" LDLIBS="${LDLIBS}")
+ -${RM} bin/richtext
+ (cd bin; ${LN} ../richmail/richtext richtext)
++ (cd fonts ; $(MAKE) CONFIGDIR=../${CONFIGDIR} CFLAGS="${CFLAGS}" CC="${CC}" LDLIBS="${LDLIBS}" FONTSUFFIX="${FONTSUFFIX}")
+ -${RM} bin/richtoatk
+ (cd bin; ${LN} ../richmail/richtoatk richtoatk)
+- (cd fonts ; $(MAKE) CONFIGDIR=../${CONFIGDIR} CFLAGS="${CFLAGS}" CC="${CC}" LDLIBS="${LDLIBS}" FONTSUFFIX="${FONTSUFFIX}")
+ -${RM} bin/shownonascii
+ (cd bin; ${LN} ../fonts/shownonascii shownonascii)
+ -${RM} bin/mailto-hebrew
+@@ -127,28 +127,27 @@ install-all: basics
+ @(cd bin; \
+ for file in *; \
+ do \
+- target=$(LOCALBINDIR)/$$file; \
++ target=$(DESTDIR)$(LOCALBINDIR)/$$file; \
+ echo "installing binary $$target"; \
+ ${INSTALL} $$file $$target; \
+ done)
+ @(cd man; \
+ for file in *.1; \
+ do \
+- target=$(MAN1DIR)/`basename $$file .1`.$(MAN1EXT); \
++ target=$(DESTDIR)$(MAN1DIR)/`basename $$file .1`.$(MAN1EXT); \
+ echo "installing man page $$target";\
+ ${CP} $$file $$target; \
+ done)
+ @(cd man; \
+ for file in *.4; \
+ do \
+- target=$(MAN4DIR)/`basename $$file .4`.$(MAN4EXT); \
++ target=$(DESTDIR)$(MAN4DIR)/`basename $$file .4`.$(MAN4EXT); \
+ echo "installing man page $$target";\
+ ${CP} $$file $$target; \
+ done)
+- @echo "Renaming old mailcap file to $(MAILCAPDIR)/mailcap.old
+- -mv $(MAILCAPDIR)/mailcap $(MAILCAPDIR)/mailcap.old
+ @echo "installing file $(MAILCAPDIR)/mailcap"
+- ${CP} mailcap $(MAILCAPDIR)
++ ${CP} mailcap $(DESTDIR)$(MAILCAPDIR)
++ (cd fonts ; $(MAKE) PREFIX=${DESTDIR}${PREFIX} CONFIGDIR=../${CONFIGDIR} CFLAGS="${CFLAGS}" CC="${CC}" LDLIBS="${LDLIBS}" FONTSUFFIX="${FONTSUFFIX}" install)
+
+ uninstall-all:
+ @(cd bin; \
+@@ -179,7 +178,6 @@ clean:
+ -${RM} -rf *.BAK
+ (cd metamail ; $(MAKE) clean)
+ (cd richmail ; $(MAKE) clean)
+- (cd fonts ; $(MAKE) FONTSUFFIX="${FONTSUFFIX}" clean)
+
+ cleanbin:
+ -${RM} bin/metamail