aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-greylist
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-22 13:07:56 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-22 13:07:56 +0000
commit09cee0d3fbf9526accab3bd1b4f0a841346a1a1f (patch)
tree38650a565d05223cb1bff572e3d71764e8d6387c /mail/milter-greylist
parent12ed6a4fe06b2240e609aeb5cb581a28db067e48 (diff)
downloadports-09cee0d3fbf9526accab3bd1b4f0a841346a1a1f.tar.gz
ports-09cee0d3fbf9526accab3bd1b4f0a841346a1a1f.zip
mail/milter-greylist: Fix options
- Remove DKIM option as it reportedly never worked - Regenerate patches to appease portlint PR: 207246 MFH: 2016Q1
Notes
Notes: svn path=/head/; revision=411656
Diffstat (limited to 'mail/milter-greylist')
-rw-r--r--mail/milter-greylist/Makefile13
-rw-r--r--mail/milter-greylist/files/patch-configure7
-rw-r--r--mail/milter-greylist/files/patch-greylist.conf6
-rw-r--r--mail/milter-greylist/files/patch-ldapcheck.c6
-rw-r--r--mail/milter-greylist/files/patch-sync.c7
5 files changed, 17 insertions, 22 deletions
diff --git a/mail/milter-greylist/Makefile b/mail/milter-greylist/Makefile
index 4dfe3827895c..e7b528ada9b6 100644
--- a/mail/milter-greylist/Makefile
+++ b/mail/milter-greylist/Makefile
@@ -3,7 +3,7 @@
PORTNAME= milter-greylist
PORTVERSION= 4.4.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail
MASTER_SITES= ftp://ftp.espci.fr/pub/milter-greylist/ \
http://fossies.org/unix/privat/
@@ -31,9 +31,8 @@ USES= tar:tgz
# installed port preference over it.
##
-OPTIONS_DEFINE= SPF GEOIP CURL DKIM LDAP P0F POSTFIX DOCS EXAMPLES
+OPTIONS_DEFINE= SPF GEOIP CURL LDAP P0F POSTFIX DOCS EXAMPLES
SPF_DESC= SPF support
-DKIM_DESC= DKIM support
CURL_DESC= curl support
P0F_DESC= P0F support
POSTFIX_DESC= Use Postfix instead of Sendmail
@@ -42,7 +41,6 @@ P0F_RUN_DEPENDS= p0f:${PORTSDIR}/net-mgmt/p0f
SPF_LIB_DEPENDS= libspf2.so:${PORTSDIR}/mail/libspf2
CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
-DKIM_LIB_DEPENDS= libdkim.so:${PORTSDIR}/mail/libdkim
POSTFIX_CONFIGURE_ENABLE= postfix
POSTFIX_LDFLAGS_OFF= ${SENDMAIL_LDFLAGS}
@@ -50,10 +48,9 @@ POSTFIX_LIBS_OFF= ${SENDMAIL_LDADD}
P0F_CONFIGURE_ENABLE= p0f306
-DKIM_CONFIGURE_WITH= --with-libdkim=${LOCALBASE}
-SPF_CONFIGURE_WITH= --with-libspf2=${LOCALBASE}
-GEOIP__CONFIGURE_WITH= --with-libGeoIP=${LOCALBASE}
-CURL_CONFIGURE_WITH= --with-libcurl=${LOCALBASE}
+SPF_CONFIGURE_ON= --with-libspf2=${LOCALBASE}
+GEOIP_CONFIGURE_ON= --with-libGeoIP=${LOCALBASE}
+CURL_CONFIGURE_ON= --with-libcurl=${LOCALBASE}
LDAP_CONFIGURE_ON= --with-openldap=${LOCALBASE}
LDAP_LDFLAGS= -L${LOCALBASE}/lib
LDAP_USE= OPENLDAP=yes
diff --git a/mail/milter-greylist/files/patch-configure b/mail/milter-greylist/files/patch-configure
index 0632147b1c3f..4b8e67759ec2 100644
--- a/mail/milter-greylist/files/patch-configure
+++ b/mail/milter-greylist/files/patch-configure
@@ -1,8 +1,7 @@
Index: configure
-diff -u configure.orig configure
---- configure.orig 2013-03-07 22:26:11.000000000 +0900
-+++ configure 2013-03-14 15:35:15.476674058 +0900
-@@ -5899,7 +5899,7 @@
+--- configure.orig 2013-03-07 13:26:11 UTC
++++ configure
+@@ -5899,7 +5899,7 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_pthread_pthread_create" >&5
$as_echo "$ac_cv_lib_pthread_pthread_create" >&6; }
if test "x$ac_cv_lib_pthread_pthread_create" = xyes; then :
diff --git a/mail/milter-greylist/files/patch-greylist.conf b/mail/milter-greylist/files/patch-greylist.conf
index dcb88e3f6618..3de9c8ba8fbc 100644
--- a/mail/milter-greylist/files/patch-greylist.conf
+++ b/mail/milter-greylist/files/patch-greylist.conf
@@ -1,6 +1,6 @@
---- greylist.conf.orig 2009-02-13 01:39:01.000000000 +0300
-+++ greylist.conf 2009-04-22 09:10:46.000000000 +0400
-@@ -9,7 +9,7 @@
+--- greylist.conf.orig 2013-01-27 02:10:19 UTC
++++ greylist.conf
+@@ -9,7 +9,7 @@ pidfile "/var/run/milter-greylist.pid"
socket "/var/milter-greylist/milter-greylist.sock"
dumpfile "/var/milter-greylist/greylist.db" 600
dumpfreq 1
diff --git a/mail/milter-greylist/files/patch-ldapcheck.c b/mail/milter-greylist/files/patch-ldapcheck.c
index 89f6bbc6b3ad..000492b123f5 100644
--- a/mail/milter-greylist/files/patch-ldapcheck.c
+++ b/mail/milter-greylist/files/patch-ldapcheck.c
@@ -1,6 +1,6 @@
---- ldapcheck.c.orig 2009-04-09 05:26:46.000000000 +0200
-+++ ldapcheck.c 2009-10-23 23:57:42.000000000 +0200
-@@ -58,6 +58,22 @@
+--- ldapcheck.c.orig 2013-01-19 16:01:15 UTC
++++ ldapcheck.c
+@@ -60,6 +60,22 @@ __RCSID("$Id: ldapcheck.c,v 1.18 2013/01
#include "prop.h"
#include "ldapcheck.h"
diff --git a/mail/milter-greylist/files/patch-sync.c b/mail/milter-greylist/files/patch-sync.c
index 52917a93d391..62d0d71f082e 100644
--- a/mail/milter-greylist/files/patch-sync.c
+++ b/mail/milter-greylist/files/patch-sync.c
@@ -1,8 +1,7 @@
Index: sync.c
-diff -u -p sync.c.orig sync.c
---- sync.c.orig 2010-04-17 12:19:02.000000000 +0900
-+++ sync.c 2013-03-14 14:57:39.284674283 +0900
-@@ -478,7 +478,11 @@ peer_connect(peer) /* peer list is read-
+--- sync.c.orig 2010-06-16 01:30:30 UTC
++++ sync.c
+@@ -487,7 +487,11 @@ peer_connect(peer) /* peer list is read-
#ifdef AF_INET6
case AF_INET6:
SA6(res->ai_addr)->sin6_port = service;