aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-greylist
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-23 23:35:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-23 23:35:54 +0000
commit29848a7ea98c389979606272bdb63144fdd394ca (patch)
tree4beaaf38c72f4ae53330317d4f68713bff8cd95b /mail/milter-greylist
parentf0a1df0f369089ba4c4f6f3dea37ec0beb5a7029 (diff)
downloadports-29848a7ea98c389979606272bdb63144fdd394ca.tar.gz
ports-29848a7ea98c389979606272bdb63144fdd394ca.zip
- Add DKIM support
- Convert to Options helper PR: 2028660 Submitted by: maintainer Approved by: mat (mentor) Differential Revision: D4428
Notes
Notes: svn path=/head/; revision=404330
Diffstat (limited to 'mail/milter-greylist')
-rw-r--r--mail/milter-greylist/Makefile62
1 files changed, 26 insertions, 36 deletions
diff --git a/mail/milter-greylist/Makefile b/mail/milter-greylist/Makefile
index 3813ce0dceeb..8e84e93e0b35 100644
--- a/mail/milter-greylist/Makefile
+++ b/mail/milter-greylist/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= ftp://ftp.espci.fr/pub/milter-greylist/ \
http://fossies.org/unix/privat/
-EXTRACT_SUFX= .tgz
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= Easy-to-use greylist milter for sendmail and postfix
@@ -19,6 +18,8 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
MAKE_JOBS_UNSAFE= yes
+USES= tar:tgz
+
##
# Use the following quirks to choose which sendmail to use (ports or system):
#
@@ -30,44 +31,34 @@ MAKE_JOBS_UNSAFE= yes
# installed port preference over it.
##
-OPTIONS_DEFINE= SPF GEOIP CURL LDAP P0F POSTFIX DOCS EXAMPLES
+OPTIONS_DEFINE= SPF GEOIP CURL DKIM LDAP P0F POSTFIX DOCS EXAMPLES
SPF_DESC= SPF support
+DKIM_DESC= DKIM support
CURL_DESC= curl support
P0F_DESC= P0F support
POSTFIX_DESC= Use Postfix instead of Sendmail
-P0F_RUN_DEPENDS+= p0f:${PORTSDIR}/net-mgmt/p0f
-SPF_LIB_DEPENDS+= libspf2.so:${PORTSDIR}/mail/libspf2
-CURL_LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-GEOIP_LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
+P0F_RUN_DEPENDS= p0f:${PORTSDIR}/net-mgmt/p0f
+SPF_LIB_DEPENDS= libspf2.so:${PORTSDIR}/mail/libspf2
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+DKIM_LIB_DEPENDS= libdkim.so:${PORTSDIR}/mail/libdkim
POSTFIX_CONFIGURE_ENABLE= postfix
-P0F_CONFIGURE_ENABLE= p0f306
-
-.include <bsd.port.options.mk>
+POSTFIX_LDFLAGS_OFF= ${SENDMAIL_LDFLAGS}
+POSTFIX_LIBS_OFF= ${SENDMAIL_LDADD}
-.if ${PORT_OPTIONS:MSPF}
-CONFIGURE_ARGS+= --with-libspf2=${LOCALBASE}
-.endif
-
-.if ${PORT_OPTIONS:MGEOIP}
-CONFIGURE_ARGS+= --with-libGeoIP=${LOCALBASE}
-.endif
-
-.if ${PORT_OPTIONS:MCURL}
-CONFIGURE_ARGS+= --with-libcurl=${LOCALBASE}
-.endif
+P0F_CONFIGURE_ENABLE= p0f306
-.if ${PORT_OPTIONS:MLDAP}
-# We can't use LDAP_CONFIGURE_WITH because configure script is buggy
-USE_OPENLDAP=yes
-CONFIGURE_ARGS+= --with-openldap
-.endif
+DKIM_CONFIGURE_WITH= --with-libdkim=${LOCALBASE}
+SPF_CONFIGURE_WITH= --with-libspf2=${LOCALBASE}
+GEOIP__CONFIGURE_WITH= --with-libGeoIP=${LOCALBASE}
+CURL_CONFIGURE_WITH= --with-libcurl=${LOCALBASE}
+LDAP_CONFIGURE_ON= --with-openldap=${LOCALBASE}
+LDAP_LDFLAGS= -L${LOCALBASE}/lib
+LDAP_USE= OPENLDAP=yes
-.if ! ${PORT_OPTIONS:MPOSTFIX}
-LDFLAGS+= ${SENDMAIL_LDFLAGS}
-LIBS+= ${SENDMAIL_LDADD}
-.endif
+.include <bsd.port.options.mk>
LIBS+= -lpthread
@@ -94,15 +85,14 @@ do-install:
${STAGEDIR}${PREFIX}/libexec/
${INSTALL_DATA} ${WRKSRC}/greylist.conf \
${STAGEDIR}${PREFIX}/etc/mail/greylist.conf.sample
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${STAGEDIR}/var/milter-greylist
+
+do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/greylist.conf ${STAGEDIR}${EXAMPLESDIR}/
-.endif
- @${MKDIR} ${STAGEDIR}/var/milter-greylist
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"