aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-regex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2019-01-07 01:08:08 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2019-01-07 01:08:08 +0000
commitd4a77d811e3cae77044e7c74feabf1ca5f2c86e8 (patch)
treedd469301dd995fb6b03fc4b1ca484462fca2b269 /mail/milter-regex
parent70057fa64309e0ac050fc5d07d2670eea324d3db (diff)
downloadports-d4a77d811e3cae77044e7c74feabf1ca5f2c86e8.tar.gz
ports-d4a77d811e3cae77044e7c74feabf1ca5f2c86e8.zip
Notes
Diffstat (limited to 'mail/milter-regex')
-rw-r--r--mail/milter-regex/Makefile5
-rw-r--r--mail/milter-regex/distinfo5
-rw-r--r--mail/milter-regex/files/patch-milter-regex.812
-rw-r--r--mail/milter-regex/files/patch-milter-regex.c34
-rw-r--r--mail/milter-regex/pkg-descr2
5 files changed, 27 insertions, 31 deletions
diff --git a/mail/milter-regex/Makefile b/mail/milter-regex/Makefile
index ead1f6bd850d..3c367068ef50 100644
--- a/mail/milter-regex/Makefile
+++ b/mail/milter-regex/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= milter-regex
-PORTVERSION= 2.0
-PORTREVISION= 4
+PORTVERSION= 2.2
CATEGORIES= mail
-MASTER_SITES= http://www.benzedrine.cx/
+MASTER_SITES= https://www.benzedrine.ch/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Milter plugin to sendmail for regular expression filtering
diff --git a/mail/milter-regex/distinfo b/mail/milter-regex/distinfo
index 5c87c3fb1889..22db17bba117 100644
--- a/mail/milter-regex/distinfo
+++ b/mail/milter-regex/distinfo
@@ -1,2 +1,3 @@
-SHA256 (milter-regex-2.0.tar.gz) = ac0388766e5780c42d39e72b694986524e312ea17e5da4823749c7c5b7a55a70
-SIZE (milter-regex-2.0.tar.gz) = 19891
+TIMESTAMP = 1546371034
+SHA256 (milter-regex-2.2.tar.gz) = 67b7cbe04be7aff111750648ea4004927de9c40c53959cab32101833e7ecccdd
+SIZE (milter-regex-2.2.tar.gz) = 20496
diff --git a/mail/milter-regex/files/patch-milter-regex.8 b/mail/milter-regex/files/patch-milter-regex.8
index 92a88b394753..36cf7965b5b8 100644
--- a/mail/milter-regex/files/patch-milter-regex.8
+++ b/mail/milter-regex/files/patch-milter-regex.8
@@ -1,5 +1,5 @@
---- milter-regex.8.orig 2011-11-21 13:13:47.000000000 +0100
-+++ milter-regex.8 2011-12-10 07:52:00.000000000 +0100
+--- milter-regex.8.orig 2018-09-25 20:51:47 UTC
++++ milter-regex.8
@@ -36,7 +36,9 @@
.Sh SYNOPSIS
.Nm
@@ -8,9 +8,9 @@
.Op Fl c Ar config
+.Op Fl r Ar pid-file
.Op Fl j Ar dirname
- .Op Fl p Ar pipe
- .Op Fl u Ar user
-@@ -53,9 +55,14 @@
+ .Op Fl l Ar loglevel
+ .Op Fl m Ar number
+@@ -58,9 +60,14 @@ The options are as follows:
.It Fl d
Don't detach from controlling terminal and produce verbose debug
output on stdout.
@@ -24,4 +24,4 @@
+/var/spool/milter-regex/milter-regex.pid
.It Fl j Ar dirname
Change root to the specified directory.
- .It Fl p Ar pipe
+ .It Fl l Ar loglevel
diff --git a/mail/milter-regex/files/patch-milter-regex.c b/mail/milter-regex/files/patch-milter-regex.c
index 6d3775c69f2e..749178ce15f5 100644
--- a/mail/milter-regex/files/patch-milter-regex.c
+++ b/mail/milter-regex/files/patch-milter-regex.c
@@ -1,6 +1,6 @@
---- milter-regex.c.orig 2013-11-25 09:41:55.000000000 +0100
-+++ milter-regex.c 2013-11-27 05:25:43.000000000 +0100
-@@ -60,6 +60,7 @@
+--- milter-regex.c.orig 2018-09-25 20:31:25 UTC
++++ milter-regex.c
+@@ -61,6 +61,7 @@ extern int parse_ruleset(const char *,
static const char *rule_file_name = "/etc/milter-regex.conf";
static int debug = 0;
@@ -8,7 +8,7 @@
static unsigned maxlines = 0;
static pthread_mutex_t mutex;
-@@ -97,6 +98,7 @@
+@@ -98,6 +99,7 @@ static void msg(int, struct context *,
#define USER "_milter-regex"
#define OCONN "unix:/var/spool/milter-regex/sock"
@@ -16,7 +16,7 @@
#define RCODE_REJECT "554"
#define RCODE_TEMPFAIL "451"
#define XCODE_REJECT "5.7.1"
-@@ -645,6 +647,9 @@
+@@ -646,6 +648,9 @@ msg(int priority, struct context *contex
va_list ap;
char msg[8192];
@@ -26,28 +26,27 @@
va_start(ap, fmt);
if (context != NULL)
snprintf(msg, sizeof(msg), "%s [%s]: ", context->host_name,
-@@ -682,15 +687,19 @@
+@@ -684,6 +689,7 @@ main(int argc, char **argv)
{
- int ch;
+ int ch, maskpri = LOG_INFO;
const char *oconn = OCONN;
+ const char *pid_file_name = OPID;
const char *user = USER;
const char *jail = NULL;
sfsistat r = MI_FAILURE;
- const char *ofile = NULL;
-
+@@ -691,8 +697,10 @@ main(int argc, char **argv)
+ const char *pgroup = NULL;
+ const char *puser = NULL;
+ mode_t pperm = 0600;
+ pid_t pid;
+ FILE *pid_fd = NULL;
-+
- tzset();
- openlog("milter-regex", LOG_PID | LOG_NDELAY, LOG_DAEMON);
-- while ((ch = getopt(argc, argv, "c:dj:l:m:p:u:")) != -1) {
-+ while ((ch = getopt(argc, argv, "c:dj:l:m:p:qr:u:")) != -1) {
+- while ((ch = getopt(argc, argv, "c:dj:l:m:p:u:G:P:U:")) != -1) {
++ while ((ch = getopt(argc, argv, "c:dj:l:m:p:qr:u:G:P:U:")) != -1) {
switch (ch) {
case 'c':
rule_file_name = optarg;
-@@ -710,6 +719,12 @@
+@@ -712,6 +720,12 @@ main(int argc, char **argv)
case 'p':
oconn = optarg;
break;
@@ -60,11 +59,8 @@
case 'u':
user = optarg;
break;
-@@ -782,9 +797,22 @@
- perror("daemon");
- goto done;
+@@ -833,6 +847,20 @@ main(int argc, char **argv)
}
-- umask(0177);
msg(LOG_INFO, NULL, "started: %s", rcsid);
+
diff --git a/mail/milter-regex/pkg-descr b/mail/milter-regex/pkg-descr
index 6b2def1a71ae..bbafac178d1e 100644
--- a/mail/milter-regex/pkg-descr
+++ b/mail/milter-regex/pkg-descr
@@ -13,4 +13,4 @@ This program is developed on OpenBSD by the maintainer.
LICENSE: BSD
Copyright (c) 2003-2006 Daniel Hartmeier
-WWW: http://www.benzedrine.cx/milter-regex.html
+WWW: https://www.benzedrine.ch/milter-regex.html