aboutsummaryrefslogtreecommitdiff
path: root/mail/mime4j
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-09-03 08:04:41 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-09-03 08:04:41 +0000
commit1098ca0851a89f4dda31ca4be5f5910d679c5339 (patch)
treee3aeb7547ef2a3054c96a7f2472357792ad81591 /mail/mime4j
parent8e2eb4f3375f97a48b0fc3b29e0be8dc93220674 (diff)
Notes
Diffstat (limited to 'mail/mime4j')
-rw-r--r--mail/mime4j/Makefile43
-rw-r--r--mail/mime4j/distinfo3
-rw-r--r--mail/mime4j/pkg-descr22
3 files changed, 68 insertions, 0 deletions
diff --git a/mail/mime4j/Makefile b/mail/mime4j/Makefile
new file mode 100644
index 000000000000..cd3002d05b6d
--- /dev/null
+++ b/mail/mime4j/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: mime4j
+# Date created: 3 Sep 2008
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mime4j
+PORTVERSION= 0.4
+CATEGORIES= mail java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= james/${PORTNAME}
+DISTNAME= apache-${PORTNAME}-${PORTVERSION}-bin
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A Java parser for e-mail message streams
+
+RUN_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/apache-${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= %%JAVAJARDIR%%/apache-${PORTNAME}.jar
+
+PORTDOCS= *
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/apache-${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/apache-${PORTNAME}-${PORTVERSION}.jar \
+ ${JAVAJARDIR}/apache-${PORTNAME}.jar
+ @${ECHO_MSG} " [DONE]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}/api
+ @cd ${WRKSRC}/javadocs && ${FIND} * \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/api > /dev/null 2>&1
+ @${INSTALL_DATA} ${WRKSRC}/RELEASE_NOTES.txt ${DOCSDIR}
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/mime4j/distinfo b/mail/mime4j/distinfo
new file mode 100644
index 000000000000..1985382029b3
--- /dev/null
+++ b/mail/mime4j/distinfo
@@ -0,0 +1,3 @@
+MD5 (apache-mime4j-0.4-bin.tar.gz) = 5c653756c073484077d2c0ad7cc6a2b3
+SHA256 (apache-mime4j-0.4-bin.tar.gz) = 1811cd368d9e6a5116063524881929c823e2f1fecef7d829eb2b4006183061fa
+SIZE (apache-mime4j-0.4-bin.tar.gz) = 631796
diff --git a/mail/mime4j/pkg-descr b/mail/mime4j/pkg-descr
new file mode 100644
index 000000000000..560f5cd1d5ad
--- /dev/null
+++ b/mail/mime4j/pkg-descr
@@ -0,0 +1,22 @@
+mime4j provides a parser, MimeStreamParser, for e-mail message streams
+in plain rfc822 and MIME format. The parser uses a callback mechanism to
+report parsing events such as the start of an entity header, the start
+of a body, etc. If you are familiar with the SAX XML parser interface
+you should have no problem getting started with mime4j.
+
+The parser only deals with the structure of the message stream. It won't
+do any decoding of base64 or quoted-printable encoded header fields and
+bodies.
+
+The parser has been designed to be extremely tolerant against messages
+violating the standards.
+
+mime4j can also be used to build a tree representation of an e-mail
+message using the Message class. Using this facility mime4j
+automatically handles the decoding of fields and bodies and uses
+temporary files for large attachments.
+
+WWW: http://james.apache.org/mime4j/
+
+- Alex Dupre
+ale@FreeBSD.org