aboutsummaryrefslogtreecommitdiff
path: root/mail/mimedefang
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-15 05:02:15 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-15 05:02:15 +0000
commit336aa66b7652d460a0b514dc4ac020b7e7c19c5a (patch)
treea7338faf0b89e38091d95ceaa351549f53f94731 /mail/mimedefang
parent35cecba4ee21b683d380c48e48dabeb9a0a1be1c (diff)
downloadports-336aa66b7652d460a0b514dc4ac020b7e7c19c5a.tar.gz
ports-336aa66b7652d460a0b514dc4ac020b7e7c19c5a.zip
mail/mimedefang: Fix CLAMAV option
Options helpers are ineffective when set after bsd.port.options.mk. Move them before that point. Reported by: tobik (in D19553)
Notes
Notes: svn path=/head/; revision=495764
Diffstat (limited to 'mail/mimedefang')
-rw-r--r--mail/mimedefang/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/mail/mimedefang/Makefile b/mail/mimedefang/Makefile
index 41beb000adab..af6fe8a08511 100644
--- a/mail/mimedefang/Makefile
+++ b/mail/mimedefang/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mimedefang
PORTVERSION= 2.83
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.mimedefang.org/static/ \
http://fossies.org/linux/misc/
@@ -21,10 +21,6 @@ BUILD_DEPENDS= \
spamassassin>=3.0:mail/spamassassin
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= CLAMAV EXAMPLES DOCS
-OPTIONS_DEFAULT= CLAMAV
-CLAMAV_DESC= Enable Clamav
-
USES= perl5 shebangfix
perl_OLD_CMD= perl
GNU_CONFIGURE= yes
@@ -52,16 +48,21 @@ PLIST_SUB+= USER="${MIMEDEFANG_USER}" \
CONFIG_FILES= mimedefang-filter sa-mimedefang.cf mimedefang-ip-key
+OPTIONS_DEFINE= CLAMAV EXAMPLES DOCS
+OPTIONS_DEFAULT= CLAMAV
+
+CLAMAV_DESC= Enable Clamav
+
+CLAMAV_BUILD_DEPENDS= clamscan:security/clamav
+CLAMAV_RUN_DEPENDS= clamscan:security/clamav
+CLAMAV_CONFIGURE_ENABLE= antivirus clamav clamd
+
.include <bsd.port.options.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
CONFIGURE_ARGS+= --with-milterinc=${MILTERBASE}/include --with-milterlib=${MILTERBASE}/lib
-CLAMAV_BUILD_DEPENDS+= clamscan:security/clamav
-CLAMAV_RUN_DEPENDS+= clamscan:security/clamav
-CLAMAV_CONFIGURE_ENABLE+= antivirus clamav clamd
-
post-patch:
@${REINPLACE_CMD} -e '/fgrep -e/d' ${WRKSRC}/configure