aboutsummaryrefslogtreecommitdiff
path: root/mail/mini_sendmail
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2003-07-11 10:03:02 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2003-07-11 10:03:02 +0000
commit2c0a632ba8f7b1c015de57f201a8cd0734c6273e (patch)
tree11c3ae8f6d74eaa5847a108611063e5bcec35c96 /mail/mini_sendmail
parentd32ebd314144b77e0e2580b8560830feb0ff4ba0 (diff)
downloadports-2c0a632ba8f7b1c015de57f201a8cd0734c6273e.tar.gz
ports-2c0a632ba8f7b1c015de57f201a8cd0734c6273e.zip
New port: mini_sendmail.
mini_sendmail reads its standard input up to an end-of-file and sends a copy of the message found there to all of the addresses listed. The message is sent by connecting to a local SMTP server. This means mini_sendmail can be used to send email from inside a chroot(2) area.
Notes
Notes: svn path=/head/; revision=84660
Diffstat (limited to 'mail/mini_sendmail')
-rw-r--r--mail/mini_sendmail/Makefile26
-rw-r--r--mail/mini_sendmail/distinfo1
-rw-r--r--mail/mini_sendmail/pkg-descr6
-rw-r--r--mail/mini_sendmail/pkg-plist1
4 files changed, 34 insertions, 0 deletions
diff --git a/mail/mini_sendmail/Makefile b/mail/mini_sendmail/Makefile
new file mode 100644
index 000000000000..4034944a5f33
--- /dev/null
+++ b/mail/mini_sendmail/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: mini_sendmail
+# Date created: 11 July 2003
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mini_sendmail
+PORTVERSION= 1.3.2
+CATEGORIES+= mail ipv6
+MASTER_SITES= http://www.acme.com/software/mini_sendmail/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Tiny MTA with only smart relay capability
+
+MAN8= mini_sendmail.8
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -static -o ${PORTNAME} ${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${MAN8PREFIX}/man/man8/
+
+.include <bsd.port.mk>
diff --git a/mail/mini_sendmail/distinfo b/mail/mini_sendmail/distinfo
new file mode 100644
index 000000000000..846a9261f76a
--- /dev/null
+++ b/mail/mini_sendmail/distinfo
@@ -0,0 +1 @@
+MD5 (mini_sendmail-1.3.2.tar.gz) = f705a89b0b9aeaf28dbffbedee4cb1d3
diff --git a/mail/mini_sendmail/pkg-descr b/mail/mini_sendmail/pkg-descr
new file mode 100644
index 000000000000..7980635160b3
--- /dev/null
+++ b/mail/mini_sendmail/pkg-descr
@@ -0,0 +1,6 @@
+mini_sendmail reads its standard input up to an end-of-file and sends
+a copy of the message found there to all of the addresses listed. The message
+is sent by connecting to a local SMTP server. This means mini_sendmail
+can be used to send email from inside a chroot(2) area.
+
+WWW: http://www.acme.com/software/mini_sendmail/
diff --git a/mail/mini_sendmail/pkg-plist b/mail/mini_sendmail/pkg-plist
new file mode 100644
index 000000000000..43487b0808d5
--- /dev/null
+++ b/mail/mini_sendmail/pkg-plist
@@ -0,0 +1 @@
+bin/mini_sendmail