aboutsummaryrefslogtreecommitdiff
path: root/mail/missey
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-02 06:03:01 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-02 06:03:01 +0000
commit4ae73c1b154c9e9043b794f16fd4e29f65b65a4f (patch)
tree6f6caf98d47de9afc29ee62fa027a2aeb1897057 /mail/missey
parent4b36aaaa37cf70e8156abee4f4246b69a7a34a74 (diff)
downloadports-4ae73c1b154c9e9043b794f16fd4e29f65b65a4f.tar.gz
ports-4ae73c1b154c9e9043b794f16fd4e29f65b65a4f.zip
Add missey 1.1.0, secure small and high performance POP3 server.
PR: ports/66113 Submitted by: delphij@FreeBSD.org.cn
Notes
Notes: svn path=/head/; revision=108135
Diffstat (limited to 'mail/missey')
-rw-r--r--mail/missey/Makefile27
-rw-r--r--mail/missey/distinfo2
-rw-r--r--mail/missey/files/Makefile27
-rw-r--r--mail/missey/pkg-descr9
-rw-r--r--mail/missey/pkg-plist4
5 files changed, 69 insertions, 0 deletions
diff --git a/mail/missey/Makefile b/mail/missey/Makefile
new file mode 100644
index 000000000000..acc2f0f2a9bf
--- /dev/null
+++ b/mail/missey/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: missey
+# Date created: 30 April 2004
+# Whom: delphij@FreeBSD.org.cn
+#
+# $FreeBSD$
+#
+
+PORTNAME= missey
+PORTVERSION= 1.1.0
+CATEGORIES= mail
+MASTER_SITES= http://snofe.dot66.net/missey/
+
+MAINTAINER= delphij@FreeBSD.org.cn
+COMMENT= Secure small and high performance POP3 server
+
+USE_BZIP2= yes
+
+WRKSRC= ${WRKDIR}/missey/src
+
+MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PREFIX="$(PREFIX)" INSTALL_PROGRAM="$(INSTALL_PROGRAM)" \
+ INSTALL_DATA="$(INSTALL_DATA)" MKDIR="$(MKDIR)" WRKSRC="$(WRKSRC)"
+
+post-patch:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/mail/missey/distinfo b/mail/missey/distinfo
new file mode 100644
index 000000000000..17f7cb57479c
--- /dev/null
+++ b/mail/missey/distinfo
@@ -0,0 +1,2 @@
+MD5 (missey-1.1.0.tar.bz2) = 668b845922a13c9cfbcae931702954b9
+SIZE (missey-1.1.0.tar.bz2) = 16687
diff --git a/mail/missey/files/Makefile b/mail/missey/files/Makefile
new file mode 100644
index 000000000000..b3b8d4a03bb2
--- /dev/null
+++ b/mail/missey/files/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+SRCS_M = main.c pop3d.c auth.c plcat.c mydaemon.c listen.c sig.c log.c conf.c checkip.c auth.h checkip.h conf.h const.h listen.h log.h mydaemon.h plcat.h pop3d.h sig.h
+SRCS_B = bent.c
+
+OBJS_M = ${SRCS_M:N*.h:R:S/$/.o/}
+OBJS_B = ${SRCS_B:N*.h:R:S/$/.o/}
+
+LDFLAGS += -lcrypt
+
+MISSEY ?= missey
+BENT ?= bent
+
+all: $(MISSEY) $(BENT)
+$(MISSEY): $(OBJS_M)
+ $(CC) $(CFLAGS) -o $(MISSEY) $(OBJS_M) $(LDFLAGS)
+$(BENT): $(OBJS_B)
+ $(CC) $(CFLAGS) ${PTHREAD_CFLAGS} -o $(BENT) $(SRCS_B) ${PTHREAD_LIBS}
+install:
+ @${MKDIR} -p $(PREFIX)/etc/missey/
+ ${INSTALL_DATA} $(WRKSRC)/pop3d.conf $(PREFIX)/etc/missey/pop3d.conf-dist
+ ${INSTALL_PROGRAM} $(WRKSRC)/$(MISSEY) $(PREFIX)/sbin/$(MISSEY)
+ ${INSTALL_PROGRAM} $(WRKSRC)/$(BENT) $(PREFIX)/sbin/$(BENT)
+
+clean :
+ rm -f *.o *.core core.* *~ *.s missey bent
+
diff --git a/mail/missey/pkg-descr b/mail/missey/pkg-descr
new file mode 100644
index 000000000000..25b77bfbf2f5
--- /dev/null
+++ b/mail/missey/pkg-descr
@@ -0,0 +1,9 @@
+Missey POP3 Server is a secure, small codes and high performance POP3 server.
+It's extremely fast and memory footprint is very low.
+
+Currently Missey supports system user (virtual user support will be added
+in the future) and Maildir format only.
+
+Source code released under a traditional 4-clause BSD License.
+
+WWW: http://snofe.dot66.net/missey/index.html
diff --git a/mail/missey/pkg-plist b/mail/missey/pkg-plist
new file mode 100644
index 000000000000..1b73d30a11b7
--- /dev/null
+++ b/mail/missey/pkg-plist
@@ -0,0 +1,4 @@
+etc/missey/pop3d.conf-dist
+sbin/bent
+sbin/missey
+@dirrm etc/missey