aboutsummaryrefslogtreecommitdiff
path: root/mail/mlmmj
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-01-22 08:06:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-01-22 08:06:39 +0000
commit29c2d6399d0a884c33e62d65db0f9dcc1835dc6e (patch)
treee5da580bd894a414f63120840e719172e63d3b84 /mail/mlmmj
parente2c1bce2a412a6dff0aabfa043065fc2537b0261 (diff)
downloadports-29c2d6399d0a884c33e62d65db0f9dcc1835dc6e.tar.gz
ports-29c2d6399d0a884c33e62d65db0f9dcc1835dc6e.zip
Fix build with recent compilers
Take maintainership
Notes
Notes: svn path=/head/; revision=562279
Diffstat (limited to 'mail/mlmmj')
-rw-r--r--mail/mlmmj/Makefile2
-rw-r--r--mail/mlmmj/files/patch-gcc1020
2 files changed, 21 insertions, 1 deletions
diff --git a/mail/mlmmj/Makefile b/mail/mlmmj/Makefile
index c815f0684c58..272ed65add10 100644
--- a/mail/mlmmj/Makefile
+++ b/mail/mlmmj/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 1.3.0
CATEGORIES= mail
MASTER_SITES= http://mlmmj.org/releases/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bapt@FreeBSD.org
COMMENT= Simple and slim mailing list manager
LICENSE= MIT
diff --git a/mail/mlmmj/files/patch-gcc10 b/mail/mlmmj/files/patch-gcc10
new file mode 100644
index 000000000000..847855d6a1d5
--- /dev/null
+++ b/mail/mlmmj/files/patch-gcc10
@@ -0,0 +1,20 @@
+--- include/mlmmj.h
++++ include/mlmmj.h
+@@ -81,7 +81,7 @@ enum subtype {
+ SUB_NONE /* For when an address is not subscribed at all */
+ };
+
+-char *subtype_strs[7]; /* count matches enum above; defined in subscriberfuncs.c */
++extern char *subtype_strs[7]; /* count matches enum above; defined in subscriberfuncs.c */
+
+ enum subreason {
+ SUB_REQUEST,
+@@ -92,7 +92,7 @@ enum subreason {
+ SUB_SWITCH
+ };
+
+-char * subreason_strs[6]; /* count matches enum above; defined in subscriberfuncs.c */
++extern char * subreason_strs[6]; /* count matches enum above; defined in subscriberfuncs.c */
+
+ void print_version(const char *prg);
+